Skip navigation

hwmond high cpu load after 10.6.8 update

18384 Views 101 Replies Latest reply: Aug 10, 2011 9:39 AM by random47 RSS
1 2 3 ... 7 Previous Next
arminhempel Calculating status...
Currently Being Moderated
Jun 24, 2011 7:36 AM

hwmond is causing up to 70% cpu load after every reboot on several xserves i manage caused by the update to 10.6.8. anybody else having this problem? it can be solved by hwmond -s5 to set the hwmond interval to 5 seconds but this command is not processed properly, is causing an error message "IOConnectMethodScalarIScalra0 call return err = 0xE00002BC" and has to be exited with cmd+c. Also, the com.apple.hwmond.plist in LaunchDaemons is empty.

  • InfraredAD Level 1 Level 1 (45 points)
    Currently Being Moderated
    Jun 24, 2011 8:15 AM (in response to arminhempel)

    Yes, I'm having the same exact problem. I have an '08 Xserve, dual-proc, quad-core, and it's taking up 95%, effectively one entire core.

     

    Since the 10.6.8 update it won't restart successfully either, I've had to restart it either via command line or the Apple Menu, then go over and hold the power button down to forcefully shut it off. I have not tried doing the final step via LOM yet.

     

    Edit: And just to drive the point home I tried restarting it (via methods mentioned above) and then let it sit for 4 hours unattended, it never restarted.

     

    Message was edited by: InfraredAD

  • ClassicII Level 3 Level 3 (830 points)
    Currently Being Moderated
    Jun 24, 2011 8:49 AM (in response to InfraredAD)

    10.6.8 yikes

  • andydvsn Calculating status...
    Currently Being Moderated
    Jun 24, 2011 8:51 AM (in response to InfraredAD)

    Same here on Xserve1,1. Bug reported.

     

    If you haven't reported the bug directly to Apple, please do so on http://bugreport.apple.com/.

  • Aaron Adams (.Mac) Calculating status...
    Currently Being Moderated
    Jun 24, 2011 10:41 AM (in response to andydvsn)

    I'm experiencing this problem with my Xserve as well, and I've filed a bug report.

  • Aaron Adams (.Mac) Level 1 Level 1 (55 points)
    Currently Being Moderated
    Jun 24, 2011 11:34 AM (in response to arminhempel)

    Didn't see anyone mention this, but you can stop hwmond from using all that CPU time by unloading it with launchctl:

     

    sudo launchctl unload /System/Library/LaunchDaemons/com.apple.hwmond.plist

     

    That will stop it until the next time your Xserve boots.

  • InfraredAD Level 1 Level 1 (45 points)
    Currently Being Moderated
    Jun 24, 2011 12:15 PM (in response to arminhempel)

    In my case:

     

    1. I installed 10.6.8 via the Combo Update, was running 10.6.7 previous to this.
    2. /System/Library/LaunchDaemons/com.apple.hwmond.plist still exists and is not empty
    3. /etc/hwmond.SMART still exists and is not empty
    4. /etc/hwmond.conf didn't exist, so from Terminal.app I simply issued "sudo touch /etc/hwmond.conf"

     

    I tried:

     

    1. In Terminal.app, ran:
      1. sudo launchctl unload /System/Library/LaunchDaemons/com.apple.hwmond.plist
    2. Then, backed up /usr/sbin/hwmond and /System/Library/LaunchDaemons/com.apple.hwmond.plist
    3. From a Mac Pro running 10.6.7 Server, copied both the binary and the plist to the same spots on the Xserve, then, in Terminal.app, ran:
      1. sudo launchctl load /System/Library/LaunchDaemons/com.apple.hwmond.plist
    4. That didn't change a thing. hwmond still spiked.
    5. Put everything back the way it was.

     

    And:

     

    1. In Terminal.app, ran:
      1. sudo launchctl unload /System/Library/LaunchDaemons/com.apple.hwmond.plist
    2. Backed up /System/Library/LaunchDaemons/com.apple.hwmond.plist
    3. Made another copy to the Desktop
    4. Edited this copy and added a string in ProgramArguments with a value of "-S255", but this still caused hwmond to spike after putting this copy back in LaunchDaemons, repairing permissions, and loading the plist via launchctl again.
      1. Any valid value still caused it to spike. However my Xserve now reboots if I set the value to an invalid value, like "-s256". Then again this also caused com.apple.hwmond and com.apple.launchd to create entries in the system log complaining about the value with hwmond attempting to relaunch itself every 10 seconds:

     

    6/24/11 2:37:10 PM com.apple.hwmond[2697] hwmond: n should be 1 to 255 seconds

    6/24/11 2:37:10 PM com.apple.launchd[1] (com.apple.hwmond[2697]) Exited with exit code: 1

    6/24/11 2:37:10 PM          com.apple.launchd[1] (com.apple.hwmond) Throttling respawn: Will start in 10 seconds


      1. OP, Armin, did something similar, but I think he tried doing it directly in Terminal, not using launchctl / launchd, which caused the error he mentioned.
    1. Finally, added a "Disabled" item, with a boolean value of YES to the plist, recopied it, repaired permissions again (launchctl will complain and won't load the plist if you don't). This way hwmond is disabled, I can reboot my Xserve, and wait until Apple figures this out.
    2. Full com.apple.hwmond.plist on my Xserve looks like this now:

     

    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">

    <dict>

              <key>Label</key>

              <string>com.apple.hwmond</string>

              <key>OnDemand</key>

              <false/>

              <key>Program</key>

              <string>/usr/sbin/hwmond</string>

              <key>ProgramArguments</key>

              <array>

                        <string>hwmond</string>

                        <string>-s255</string>

              </array>

              <key>ServiceIPC</key>

              <false/>

              <key>Disabled</key>

              <true/>

    </dict>

    </plist>

     

    Edit: I too have filed a bug report with a link to this thread included.

     

    Second Edit: Server Monitor.app still works after disabling hwmond via the plist even after a reboot.

     

    Third Edit: Sorry, keep remembering things, a modified /usr/sbin/hwmond was included the 10.6.8 Server Combo Update package, but not the Delta. Not sure if this matters. How has everyone updated to 10.6.8 so far? Like I mentioned, I used the Combo.

    Xserve, Mac OS X (10.6.7)
  • InfraredAD Level 1 Level 1 (45 points)
    Currently Being Moderated
    Jun 24, 2011 1:18 PM (in response to InfraredAD)

    The downside to disabling hwmond is it's not available to periodically report on the hardware, nor does it provide feedback to the front fascia LEDs on the Xserve (not including the ADM ones). LEDs I can live without, reporting, not so much. I'll probably end up rebuilding in a few days if there's no official fix for this. And I'll use the delta updater provided through ASU.

  • qmp Calculating status...
    Currently Being Moderated
    Jun 24, 2011 1:49 PM (in response to arminhempel)

    Yep. Same here.

    I too installed the combo update.

    Dös this problem only occur when installing the combo?

  • Aaron Adams (.Mac) Level 1 Level 1 (55 points)
    Currently Being Moderated
    Jun 24, 2011 1:52 PM (in response to qmp)

    I installed from Software Update and I have the problem.

  • qurt Calculating status...
    Currently Being Moderated
    Jun 24, 2011 2:04 PM (in response to arminhempel)

    +1

    combo update

  • InfraredAD Level 1 Level 1 (45 points)
    Currently Being Moderated
    Jun 24, 2011 2:38 PM (in response to Aaron Adams (.Mac))

    Were you running 10.6.7 Server prior to running the update?

  • Daniel Ball Level 2 Level 2 (225 points)
    Currently Being Moderated
    Jun 25, 2011 4:02 AM (in response to InfraredAD)

    Hate to spoil the assuption its the combo update........but I was running 10.6.7 and ran software update on my two servers and installed 10.6.8.  So I most likely installed the delta update.

     

    Having the same issue with the process and filed a bug report as well.  Hopefully they get this fixed quickly!

  • Ziatron Level 4 Level 4 (3,255 points)
    Currently Being Moderated
    Jun 25, 2011 12:51 PM (in response to Daniel Ball)

    All fixed for me.

     

    just use Time Machine, I was back to 10.6.7  in 2 minutes.

1 2 3 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (16)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.