Previous 1 2 3 4 Next 58 Replies Latest reply: Jan 19, 2014 10:56 AM by camouk
David MacVicar Level 1 Level 1 (30 points)

My iMac worked flawlessly for 3 years.  Today after upgrading to 10.6.8 my iMac WILL NOT stay connected to my wireless network.  It will drop every 2-3 minutes.  The computer has never once done this before....I can only conclude that 10.6.8 is the culprit


iMac, Mac OS X (10.6.7)
  • umma08 Level 1 Level 1 (0 points)

    when i first got my Laptop with 10.6 i had this exact same issue. it got fixed when i managed to get the update to 10.6.2, which at the time was the newest version. to get this, i had to use another computer to download the combo update, then transfer it via usb key - it fixed the problem immediately. i would suggest - and some others are suggesting that you try installing the 10.6.8 combo update - as that may fix any airport issues.

     

    i, myslef had a problem with 10.6.8, which i have never had before. my computer now does not sleep - well i think that is the issue - when i closed the lid of the laptop - with no aplications or programs running - the apple light went off, and the sleep light at the front of the laptop came on - but when i returned i found the computer hot!

     

    and the battery completely dead and all my network preferences reset!

  • polycorpmedia Level 1 Level 1 (0 points)

    @David: I have the same here. My MBP (i7) worked fine untill the upgrade I did yesterday evening. Now connection is dropping. Did you find a solution yet?

     

    Thanks, Harmen

  • dgsg Level 1 Level 1 (0 points)

    I have the same problem. Has anyone come up with a solution to this issue yet?

  • polycorpmedia Level 1 Level 1 (0 points)

    My temporary solution is an ethernet cable.

     

    So far I haven't experienced an advantage in the 10.6.8 update, only this major DISadvantage.

     

    Getting rather annoyed...

  • moseslsy Level 1 Level 1 (0 points)

    I am facing the same issue too with my 27" iMac but interestingly, not with my MBA 13" (mid 2010).  It's very irritating as my router is too far away for me to use wired ethernet. I hope apple fixes this soon

  • umma08 Level 1 Level 1 (0 points)

    here is the combo update

     

    http://support.apple.com/kb/DL1399

     

    you could try that.......it is 1.09GB and if you can only connect on wireless, obviousy, that won't work with a dropping connection.

     

    You can download it via another computer and the install on your mac. alternatively you can connect by ethernet cable to your router.

     

    i found the isue with mine is was iAntiVirus which was causing the issue (i think) it was not recognising the sleep and was still running a full hard drive scan. didnt seem to like 10.6.8 at all. have since deleted it and installed the Sophos Anti Virus (check App Store) which on first scan found 13 Java threats in cache!

     

    all for Windows - but still they were on my machine!

  • moseslsy Level 1 Level 1 (0 points)

    thanks umma08.  I actually tried the combo update (used my MBA to download it and transferred it via USB to my iMac) but my WIFI still drops although less frequently now. I notice that it occurs especially after the iMac enters sleep mode and is reawaken.

  • Shawn Grinter 2 Level 3 Level 3 (950 points)

    Hi M,

     

    I had exactly the same issue - although triggered by a previous system update. I used iStumbler to track the Airport connection and discovered the card in the MBP would intermittently just stop transmitting. I presume the offending update had shortened the time-out value so it was now more apparent.

     

    Anyway to cut a long story short a visit to an Applestore and one new Airport card later and it was sorted,.

     

    Regards,

    Shawn

  • polycorpmedia Level 1 Level 1 (0 points)

    Thanks Umma08!

     

    Installing the combo update (yes, on top of an already updated 10.6.8) seems to have done the trick for me, as far as I can tell right now...

     

    Weird! (But hey, I'm not complaining)

  • waharris007 Level 1 Level 1 (0 points)

    Same here. I installed 10.6.8 on my 11" Air and suddenly, my entire WiFi network was down. I can't even get a connection on my iPhone. I now have 10.6.8 on my Air and iMac, and Airport is broken on both. I installed the combo on my iMac and had no change. This is SO annoying. Seriously, Apple?

     

    Anyone have any luck getting their connections back? Is it just an Airport-to-Mac issue, or are your iPhones, iPods and iPads messed up, as well? I can't believe an OS update messed my Airport Extreme up so bad that NO devices will work.

  • ds store Level 7 Level 7 (30,315 points)

    After the 10.6.8 update the Airport file permissions were possibly not returned to their original state.

     

    Open Disk Utility in the Utilities folder, select your boot drive and Repair Permissions, enter the admin password if necessary.

     

    Log into a admin account and run Software Update so Airport gets updated. Also toggle your System Prefrences > Secuirty > General > "Auto-update safe downloads list" on and then off.

     

    After that download and run ALL the cleaning and maintenance aspects of the free OnyX and reboot.

     

    http://www.titanium.free.fr/

     

    And then use OnyX > Verify > Preferences (check the box for show only corrupted ones) and write down all the corrupted .plist files.

     

    Use the free Easy Find to seek and Trash those .plists (or move them to the desktop) and reboot. They will get automatically rebuilt (minus your preferences of course which you need to reset.)

     

    http://www.devon-technologies.com/download/index.html

  • waharris007 Level 1 Level 1 (0 points)

    Geez, that's a lot to have to do to fix a crummy OS update. I'm honestly not super confident in doing all that. Plus, how could this have messed up the actual Airport Extreme hardware? I'm shocked that even my i-devices and my wife's Windows laptop can't even get online. Any thoughts on that?

  • dougfromflorida Level 1 Level 1 (0 points)

    I have a 24"  iMac w/10.6.7. Upgraded to 10.6.8 yesterday and couldn't get the Mac into my WiFi network. The Mac could "see" the network, but when I tried to join, the network was locked and my password was no longer recognized! My iPad continued to work flawlessly on the network. I reloaded 10.6.0 from the disk (my Wi-Fi network working fine), then tried upgrading to 10.6.8 with their "combo" upgrade package: same results. I'm now back to 10.6.0 (Wi-Fi back to okay), hoping that Apple will come up with another upgrade version soon. Shouldn't be this difficult.

  • umma08 Level 1 Level 1 (0 points)

    yeah the combo update seems to clear things up - haven't the foggiest why, i just saw from another thread. i havent had the need to do the combi updat yet.....my issue was with iAntiVirus, so i uninstalled and installed Sophos Anti Virus - problems seem to have been sorted. weird by Apple to drop the ball.....

     

    oh and with Apple support - i always find waiting till the afternoon and then calling the IS tech support much better - they seem to know a bit more out there - as getting on to a tech support person that knows $£*& all is soooooo frustrating!

Previous 1 2 3 4 Next