Previous 1 2 3 4 Next 58 Replies Latest reply: Jan 19, 2014 10:56 AM by camouk Go to original post
  • Fahad from Fremont Level 1 (0 points)


    I had the same issue ... Please try to change the router security settings, it worked for me. I initially had it on WPA personal... and removed it to make it unsecured.. the signal strength on my Mac jumped up right away. Then I replaced the same WPA settings I had before, and my signal stayed the same (meaning issue was resolved). Maybe after downloading the update, the old settings were not being transmitted correctly... I dont know but its resolved


    Hope that helps. Thanks harikris

  • Bungan Level 1 (0 points)

    Hi Steve

    Thanks for the tips - and Harikris too. Through a combination of the two I THINK I have finally sorted it out. disabling security settings and then re-enabling them cleaned up the mess (so far!!)

    thanks for the suggestion of iStumbler too - now I have a more realistic reading of the signal strength than Airports misleading one. I now have to convince my wife to move the freezer that is humming away between me and the router.....

  • grasmith Level 1 (0 points)

    I tried most things on this forum, without success. In the end, removing the network from the preferred network list solved the problem for me too.

  • Bungan Level 1 (0 points)


    I havent had any problems again. All back to normal speeds - which is good as I was about to put a brick through the iMac screen. I have a funny feeling that Apple must obviously scan these pages and try to fix bugs - as issues seem to mysteriously fix themselves over time.

    Hope you stay bug free.

  • brightond Level 1 (0 points)

    Same problem as others.  UPdated to 10.6.8 and lost wireless capability.  Luckily I had ethernet available.

    I went into the networ prferences....deleted my wireless network...turned of airport.  waited 30 seconds and turned airport back on.  all seems to be working fine now.

  • m_r_nadh Level 1 (0 points)

    Helloo Brightond,


    Does the connection stays good after reboot?

    In my case, after the bootup it connects to WiFi but that is a fake connection. Meaning it doesnt connect to internet, ping to router fails. All i need to do is turn the adapter off and on then it is good to go.


    The same problem exists in Apple's latest and greatest OS (Mountain Lion) too. It made my Mac slow and because these annoying connection problems i switched to snow leaopard but here also connection problems exists


    SnowLeopard atleast better in speed/multi tasking.




  • Serafinatoyou Level 1 (0 points)

    Lost my connection 2 weeks ago. Still cannot get it back. I can connect right beside the modem but as soon as I walk a few feet away I lose my connect. I have scoured the net and tried everything.


    Is there a fix for this yet?

  • Iceberg_Slim Level 1 (0 points)

    It certainly DID help - you're a Legend in the making!

  • thedingbat Level 1 (0 points)

    Well after many hours spent researching this problem, I finally fixed it. Like you all, after updating an old mac from 10.5.8 to 10.6.3 (and then .8 as part of my attempts at a solution) my airport was basically dead. I could only load google and even that was slow and only possible sometimes.


    Anyway, for the longest time I assumed it was some sort of setting I needed to change on my computer--after all, that was what had changed. I did briefly fiddle with the wireless settings but everything was as recommended so I didn't spend too much time there.


    What finally worked for me was resetting my **** router settings. Why I didn't think to do this before is beyond me--it is so simple.

    The problem, I think, was the router channel. I noticed that the Region field in the router settings was set to "Europe" which apparently corresponds to a different set of frequencies. Also, in the system profiler, I saw that some channels (specifically 12-14) were not supported by my airport card (while I think it is standard in Europe to use those channels). My router would not let me change the region manually but resetting all settings to factory default took care of that (I think I could have manually assigned a channel too).


    Very glad to be done with that. I feel like such a fool to have neglected to try such an obvious solution from the start, but I'm glad it's over. By the way, I'm referring to the router settings accessible on the router management portal accessible by typing or some other IP address into your address (I don't know what that IP corresponds to cause I think that that's the same for all Netgear routers or something). Anyway, good luck with your problems!


    More generally, I would suggest to just look through all your router settings and make sure nothing is amiss. If you don't care about preserving your settings I would go straight for the hard reset.

  • HarpuaNineteen Level 1 (0 points)

    Thanks for all this info guys!  Did the combo update, then the SMC reset, then the PRAM reset.  Reset the airport and it was smooth sailing from there.



  • Michael Rath Level 1 (5 points)

    I have an iMac and as originally running a LAN through its built in Airport. After I upgraed to 10.6.8 my Airport insisted on assigning itself an IP address. I did everything listed through all four pages of this thread and after two hours was about to give it up. However...


    I don't know why, but I tried setting the IP address manualy to within the range my router had set up  - - and vvoila! I have WiFi back and am running my MacBook Pro, iPhone and iPad just fine!


    Give that a try and let me know if it works for other machines/configurations.



  • brollyjohn Level 1 (0 points)

    Yes in the end the 10.6.8 upgrade was the culprit.


    The internet comes and goes. At it's worst, I have to pull the ethernet out and plug back in constantly. If I'm lucky, I'll have internet for hours at a time without problem. But as I write this my internet will probably black out.


    Over 2 years later and still no answer to this dilemma. The longer this issue goes unresolved, I realize that Apple wants my $19 and force me to upgrade to Mountain Lion.


    It's a great way to get people off Snow Leopard and onto the IOS version of OS X, Mountain Lion.


    Shame on you apple for this mess. I'm seriously thinking about another option after this long enduring mess.


    FYI everyone:


    Deleting the alf.plist file IS NOT the solution. Unless deleting it every 10 minutes is a solution to you.

  • Paul Sabo Level 1 (5 points)

    Having the same issue with 10.6.8 on my 2008 Macbook Pro 17". Really bad wifi connection with my home time capsule after the upgrade. Works great at work and the Apple Store (of course).  My 2010 Macbook with 10.6.8 already installed from the store has no issues. 


    Wonder if the Mavericks OS upgrade (free) would be worth the trouble?

  • camouk Level 1 (0 points)

    I have the same problem after the 10.6.8 update.No wifi connection to my home router.....stuck with having to use an ethernet cable.

    Apple really need to sort this out!

Previous 1 2 3 4 Next