Previous 1 2 Next 17 Replies Latest reply: Jul 10, 2011 9:26 AM by gregory186
mi5key Level 1 Level 1 (0 points)

I've installed 10.6.8 via Software Update and the Macbook Pro will not boot, causes a kernel panic.  It will boot in Safe Boot however.  I've tried installing the combo update as well, no change.  Verify disk permissions, no change.  Help!

 

panic(cpu 2 caller 0x2abf6a): Kernel trap at 0x0029f24f, type 14=page fault, registers:

CR0: 0x8001003b, CR2: 0x7aae9000, CR3: 0x00100000, CR4: 0x00000660

EAX: 0x7a6fe06c, EBX: 0xec835381, ECX: 0xfcf7b1e9, EDX: 0x7aae8ffd

CR2: 0x7aae9000, EBP: 0x820ebd18, ESI: 0x00000000, EDI: 0xec835381

EFL: 0x00010202, EIP: 0x0029f24f, CS:  0x00000008, DS:  0x00000010

Error code: 0x00000002

 

Backtrace (CPU 2), Frame : Return Address (4 potential args on stack)

0x820ebb18 : 0x21b837 (0x5dd7fc 0x820ebb4c 0x223ce1 0x0)

0x820ebb68 : 0x2abf6a (0x59e3d0 0x29f24f 0xe 0x59e59a)

0x820ebc48 : 0x2a1a78 (0x820ebc60 0x0 0x820ebd18 0x29f24f)

0x820ebc58 : 0x29f24f (0xe 0x20650048 0x820e0010 0x2a0010)

0x820ebd18 : 0x8255448f (0xfcf7b1e9 0xec835381 0xfcf7b1e9 0xec835381)

0x820ebd58 : 0x82556ef9 (0x588ffd 0x81fcf7b6 0x8255bab0 0x53c996)

0x820ebe18 : 0x543f60 (0xc654100 0xbefdf00 0x1 0x506b76)

0x820ebe78 : 0x542137 (0xbefdf00 0xc654100 0x5e5209 0x1)

0x820ebf28 : 0x5426e9 (0xbefdf00 0xc5873c0 0x0 0x516766)

0x820ebf78 : 0x5443d5 (0xbefdf00 0x0 0x820ebfac 0x1)

0x820ebfc8 : 0x2a179c (0xc61ff90 0x0 0x2a17ab 0xc467000)

      Kernel Extensions in backtrace (with dependencies):

         com.metakine.handsoff.driver(1.2.4)@0x82551000->0x8255ffff

 

BSD process name corresponding to current thread: kernel_task

 

Mac OS version:

Not yet set

 

Kernel version:

Darwin Kernel Version 10.8.0: Tue Jun  7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386

System model name: MacBookPro6,1 (Mac-F22589C8)

 

System uptime in nanoseconds: 1576987135

unloaded kexts:

(none)

loaded kexts:

com.metakine.handsoff.driver    1.2.4

com.apple.driver.MaxTranserSizeOverrideDriver    2.6.1 - last loaded 1338933558

com.apple.driver.AppleUSBTCKeyEventDriver    201.6

com.apple.driver.AppleUSBTCKeyboard    201.6

com.apple.iokit.SCSITaskUserClient    2.6.8

com.apple.BootCache    31.1

com.apple.AppleFSCompression.AppleFSCompressionTypeZlib    1.0.0d1

com.apple.iokit.IOAHCIBlockStorage    1.6.4

com.apple.driver.AppleFWOHCI    4.7.3

com.apple.driver.AppleSmartBatteryManager    160.0.0

com.apple.driver.AppleUSBHub    4.2.4

com.apple.driver.AppleEFINVRAM    1.4.0

com.apple.driver.AppleAHCIPort    2.1.7

com.apple.driver.AppleUSBEHCI    4.2.4

com.apple.driver.AppleUSBUHCI    4.2.0

com.apple.driver.AppleACPIButtons    1.3.6

com.apple.driver.AppleRTC    1.3.1

com.apple.driver.AppleHPET    1.5

com.apple.driver.AppleSMBIOS    1.7

com.apple.driver.AppleACPIEC    1.3.6

com.apple.driver.AppleAPIC    1.4

com.apple.driver.AppleIntelCPUPowerManagementClient    142.6.0

com.apple.security.sandbox    1

com.apple.security.quarantine    0

com.apple.nke.applicationfirewall    2.1.12

com.apple.driver.AppleIntelCPUPowerManagement    142.6.0

com.apple.iokit.IOSCSIBlockCommandsDevice    2.6.8

com.apple.iokit.IOUSBMassStorageClass    2.6.7

com.apple.driver.AppleUSBMultitouch    207.7

com.apple.iokit.IOUSBHIDDriver    4.2.0

com.apple.iokit.IOSCSIMultimediaCommandsDevice    2.6.8

com.apple.iokit.IOBDStorageFamily    1.6

com.apple.iokit.IODVDStorageFamily    1.6

com.apple.iokit.IOCDStorageFamily    1.6.1

com.apple.driver.AppleUSBMergeNub    4.2.4

com.apple.driver.AppleUSBComposite    3.9.0

com.apple.driver.XsanFilter    402.1

com.apple.iokit.IOAHCISerialATAPI    1.2.6

com.apple.iokit.IOSCSIArchitectureModelFamily    2.6.8

com.apple.driver.AppleFileSystemDriver    2.0

com.apple.iokit.IOFireWireFamily    4.2.6

com.apple.iokit.IOUSBUserClient    4.2.4

com.apple.iokit.IOAHCIFamily    2.0.6

com.apple.iokit.IOUSBFamily    4.2.4

com.apple.driver.AppleEFIRuntime    1.4.0

com.apple.iokit.IOHIDFamily    1.6.6

com.apple.iokit.IOSMBusFamily    1.1

com.apple.security.TMSafetyNet    6

com.apple.kext.AppleMatch    1.0.0d1

com.apple.driver.DiskImages    289.1

com.apple.iokit.IOStorageFamily    1.6.3

com.apple.driver.AppleACPIPlatform    1.3.6

com.apple.iokit.IOPCIFamily    2.6.5

com.apple.iokit.IOACPIFamily    1.3.0


Mac Pro, Mac OS X (10.6.7), 10.6.8
  • Kappy Level 10 Level 10 (255,715 points)

    Uninstall the Metakine software then do the following:

     

    Repair the Hard Drive and Permissions

     

    Boot from your Snow Leopard Installer disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Utilities menu. After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list.  In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive.  If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the installer.

     

    If DU reports errors it cannot fix, then you will need Disk Warrior and/or Tech Tool Pro to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.


    Quit the installer and restart. Now download the Mac OS X 10.6.8 Update Combo and update.

  • ds store Level 7 Level 7 (30,310 points)

    mi5key wrote:

     

    com.metakine.handsoff.driver    1.2.4

     

     

    MetaKine issues with 10.6.8


    MetaKine hands off,  update to 1.3.1 before attempting an install of 10.6.8: the old version causes a kernel panic and will not allow booting after an update.  As it loads a kernel extension, safemode also doesn't work.

     

    Simple solution: boot OSX install DVD, run terminal from utilities menu:

     

    code, enter and press return

    cd /Volumes/yournormalbootdisk/System/Library/Extensions

     

    mv HandsOff.kext /

     

    quit Terminal and reboot

     

    Then load Hands off app, and run the update it finds.

  • mi5key Level 1 Level 1 (0 points)

    That did it, thanks!

  • jeromefromaa Level 1 Level 1 (0 points)

    I was able to boot in safe mode. Move the HandsOff.kext to root as described using

    sudo mv HandsOff.kext /

    and entering password a the prompt.

    Restarted computer and it booted fine

     

    About this Mac says I'm now running 10.6.8 - goiing trust that it is.

    Handsoff launched and asked to update - it updated fine too from what I could tell. I'm seriously wondering if Handsoff is really all the worth its trouble. Lot of work approving access for any new apps and sites. And now this kernal panic that certainly made me PANIC.

     

    Thanks for the advice and fix.

  • LtDave928 Level 1 Level 1 (0 points)

    My MacPro also refuses to boot after the 10.6.8 update.  All I get is a grey screen.  One time I let it sit for 20 min or so and eventually I got the flashing folder with question mark.

    I'm not using Hands Off, but have the latest version of Little Snitch installed.

    I managed to get the CD drive to open and inserted the Snow Leopard DVD, but nothing seems to work.  Holding down the "c" key and trying to boot into safe mode go nowhere.

    Any ideas?

  • mi5key Level 1 Level 1 (0 points)

    Try holding down the shift key to get into Safe Boot, that worked for me.

  • LtDave928 Level 1 Level 1 (0 points)

    Machine doesn't respond to keystrokes, just sits there with a blank grey screen.

  • John Landi Level 1 Level 1 (135 points)

    When you say, "run the HandsOff update" where do you get that from? Thanks

  • John Landi Level 1 Level 1 (135 points)

    I've tried this but all I get is an error message saying "no such file or directory" I must be doing something wrong. When I start from the Utilities menu, I just go to Terminal and it brings up a blank page with -bash- 3.2# on it. Am I starting in the wrong place? Thanks

  • EPPFILM Level 1 Level 1 (0 points)

    I'm not using HansdOff! any other suggestions. I am able to boot in safe mode.

  • gregory186 Level 1 Level 1 (0 points)

    Same here -- not using HandsOff and my macBookPro6,2 will not start now. I reset PRAM, etc. but it just gives me

     

    panic(cpu 2 caller 0x2abf6a): Kernel trap at 0x002e3388, type 14=page fault registers:

    ...

     

    BSD process name corresponding to current thread: launchd

  • Bluebirdk7 Level 1 Level 1 (0 points)

    Yup hands off is the clash.  Boot in safe boot mode by restarting whilst holding the shift key down. start hands off...uninstall it and restart your mac. then download the new version of Hands off and re-install.

  • jpgoldberg Level 1 Level 1 (15 points)

    I'm in the same boat. I am not using HandsOff. Any suggestions would be very welcome.

     

    Cheers,

     

    -j

  • AussieDJ Level 4 Level 4 (1,435 points)

    N1 ds_store.

Previous 1 2 Next