3 Replies Latest reply: Jun 25, 2011 6:22 AM by El Duderino
funkosauras Level 1 Level 1 (0 points)

Ok, geniuses, someone help a brother out!!

 

Using compressor 4, it won't let me cancel a job.  I have done the usual, and even the extreme:

 

1.  Trashed the var/spool compressor subfolder, this doesn't seem to be where compressor 4 stores its temp stuff anymore.

2.  Done the 'reset background processing' thing with 'reset and cancel all jobs'

3.  Uninstalled every aspect of FInal Cut Studio AND FCP pro X / Compressor 4 / Motion etc...

 

The only thing I haven't done is reformat my computer, which I can't do just yet (mid project on some other stuff).

 

So, does anyone know where Compressor 4 stores its files so I can wipe it clean?

 

Thanks!

  • El Duderino Level 1 Level 1 (15 points)

    Hi,

     

    you will find all the settings and history in

    /Users/[youruser]/Library/Application Support/Apple Qmaster

     

    A good thing to do is to quit Compressor before making changes in this folder, then use Activity Monitor and (if it's still running) kill the "CompressorJobController" process (which will also quit all other related CompressorX and qmaster processes). Then you can just delete the contents of the History folder in the location above.

     

    Good luck.

  • funkosauras Level 1 Level 1 (0 points)

    Tried, that, it seemed to work at first but now no jobs will go through.  So if I submit a new job, it gets stuck in the 'waiting' phase for what seems like indefinitely (activity monitor shows no cpu or disk activity and I've left it for 2 hours now).  Not loving the upgrade so far!!!

  • El Duderino Level 1 Level 1 (15 points)

    Do you use the cluster functionality? When i tested with different cluster settings, i ran into the same problem, that every job would get stuck. This didn't happen in a non-cluster environment. If you don't use a cluster, i would suggest to turn off Apple Qmaster Sharing at all. If you do, the problem might be, that your cluster is setup incorrectly because it cannot find any services to render your jobs and sits there forever.

     

    If you want to start from scratch and reset Compressor to its defaults, then you might try to delete the "Apple Qmaster" folder at /Users/[yourusername]/Library/Application Support/ and remove the preferences as well (see /Users/[yourusername]/Library/Preferences/com.apple.compressor... note: there are two files!). But make sure, that no Compressor/Qmaster related service is running. You should kill those processes using Activity Monitor or just restart your machine before deleting the files mentioned above.

     

    Additionally, you might want to check the contents of /Users/[yourusername]/Library/Application Support/Compressor/History/ and remove any file there as well.