1 2 3 Previous Next 171 Replies Latest reply: Apr 7, 2013 1:12 PM by Yank7
Silkroad Level 1 Level 1 (15 points)

In looking closely at cookies accepted "only from sites I visit" I noticed that it actually includes a lot of third-party cookies, so I keep Preferences set to Never unless I'm accessing a site that must accept them (for example, New York Times).  However, in the last few days something has changed (I don't know what that is), and now all cookies are accepted even though I have Preferences set to Never.  Seems like this change coincides with the latest Safari update from a couple of days back.  Is there anything I can do to stop it accepting any and every cookie?  Thanks.


iMac, Mac OS X (10.6.7)
  • 2. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    Ernest Padilla Level 1 Level 1 (5 points)

    Hi Carolyn,

    I'm having the same problem as the OP and followed your advice to install

    Safari Cookies Manager. It didn't seem to make a difference

    In addition to accepting cookies, Safari is now allowing sites to store

    databases on my computer even though I have that option disabled.

    This just started with the last update.

    Any ideas how it might be solved?

    Thanks in advance for your help! 

  • 3. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    Silkroad Level 1 Level 1 (15 points)

    Hi Ernest,

    Can you elaborate a little about the databases you claim are being stored on your computer?  I've never heard of such a thing until now.  Because I used to do Security for a big IT company, I'm always watchful for news like this.  Thanks.

  • 4. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    James Shea1 Level 1 Level 1 (75 points)

    The same problem exists with Safari 5.0.5 on my Mac Pro that is running OS 10.6.8. Safari Preferences are set to never accept cookies -- but web site cookies are saved on the local drive nonetheless.

     

    When I attempted to reinstall Safari 5.0.5, an error message appeared that states, "Safari can't be installed on this disk. This update requires Mac OS X 10.6.7."

  • 5. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    richardfromgreenvale Level 1 Level 1 (0 points)

    - happened to both my 2010 and 2011 macbook pros. i updated the second one to test if 10.6.8 was the culprit and surely enough it accepted all cookies directly after the 10.6.8 update.

    it also would occasionally delete my address and search window from toolbar when i entered a search and i would have to then go to "Customize Toolbar" to put it back up there.

    Called apple and reported the problem on 6/25 and they said they hadn't heard anything.

  • 6. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    Stephen Creswell Level 1 Level 1 (15 points)

    I'm also experiencing the same accumulation of cookies in Safari even though I have my "accept cookies" preference set to "never".

    I'm currently running 10.6.8 (Safari 5.0.5) but not sure when this behaviour started ... it hasn't always been like this though.

    However, I have a temporary work around which is to leave my "accept cookies" preference as "never" and enable "private browsing".  This appears to prevent the accumulation of cookies and indeed prevented me from logging into the Apple Discussions Forums to make this post ... I can however log in if simply turn off "private browsing" (and rely on the fact that my "never" accept cookies preference is redundant, doh!).

  • 7. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    seventy one Level 6 Level 6 (8,990 points)

    I find Safari cookies quite useful but it should be noted that the database element is a recent innovation and the content can be removed as easily as the unwanted cookies.    All the same, it isn't the most efficient of apps and when I clear cookies etc I find it best to quit Safari immediately afterwards..  This tends to prevent old cookies reappearing.

  • 8. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    karinfromroswell Level 1 Level 1 (0 points)

    I have the same problem now--it's definitely a new bug.  It's handling the cookies as if I had selected to allow cookies from the site I visited, but I have "never" selected.  I can't duplicate the database problem though.  For instance, I just looked at a twitter site, and it didn't override my database selection to allow no storage.

  • 9. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    Silkroad Level 1 Level 1 (15 points)

    I also noticed that sometimes deleted cookies reappear, so I close Safari after deleting them, then reload it.  Don't know how to  override database selection to allow no storage.  Is that something new?

  • 10. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    richardfromgreenvale Level 1 Level 1 (0 points)

    the oddest thing is that the ONLY site that doesn't allow to you enter while cookies are set to "Never" is ME.COM...

    if you don't have your cookies on it won't let you even get to the login page....  (me.com is email service from apple)

    hmmm......

  • 11. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    Zebra Storm Level 1 Level 1 (5 points)

    Silkroad,

     

    I just installed 10.6.8 and have the same issue. It appears 10.6.8 broke Safari. I hate cookies, and always have Safari set to "never". If ad companies want to pay me to track my web use, that's one thing, but I'm certainly not going to let them do it for free! I'm quite frustrated this slipped through Apple's QA, and hopefully they will fix this soon. In the meantime, FireFox works fine. I normally use Safari for general browsing, and FireFox for the occaisonal site I need cookies for (and I have FireFox set to clear all information upon closing). If you do banking online, you certainly don't want cookies laying around on your machine. Unrelated, it's important to delete Flash cookies, which most people don't do. These are buried in user/library/preferences/macromedia

     

    You need to lock the "#SharedObjects" folder (press command+I on the folder and click "lock"). Then also click throguh the "macromedia.com" folder to "sys" and lock that folder. A few sites will require you to unlock the "#SharedObjects" folder to play their flash video, but most don't require this. I dropped the Flash folder in my "places" section so I can quickly access it when needed. Flash is evil stuff, no getting around it.

     

    It would be nice if our web browsers could block Flash cookies as well. At any rate, Apple should fix this Safari cookie issue ASAP!

  • 12. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    richardfromgreenvale Level 1 Level 1 (0 points)

    i wonder why ME.COM is the only site that doesn't allow you in unless you enable cookies.  i don't understand how they are the only website that can bypass the glitch... the company that made the update...

    it's just too suspicious.

  • 13. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    Silkroad Level 1 Level 1 (15 points)

    Actually, ME.COM is not the only website that doesn't allow you in unless you enable cookies -- I'm sorry, but that statement is just wrong.  In fact, most of my banking sites won't let me in until I enable cookies.  When I tried enabling cookies while invoking Private Browsing on a couple of them, those sites then required me to re-register my computer before I could go any further.  So, sorry to burst your bubble, but it's not suspicious, it's not a conspiracy, and Apple doesn't have any nefarious plans up its sleeve on this.

     

    I used to lead application software development for a large company, and discovering we'd inadvertently broken something with our latest update was pretty much par for the course.  We never intended it, it's just that the code for big apps like Safari can run many thousands of lines, and finding every place where there might be a conflict is almost impossible.  So you go live with the new version and cringe waiting for users to howl over something that's now broken, then you fix it.

     

    Apple will fix it, I'm sure they're working on it now.  In fact, I usually post to these discussion groups to be sure new glitches will show up on their radar.

     

    Just set your cookies to Never, invoke Private Browsing, and give it a little time.  Next Safari update will fix it.

  • 14. Re: Cookies set to "Never" but Safari now accepts all cookies anyway
    richardfromgreenvale Level 1 Level 1 (0 points)

    sorry silkwood, not living in a bubble - just going off your original post "...Safari now accepts all cookies anyway" Yes, very aware of when you invoke "Private Browsing" and "Never" it behaves just like 10.6.7.

    But i don't personally know of any other sites aside from me.com whereas if you just have "never" clicked and have not invoked "Private Browsing" that it doesn't allow you in. 

    But again, just going off your subject line. 

     

1 2 3 Previous Next