2 Replies Latest reply: Jul 7, 2011 7:47 AM by cudaboy_71
cudaboy_71 Level 1 (135 points)

Just upgraded my tired 3G to a verizon iphone 4. everything backed up and transferred just fine except......


my gmail account won't accept the password on 3G.


that is to say, if i'm in my house on wifi, gmail checks/sends just fine. as soon as i walk out/disable wifi and am on verizon 3G only, the gmail password won't auth. I get a "The user name or password for 'address@gmail.com' is incorrect."


i've tried changing my password (via my computer) and re-trying on the phone. i've tried deleting the account on the phone and re-setting it up. results are the same.


here's the kicker: i upgraded my wife's 2G iPhone at the same time to the same model verizon iPhone 4. she has two gmail accounts that were imported via the same backup/restore function in itunes. they both work fine on 3G or wifi.


any ideas at all what's going on?

  • jnasmith Level 1 (0 points)

    I am having the exact same issue... did you ever find a work around?

  • cudaboy_71 Level 1 (135 points)

    for me it came down to a rogue smtp server. in my case, my desktop machine uses the gmail smtp servers to sent outgoing mail from my comcast account because comcast's has always been flaky for me. when the phone synced, it brought over all of those settings/servers. not sure why, but, re-entering the smtp password in the smtp server for the comcast account--on the phone-- fixed the issue with gmail checking even though gmail had its own smtp server with the correct password.


    as an aside, i don't think i'd tried sending mail from the comcast account from the phone, as gmail is set up as my default account. had i done so, i might have been able to troubleshoot this faster.


    hope that's clear as mud. good luck.