8 Replies Latest reply: Aug 5, 2012 3:08 AM by TigerKR
TigerKR Level 1 Level 1 (30 points)

Hello all,

 

I was updating amavisd using the wonderful instructions over at <http://downloads.topicdesk.com/docs/Updating_amavisd_new_on_OS_X_Server_10_5_Leo pard.pdf>

 

I've done this update, and others like it a bunch of times over the years. However, this time I'm having a problem.

 

When I type:

 

#: /usr/bin/amavisd -V

 

I get this error message:

 

fetch_modules: error loading required module Compress/Zlib.pm:

  Compress::Raw::Zlib version 2.037 required--this is only version 2.033 at /Library/Perl/Updates/5.10.0/darwin-thread-multi-2level/Compress/Zlib.pm line 11.

  BEGIN failed--compilation aborted at /Library/Perl/Updates/5.10.0/darwin-thread-multi-2level/Compress/Zlib.pm line 11.

  Compilation failed in require at /usr/bin/amavisd line 197.

ERROR: MISSING REQUIRED BASIC MODULES:

  Compress::Zlib

BEGIN failed--compilation aborted at /usr/bin/amavisd line 237.

 

So I tried to update that module:

 

# perl -MCPAN -e shell

cpan[1]> install Compress::Zlib

 

I get this message:

 

CPAN: Storable loaded ok (v2.25)

Going to read '/Users/kroberts/.cpan/Metadata'

  Database was generated on Sun, 26 Jun 2011 06:27:18 GMT

CPAN: Module::CoreList loaded ok (v2.51)

Compress::Zlib is up to date (2.037).

 

Looks good right?

 

so I run:

 

cpan[2]> install Compress::Raw::Zlib

 

I get this message:

 

[snip]

lipo: can't open input file: /var/tmp//ccWqTs15.out (No such file or directory)

make: *** [Zlib.o] Error 2

  PMQS/Compress-Raw-Zlib-2.037.tar.gz

  /usr/bin/make -- NOT OK

Running make test

  Can't test without successful make

Running make install

  Make had returned bad status, install seems impossible

Failed during this command:

PMQS/Compress-Raw-Zlib-2.037.tar.gz          : make NO

 

I've tried to force install but it makes no difference.


Mac OS X Server 10.6.8
  • TigerKR Level 1 Level 1 (30 points)

    So I downloaded, compiled, and installed a fresh version of Perl. Now I've got new problems.

     

    --------------------------------

     

    bash-3.2# cd Mail-SpamAssassin-3.3.2

    bash-3.2# sudo perl Makefile.PL

    What email address or URL should be used in the suspected-spam report

    text for users who want more information on your filter installation?

    (In particular, ISPs should change this to a local Postmaster contact)

    default text: [the administrator of that system] postmaster@xxxxxxx.com

     

     

    NOTE: settings for "make test" are now controlled using "t/config.dist".

    See that file if you wish to customise what tests are run, and how.

     

     

    checking module dependencies and their versions...

     

     

    ***************************************************************************

    NOTE: the optional Razor2 module is not installed,

    minimum required version is 2.61.

     

     

      Used to check message signatures against Vipul's Razor collaborative

      filtering network. Razor has a large number of dependencies on CPAN

      modules. Feel free to skip installing it, if this makes you nervous;

      SpamAssassin will still work well without it.

     

     

      More info on installing and using Razor can be found

      at http://wiki.apache.org/spamassassin/InstallingRazor .

     

     

    dyld: lazy symbol binding failed: Symbol not found: _SSL_load_error_strings

      Referenced from: /usr/local/lib/perl5/site_perl/5.14.1/darwin-2level/auto/Net/SSLeay/SSLeay.bund le

      Expected in: dynamic lookup

     

     

    dyld: Symbol not found: _SSL_load_error_strings

      Referenced from: /usr/local/lib/perl5/site_perl/5.14.1/darwin-2level/auto/Net/SSLeay/SSLeay.bund le

      Expected in: dynamic lookup

     

     

    Trace/BPT trap

     

    --------------------------------

     

    same error I get when I run lint.

     

    bash-3.2# sudo -H -u _amavisd /usr/local/bin/spamassassin --lint

    dyld: lazy symbol binding failed: Symbol not found: _SSL_load_error_strings

      Referenced from: /usr/local/lib/perl5/site_perl/5.14.1/darwin-2level/auto/Net/SSLeay/SSLeay.bund le

      Expected in: dynamic lookup

     

     

    dyld: Symbol not found: _SSL_load_error_strings

      Referenced from: /usr/local/lib/perl5/site_perl/5.14.1/darwin-2level/auto/Net/SSLeay/SSLeay.bund le

      Expected in: dynamic lookup

     

     

    Trace/BPT trap

  • TigerKR Level 1 Level 1 (30 points)

    and the system log is spamming this message:

     

    Jun 26 07:24:24 xxxxxxxx org.amavis.amavisd[819]: Problem in Amavis::DB or Amavis::DB::SNMP code: Can't locate BerkeleyDB.pm in @INC (@INC contains: /usr/local/lib/perl5/site_perl/5.14.1/darwin-2level /usr/local/lib/perl5/site_perl/5.14.1 /usr/local/lib/perl5/5.14.1/darwin-2level /usr/local/lib/perl5/5.14.1) at (eval 67) line 19.

    Jun 26 07:24:24 xxxxxxxx org.amavis.amavisd[819]: BEGIN failed--compilation aborted at (eval 67) line 19.

    Jun 26 07:24:24 xxxxxxxx com.apple.launchd[1] (org.amavis.amavisd[819]): Exited with exit code: 2

    Jun 26 07:24:24 xxxxxxxx com.apple.launchd[1] (org.amavis.amavisd): Throttling respawn: Will start in 10 seconds

  • TigerKR Level 1 Level 1 (30 points)

    Ok, I just downloaded, compiled, and installed BerkleyDB:

     

    <http://www.linuxfromscratch.org/blfs/view/svn/server/db.html>

     

    and that didn't help.

  • TigerKR Level 1 Level 1 (30 points)

    Downloading and installing the 10.6.8 Server Combo Update didn't help.

  • TigerKR Level 1 Level 1 (30 points)

    I ended up restoring from a time machine backup. I'm not feeling like upgrading my software again right now.

     

    Currently, I'm running 10.6.8 server, amavis-new-2.6.4 (is anyone running 2.6.6?), spamassassin 3.2.5 (is anyone running 3.3.2?), perl 5.10.0 (anyone running 5.14.1?), clamav 0.97.1, squirrelmail 1.4.21, php 5.3.4 (is anyone running 5.3.6?).

     

    I'm not sure what caused the problem. Maybe a perl module? Maybe amavis-new-2.6.6?

  • TigerKR Level 1 Level 1 (30 points)

    I also updated to Xcode 4.0.2. Too many updates at once I guess.

  • TigerKR Level 1 Level 1 (30 points)

    I'm trying to update SpamAssassin and I'm getting the same error.

     

    I've installed perl 5.14.1 and I need to reinstall SpamAssassin. Can anyone help me please?

  • TigerKR Level 1 Level 1 (30 points)

    If anyone cares, I ended up deleting the CPAN stuff and installing macports. Somehow I have a working system. More or less.