6 Replies Latest reply: Jul 28, 2012 7:20 PM by saig15
prankz Level 1 Level 1 (0 points)

My iPhone 4 camera is not working. When i try to put on the camera the shutter appears and the screen gets stuck on closed shutter.

Can i ask for a replacement ?

Please help ... Thanks in advance...


Hp, Windows Vista
  • John Guo Level 5 Level 5 (5,265 points)

    I would do a reset. Press and hold the Sleep/Wake button until the Apple logo appears (ignore the option to turn off the device).

  • prankz Level 1 Level 1 (0 points)

    Yes i did that but still its stuck in closed shutter.

    Can i get a replacement ? I am afraid that the iPhone that i am using is already a replacement one.

    I had got a replacement in December 2010 due to a cracked screen.

    Thanks for the reply ... Cheerss ...

  • John Guo Level 5 Level 5 (5,265 points)

    Try a restore too before you bring it back to the store. Plug your iPhone in your computer. Go to the iPhone preferences and press the Restore button (backup your device first).

  • nikolaifromsankt-petersburg Level 1 Level 1 (0 points)

    Problem with Iphone 4.  I am  bought in Elisa Imatra 09.10.2010. camera does not work. Do not open gate. He did just reset as described above and a full reset iPhone to the state as a "new". did not help.

    And sometimes it does not sound have not worked. Neither the phone call, no the iPod, no ringtones. Turn off the sound, even if theiPhone is without movement.

    Microphone does not work, I can not talk on the phone.
    It happens two or three times a day or more. Only helps to restart the iPhone.

    How can I use the warranty Apple and exchange it for a new one?

    with respect, Nikolai P.

  • nikolaifromsankt-petersburg Level 1 Level 1 (0 points)

    Elisa took the phone in for repair, where to buy in Finland. . Five days is not the result. how long to wait for an answer?

    What does this warranty Apple?

  • saig15 Level 1 Level 1 (0 points)

    I took apart my iphone 4 and cleaned the camera and other parts. Turned it off and on works perfectly now. Loose connection I think. And I'm only 16.