13 Replies Latest reply: Dec 3, 2012 3:24 PM by GFXZen
grbrum Level 1 Level 1 (0 points)

Hello, I am new with motion and I have an issue I could not find a result in the forums.

 

I have taken a video of my backyard and I want to have the trash can on fire for learning purpose.

So I tracked the trash can and it worked fine, I applied the particle emitter to the trash can and added the match move behavior.

So, the fire is coming out of the trash can ok, no problem there.

 

The problem is that it is not realistic as the fire is moving around with the camera (not the base of the fire, this is sticking to the trash can, but as the fire and smoke goes up, instead of going vertically up, it swings right and left as the camera moves).

 

Can anyone help me with this?

 

Thank you.


MacBook Pro, Mac OS X (10.6.7)
  • Robert Kleindienst1 Level 1 Level 1 (130 points)

    It sounds like you are applying the motion tracker to the group....which includes the generator and particles. You need to apply the tracker to just the generator.

  • grbrum Level 1 Level 1 (0 points)

    Thank you Robert, this was helpful.

    Do you mind explaining a little further how I get to the particle generator?

     

    My project is very simple. I have the movie layer, and the fire layer (emitter).

    The fire group has 2 items, but none is a generator.

     

    I see I can add some kind of generator, but there are about 20 different types (Caustic, Cellular, etc).

    Which should I add and where?

     

    All help is appreciated.

     

    thanks

  • Robert Kleindienst1 Level 1 Level 1 (130 points)

    Sorry, when I said 'generator', I meant 'emitter'. In the fire grouup there should be an emitter, and that is what you want to apply the motion tracking to.

  • grbrum Level 1 Level 1 (0 points)

    Hello Robert, I think I did exactly that. See image below:

     

    Screen shot 2011-06-27 at 9.40.32 PM.png

     

    Also, I apologize for the mess in my kitchen, haha. This is the effect I do not want to happen:

     

    Screen shot 2011-06-27 at 9.43.36 PM.png

     

    I want the fire to go up, not follow the camera movement.

     

    Thanks.

  • Robert Kleindienst1 Level 1 Level 1 (130 points)

    I don't have Motion 5, but fundamentally they process isn't different than any other version.

     

    Everything looks ok in your setup, but it's hard to judge from a still frame. Any way to see a clip of what you are getting?

  • Robert Kleindienst1 Level 1 Level 1 (130 points)

    OK, here's what is happening:

    If you open up the inspector on the particle emitter, you should see that the emission direction is "up" and the angle should be fairly small -- but the problem is that the emitter is moving around the screen so quickly from the motion track, and the particles are moving so slowly when they are born from the emitter -- that they are appearing to move in an opposite direction from the way the emitter is moving on screen and not traveling upward all that much.

     

    If you punch up the speed of the particles it should overcome the movement of the emitter and limit their movement to a mostly 'upward' direction and look better. (also, increase the birth rate as needed)

  • grbrum Level 1 Level 1 (0 points)

    Robert, you are right, the speed and birth rate reduced the fire dance. but not by much.

    I raised both to over 400%... and still very noticeable movement.

     

    It is like the emitter is being tracked but the direction of the particles are not.

     

    It is unnatural

    do you have any other idea?

     

    thanks

     

    Screen shot 2011-06-28 at 12.16.48 AM.png

  • Robert Kleindienst1 Level 1 Level 1 (130 points)

    Try this:

     

    Go to frame 1 and create a new shape. Doensn't really matter what the shape is or how big it is.

    Move the shape offscreen, above the stove and give it the same Match Move behavior that the particle emitter has so that it moves around the scene in the exact same manner as the emitter, but all offscreen.

    Turn the visibility of this shape off, but give it an Attractor behavior and set the Attractor to affect the particles emitted only.

     

    So no matter how the stove and emitter moves in the scene, the shape with the attractor behavior will always be directly above it offscreen and the particles should always travel in a more-or-less straight line, relative to the location of the stove.

  • GFXZen Level 4 Level 4 (1,455 points)

    If you want to keep it really simple, you could just export a movie of the fire.  I'd set up the fire towards the bottom so you have plenty of room if your camera tilts down.  Make sure to use format with an alpha channel,  something like ProRes 4444.  Re-import the movie and then use the match move behavior. It would give you exactly what you want and be much easier and less complex than playing with the speed or using the Attractor.

  • PowerPhill Level 1 Level 1 (15 points)

    Hi, I'm having the exact same problem. It seems very odd to me that Apple would make this seemingly simple thing to turn off very difficult. Your fix seems to be a very simple work around, but there must be another way of doing this without going through this step. I remember fixing this issue with Motion 3, but I don't remember how to do it, or if it's even possible. I'll keep messing around and let you know what I come up with.

  • revelever Level 1 Level 1 (0 points)

    anyone ever figure this out?  I am having a similar issue

  • GFXZen Level 4 Level 4 (1,455 points)

    I had totally forgotten about this post.  Someone, I can't remember who, reminded me that you can use the "Attach to Emitter" setting in the particle emmiter to prevent the particles from streaming out and following the camera.  Just set it to 100%.