4 Replies Latest reply: Oct 29, 2011 7:01 AM by lupunus
paulfromhere Level 1 Level 1 (0 points)

Newbie in osx, but experienced in linux.

 

My new imac has 3 printers setup for sharing, but ipad 2 / iphone 4 fail to see them.  I am using the belkin router that I owned already, instead of buying an Airport.

 

I found a solution at askubuntu.com Q 26130 at http://askubuntu.com/questions/26130/how-can-share-my-printer-so-that-i-can-use- it-with-airprint

 

I setup a linux machine on the network, with no physical connection to any printer. The 1st, an hp fax psc has a usb to imac, as the 2nd, an hp psc, the 3rd printer is an epson wireless, which is only connected on the network by wifi to the belkin router. I'm certain the imac "sharing" is properly setup, because the linux machine has no trouble finding the printers.  Only the ipad / iphone have a problem.

 

Once I put the linux machine (with the above changes) on the network, everything works as desired.  I can print on the ipad / iphone to any of the 3 printers, using the built in Airport printer routine (not the epson or hp apps). And the imax and linux machines can also print on all 3.

 

So, I suspect the imac isn't telling the router to display the printers on the network in a way that iOS can see them. I know it would work if I owned an Airport, but I'd rather not spend that much right now.

 

I'm sure someone knowledgable in OSX might have an idea where to stick an Airport definition file, created from the python script in askubuntu, that could solve this without having to run the linux laptop all the time.  Any ideas?

 

TIA


iMac, Mac OS X (10.6.8)
  • paulfromhere Level 1 Level 1 (0 points)

    It's possible to use free software (Virtualbox and Ubuntu) to fix the broken iOS 5 Airprint printing with non supported printers.  Here's a fix that works on my imac, but should also work on even a windows pc.

     

    My setup is a lion imac with 2 non-airprint supported usb printers attached, a belkin wifi router that provides network connectivity for my imac, ipad, and iphone.

     

    Install ubuntu 11.10 in a virtualbox vm.  Specify to use the "Bridged Adapter" with "en1: WiFi (AirPort)" for the network hardware.  Make sure the imac's usb printers are setup with sharing.  On ubuntu, select System Settings > Printers and add your imac's shared printers to the list.  Then start ubuntu's firefox and set "localhost:631" in the address. On the administration tab, under the Server section, check "Share printers connected to this system" and hit Change Settings button to activate it.  Go back to ubuntu's printer setup, and right click on each printer and check that the properties Policies tab does not have any messages about it being unshared. If so, then go back to firefox and make sure the Server sharing checkbox is enabled. It may help to reboot.

     

    Fire up virtualbox to be able to use AirPort printing to your imac's usb printers, when you want to print from the iphone or ipad. This also works on iOS 5.

     

    Only problem is error message from iphone to check the printer for errors, even though it actually prints ok.

     

  • lupunus Level 3 Level 3 (995 points)

    paulfromhere wrote:

     

    Newbie in osx, but experienced in linux.

     

    My new imac has 3 printers setup for sharing, but ipad 2 / iphone 4 fail to see them.

    Airprint is bound to Airprint capable printers only. These are available from the major printer manufacturers since Oct. 2010.

     

    Nevertheless there is a way to use that function with older printers too.

    You have to enable "Printer sharing" in the Sharing section of the system settings on your Mac and in the printer settings too.

    screen-capture-9.png

    Then you need Airprint Activator for the Mac:

    http://netputing.com/2011/09/05/airprint-activator-v2-1b1/

     

    After starting the application and set it active, the printer should show up in the Airprinter Section on the iPad.

     

    Unfortunately there is a little bitter pill, as your Mac have to be active for printing unless you buy a Airprint capable printer.

     

     

    Lupunus

  • paulfromhere Level 1 Level 1 (0 points)

    Thanks, I heard of netputing before, but also had heard that it got broken by upgrading to iOS 5 ( http://netputing.com/2011/09/05/airprint-activator-v2-1b1/#disqus_thread ).  The way I fixed it by running ubuntu in a virtualbox works even with iOS 5.  However, it takes the time to download and install them to get it working. But, at least it gave me a reason to learn about running a virtual machine and running linux on your mac.

     

    regards,

  • lupunus Level 3 Level 3 (995 points)

    paulfromhere wrote:

     

    But, at least it gave me a reason to learn about running a virtual machine and running linux on your mac.

    I run a actual Ubuntu and a Ubuntu 10.4 LTE server with Fusion and is really fast and smooth on the MBPro. Even some applications outruns the OS X equivalent applications performance.

     

    Lupunus