11 Replies Latest reply: Jan 27, 2013 3:12 AM by jujubeads1973
KoreanSasquatch Level 1 Level 1 (0 points)

I have a 6th generation ipod. When I try to eject it, itunes crashes. I have tried to restore my ipod to it's factory settings, but when I do this, itunes crashes. What can I do?


iPod nano, Mac OS X (10.6.8)
  • Hoggleton Level 1 Level 1 (0 points)

    I have the same problem with my iPod Classic. My iPhone 4 and iPad 2 are both fine when I eject them. It's just my iPod Classic. When I eject it iTunes crashes and in Finder my iPod is all greyed out. I have to remove my iPod from my dock, then I have to Force Quit iTunes and then relaunch Finder to get everything back to Normal.

     

    I too have treid to restore my iPod. It downloaded the software and then it seems to be thinking about restoring it, then 10 minutes later nothing's happened and iTunes has stopped responding so I have to Force quit it again!

     

    I thought it was something to do with the itunes 10.4 update? or Lion perhaps, but I can see you've been using Snow Leopard. For me the problems all started from when I updated iTunes and OSX to Lion.

  • KoreanSasquatch Level 1 Level 1 (0 points)

    That's exactly what happens with my iPod as well. I have absolutely no problems with my iPhone 4, however. Just with my iPod nano 6th gen.

    The problem started for me when I installed an update for iTunes. I have since upgraded to Lion, hoping that it was an issue with Snow Leopard, but the problem still persists.

    It's very, very annoying.

  • Hoggleton Level 1 Level 1 (0 points)

    I've tried to find a solution, short of almost reinstalling Lion. I think it must be the iTunes update then. It's not like in Windows you uninstall iTunes and use a previous version and install it. Trying to find other people with the same problem... urgh... Darn these people who just use their iPhone for music. I'll start rooting around, see if a hard reset will get the thing to work again. If I get any closer to solving it, I'll update it on here!

  • Carolyn Samit Level 10 Level 10 (100,390 points)
  • Hoggleton Level 1 Level 1 (0 points)

    Cheers but that's not the issue.

  • Hoggleton Level 1 Level 1 (0 points)

    Hey buddy,

     

    I don't know how far you got with your problem. But in the end I had so many problems with Lion and iTunes. I backed up all my stuff using time machine. Did a full format and reinstalled Lion. My problem has now gone. It'll take a day or two to fully get you back to where you are depending on applicatiosn and your data.

     

    Another thing I had enabled was Disk Useage on my Classic. I unchecked that in itunes too after the rebuild and I didn't have any other problems too.

     

    I'm not sure what the problem was, but I encountered unexpected Finder freezes and I needed a rebuild.

     

    Hope this is of some help. Good Luck if you haven't solved the problem yet.

     

    It seems as though you and I were the only one havcing this problem.

  • KoreanSasquatch Level 1 Level 1 (0 points)

    Thanks.

    I still have problems with iTunes. Only with my Nano though. The other issue I now have is that my mac will not shut off when I select Shut Down from the Apple menu. I have to press the power button to turn it off.

    Perhaps it would be a good idea if I did a full format as well. Now I just have to get a bigger EHD to back my stuff up on to.

    Strange that we were the only two people having this problem.

    Anyway, I'll give your suggestion a try. Thanks!

  • d.walker.de Level 1 Level 1 (0 points)

    I found a solution that worked for me; I have Iphone4 and after Itunes update of 10.4.? itunes would no longer sync my photos, so after reading a few post and researching online I have found that when I unistalled ALL components of Itunes (anything in my add/remove program list with Apple's name) then I downloaded Itunes 10.1 and installed it. There was one error when it was done and it had to do with the library.itl file that I found on my computer and deleted! Since then I have had NO problems at all! I hope this helps some of you!

     

    Dave

     

    <Link Edited by Host>

  • KoreanSasquatch Level 1 Level 1 (0 points)

    Hope this helps someone else.

    I've done a clean reinstall. Then, after I reinstalled all of my software, the problem with my iPod started again.

    Also, my OS slowed right down and started crashing.

    I uninstalled Kaspersky and ever since I have not had a single problem. There must be some kind of conflict. I'm not knowledgeable enough about programming to diagnose exactly what the problem is, but ever since I've unistalled it I've had no issues with my iPod nor with OSX.

    I started using ClamXav and so far, have not encountered any problems.

  • sun.it Level 1 Level 1 (0 points)

    iPod nano 5G

     

    For me, Kaspersky was ist - the Kaspersky from Parallels Desktop.

    Just uninstall ist and reboot.

    I also disable Disk usage, than sync, enable it again, sync again.

     

    Now fine working

  • jujubeads1973 Level 1 Level 1 (0 points)

    The "not shutting down or rebooting" issue is usually caused by a peripheral device connected to the computer.  I had the same problem and realized it was my Microsoft wireless mouse.  When I "Shut Down", "re-start", etc. I just unplug the USB mouse receiver before-hand and I never have a problem.... I know this thread is pretty old, but I thought maybe it might help!