Previous 1 2 3 Next 107 Replies Latest reply: Apr 12, 2012 7:32 AM by Pondini Branched to a new discussion.
TomRadfahrer Level 1 (5 points)

In short: A backup of 2 Mbytes takes more than half an hour


Long version

I used Time Machine with my old iMac and of course I am using it with my new iMac (SSD + 2 TB). The Backup destination is an external FireWire drive with 2 TB, the same I used with the old iMac.


The first backup took some time (more than 700 GB), but this is normal, I assume. Now I have problems with the "small" delta backups. Just one example from the console output:


27.06.11 17:56:20[8775]          Starting standard backup

27.06.11 17:56:20[8775]          Backing up to: /Volumes/Archiv 1/Backups.backupdb

27.06.11 17:57:56[8775]          No pre-backup thinning needed: 855.7 MB requested (including padding), 883.02 GB available

27.06.11 18:06:31[8775]          Copied 226532 files (1.8 MB) from volume Speedy HD.

27.06.11 18:06:50[8775]          Copied 226781 files (1.8 MB) from volume Speedy Medien.

27.06.11 18:09:48[8775]          No pre-backup thinning needed: 871.3 MB requested (including padding), 882.92 GB available

27.06.11 18:17:59[8775]          Copied 178604 files (236 KB) from volume Speedy HD.

27.06.11 18:18:19[8775]          Copied 178853 files (236 KB) from volume Speedy Medien.

27.06.11 18:24:55[8775]          Starting post-backup thinning

27.06.11 18:33:17[8775]          Deleted backup /Volumes/Archiv 1/Backups.backupdb/Speedy/2011-06-26-171728: 883.00 GB now available

27.06.11 18:33:17[8775]          Post-back up thinning complete: 1 expired backups removed

27.06.11 18:33:18[8775]          Backup completed successfully.


As you can see from the log there is no single error message or warning but the backup of about 2 MBytes took 37 Minutes !! And this happens every hour. Most time of the day my iMac is backing up!! If I add some content to my iMac, (e.g. the backup of a new TV show with 3 GBytes) the backup is as fast as expected (at least the copy phase of Time Machine). Nevertheless every backup has a long preparation and a long cleanup phase. During these ridiculous long phases the activity of the external FireWire drive is very high, I hear the head of the drive positioning all the time.


I checked all discs with disk utility, repaired all rights, rebooted the iMac and switched the external drive off and on.


The backup source consists of the SSD and the HDD of my iMac. For the HDD I disable access rights management to share an iPhoto library easily between multiple users in our family.

iMac, Mac OS X (10.6.8), iMac mid 2011
  • John Kitchen Level 3 (645 points)

    In case you haven't found it, Pondini's website is a super resource on Time Machine.


    Try this page -

  • TomRadfahrer Level 1 (5 points)

    Yes, this website contains helpful information in general, but in my special case I found no help. I followed the hint to disable spotlight for the backup HDD, but it doesn't help.


    Has anybody an idea?

  • John Kitchen Level 3 (645 points)

    Did you do the Repair step recommended?

  • TomRadfahrer Level 1 (5 points)

    Hi John,

    thank you for helping me. Yes, I did the repair step for all drives (backup sources and backup destination).


    I assume, that my problem is very rare. There must happened something very special in my configuration. I decided to re-format my FireWire backup destination and start Time Machine from scratch. The first backup runs at the moment with a speed between 70 and 80 MBytes/s. This is pretty fast and seems to be the limit of my FireWire800 drive. I will come back tomorrow and will report, if the problem still exists or not.

  • John Kitchen Level 3 (645 points)

    Coincidentally, I had a similar problem with TM never getting past the Cleanup phase.  So I took the opportunity to expand the TM partition, since I could see problems of capacity looming there. 


    I figured I'd do a repair after the expansion.


    Well, that was not a great idea.  The result was an empty partition with a system-generated name, even though Disk Utility assured me it would do what I wanted.


    So I too am running a full TM backup overnight, and hope this clears my performance issue.  To be sure, I'll be doing a repair after the backup completes!

  • MaBi Level 1 (0 points)

    Got the very same issue (see my own post) and it annoys me quite a bit! I'll call Apple for help, after all, I am still within my 90 days of free support. I ll post any solution they might suggest!

  • TomRadfahrer Level 1 (5 points)

    Hi MaBi,

    verey interesting: Same hardware, same problem. Did you made use of Setup Assistant or Migration Assistant? I used Setup Assistant and maybe this assistant corrupted my boot partition in a way which disturbs TM.


    Yesterday I reformatted my FireWire HDD and re-started TM. No success, the delta backups take much too long.


    Hi John Kitchen,

    is your problem related also to an SSD ?

  • John Kitchen Level 3 (645 points)

    I'm using TM to backup both internal SSD and internal HDD.


    Looks like my problem went away with the new backup, but has come back again.


    Now I'm doing a verify on my TM disk, but it's taking forever.  Over 1 TB


    Then I plan to do a verify on both the SSD and the internal HDD (when booted from an external)

  • TomRadfahrer Level 1 (5 points)

    there seems to be a general scheme: new iMac + SSD + Time Machine = Problem

  • John Kitchen Level 3 (645 points)

    Did a repair on the SSD and internal HDD while booted from an external drive, and there were no problems found.  There was one permission issue that was fixed.


    Now back to booted from the SSD and running TM.


    I will keep an eye on it, and if it plays up, I'll be calling Apple for help.  Backup is too important to fail.

  • MaBi Level 1 (0 points)

    I have already repaired internal SSD, internal HDD and external HDD (was nothing to repair anyways), but didnt help the problem. I have now disabeled Spotlight on the TM volume and also checked the cable connection (Firewire) to my external HDD.... nothing (plus I can copy huge files to that HD with absolutely normal speed, so no problem with the FW connection). I m totally lost...

  • TomRadfahrer Level 1 (5 points)

    Hi John Kitchen, hi MaBi,


    I booted from DVD and repaired the boot volume, but there was nothing to repair. I did a repair of permissions, and there was a single file with permission errors. Disk Utility reported, that it had fixed the problem, but a 2nd repair of permissions showed the same file with the same permission errors.


    There is a single file "/private/.../launchd" which cannot be repaired. You both seem to have the same problem. Maybe this is related to the Time Machine problem, or it is a completely independent effect.


    I will try to chat with the Apple support.

  • psendeavor Level 1 (10 points)

    Well guys, I have exactly the same problem with a new 27" iMac SSD+2GB HDD: fast initial back up, very very slow incremental back up (often >30 minutes, for just a few kb's !?!). Even cleaning up takes ages.


    I didn't use migration assistant, nor set-up assistant.


    It's not an SSD problem with OS 10.6.8, my MBA works fine with TM, but we don't seem to be the only ones to be stuck with incredibly slow TM backups on a new SSD-HDD iMac...


    Oh, and repairing permissions, reinstalling, reformatting the target drive, etc doesn't work.

  • TomRadfahrer Level 1 (5 points)

    60 seconds !!! 



    I solved it!


    What I did:

    I interrupted a running incremental backup after 20 minutes by switching off Time Machine in the control panel. In the log the message was:


         Stopping backupd to allow ejection of backup destination disk!


    Then I rebooted the iMac from the Snow Leopard DVD and repaired the SSD and the FireWire Drive. In both cases no failures could be found.


    Then I restarted the iMac from its internal SSD and waited until Time Machine started again (after one hour). Now there was something new in the log:


                  Event store UUIDs don't match for volume: Speedy HD

                  Node requires deep traversal:/ reason:must scan subdirs|new event db|


    This backup took just 12 Minutes and was much faster than the previous incremental backups which took 30..45 minutes.


    Now I tried the ultimate thing: I ordered Time Machine to make a new incremental backup. See what happens:


    30.06.11 21:10:23 Starting standard backup

    30.06.11 21:10:23  Backing up to: /Volumes/Archiv 1/Backups.backupdb

    30.06.11 21:10:32  No pre-backup thinning needed: 1.83 GB requested (including padding), 911.84 GB available

    30.06.11 21:11:03  Copied 9117 files (647.1 MB) from volume Speedy HD.

    30.06.11 21:11:08  Copied 9365 files (647.1 MB) from volume Speedy Medien.

    30.06.11 21:11:10  No pre-backup thinning needed: 1.08 GB requested (including padding), 911.18 GB available

    30.06.11 21:11:15  Copied 2811 files (1 KB) from volume Speedy HD.

    30.06.11 21:11:18  Copied 3059 files (1 KB) from volume Speedy Medien.

    30.06.11 21:11:22  Starting post-backup thinning

    30.06.11 21:11:22  No post-back up thinning needed: no expired backups exist

    30.06.11 21:11:23  Backup completed successfully.


    I don't know what made the difference and I do not know how long Time Machine behaves well from now on. But I hope, that the problem is solved.

Previous 1 2 3 Next