Previous 1 3 4 5 6 7 Next 439 Replies Latest reply: Aug 1, 2015 3:02 PM by YouSuckiCloud Go to original post
  • Will_i_am247 Level 1 Level 1 (0 points)

    Like others have said, you can turn off EVERYTHING in the iCloud account settings then click delete account. Then setup your iCloud again using your apple ID then turn on mail again and type new email.

     

    Or if you want to make an email alias go to icloud.com/mail (on the computer only. Not i device) then click alias and. Create your alias

  • s102587 Level 1 Level 1 (0 points)

    You change it through itunes store - it automatically changes icloud's email as well;

     

    -click on itunes store

     

    -the email address in the right hand corner has a drop down arrow, click on that and then click on account

     

    -underneath "Apple ID Summary" you will see your information, including your email addresss.There is an edit button on the right side. click on that change your email and or password and continue.

     

    to double check go to icloud.com and log in with the new email address you changed it to.

     

    It worked for me

  • stellafromhaywards heath Level 1 Level 1 (0 points)

    This is the perfect solution.

    People trying to change the cloud account address need to realize that this is just a link to a server to save your device contentu..  The address is part of your iTunes identity and the email address therefore has to be correct in iTunes and linked with your apple ID. The devices will automatically have this address as your default cloud address.

    That is why an incorrect cloud address cannot be changed, but the incorrect cloud account must be deleted to sever the link to the cloud server.

  • jamesfromridgeland Level 1 Level 1 (0 points)

    Yes Matts solution does work (Iphone 4). If you already have another apple id, follow Matts instructions and when you delete the accout select keep on Iphone, log back in and your new apple id should appear.

  • jamesfromridgeland Level 1 Level 1 (0 points)

    Thanks Matt it worked fine

  • Incuplex Level 1 Level 1 (0 points)

    I got bored reading all 5 pages of responses, so my solution might already be posted.  I started by going into iTunes and changing my email.  That was easy.  Then, on my computer I simply went to System Preferences (NOT iCloud), then Users & Groups under System, then clicked "Change" by the Apple ID (you'll need to use your computer password rather than your Apple ID password), then deleted my existing Apple ID and added my new one.  I can't remember if I had to make the same change on my iPhone or if it automatically changed the id, but it was easy either way.

     

    Let me know if this works for others.

  • williamimac Level 1 Level 1 (0 points)

    Just to clarify... people are not trying to change the email address associated with their apple ID. They are trying to change the "@me.com" email address they originally were asked to create when setting up their iCloud mail. I for one, do not want to change the email address attached to my apple ID. I want to keep it the same. When I set up iCloud though, I wasn't sure what I was creating with the "@me.com" extension and so I put in random letters. I'm now stuck with that as my default "@me.com" email address and have to creat aliases. It appears that when I send emails (from my phone or my iMac or my macbook) that go via the iCloud email address, no matter what alias I send them from they are still coming from the original "@me.com" and not from the alias.

     

    If anyone knows how to change your "@me.com" email address once it's been created WITHOUT changing your appleID, that's the real question here...

     

    Thanks,

     

    Bill

  • shewdawg Level 1 Level 1 (0 points)

    Thanks, Bill, for getting this back on track. Maybe a new thread regarding the original intent is warranted.

  • cristianfrombucuresti Level 1 Level 1 (0 points)

    EXACTLY!
    Please do not forget to post back, if a solution really exists!

    Thanks!

     

    And I thought the migration to iCloud was going to be simple... which it was.. but the settings on the iPhone... So please Apple, make that field editable!!!

  • cristianfrombucuresti Level 1 Level 1 (0 points)

    hehe! Found a simple solution: when configuring iCloud on the iPhone, at the Account field, instead of the Apple ID, I wrote the @me.com email address that I wanted to use. And that's it.

     

    So you have to delete your iCloud account from the iPhone, select to keep the information on phone, or whatever, then create it back with the @me.com email you want to use.

     

    Also, because this @me.com email came from mobileMe, I now have 25 GB of storage (20 mobileMe + 5 GB iCloud); so I really needed to enter this address in the iCloud setup.

     

    If I'm a little ambiguous, lemme know and I'll post again, with steps.. I just woke up. )

  • renei15 Level 1 Level 1 (0 points)

    Hi everyone,

     

    I've figured it out.. Go to iTunes and under Store go to View Your Account and under Account Information - Apple ID: (your login email address appears) go into edit.  There you will see the email address you are looking to change even though it does not appear on the main page.  Good luck!

  • rettogo Level 1 Level 1 (0 points)

    I have the same issue.  I was a MobileMe customer with a me.com address before iCloud came out.  Once iCloud was released, I was able to convert my iMac and MacBook Pro with no problems.  However, my iPhone and iPad gave me the message that that e-mail address was already in use.  (Well, yeah, it's in use by me and I want to connect it to this iCloud account.)  I never found a way so to do an endrun and come back to the e-mail issue later, I dreamed up an e-mail address.  Now my iOS devices use iCloud attached to that dummy e-mail.  My Book and iMac are using the correct account with the correct e-mail.  There has GOT to be a way to fix this. 

     

    For the record, I've tried deleting the iCloud account on the iOS devices.  As one user noted though, this is merely breaking the connection.  The problem that he/she alluded to but didn't address was that once the connection to that iCloud account is re-established, it is re-established with the same old useless e-mail address.

  • Alex_Dm_Shalin Level 1 Level 1 (0 points)

    I found how to solve you problem:

    1. Go to this link: https://appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa/

    2. Press manage your account

    3. Sign in

    4. Make necessary changes

    Good luck!

  • CarJunki Level 1 Level 1 (0 points)

    I just had to do this on my husbands iPad. His iPad kept saying his password was invald when he went to do app updates. I reset his password then it gave me the same error. I found his usernames for the Apple account and the iCloud account did not match. I deleted his iCloud account and it let me change his username to match his Apple account and this seemed to work. So I think you need to have matching ID's on the iPad or iPhone.

  • emilefromandover Level 1 Level 1 (0 points)

    Hi

     

    I solved the issue in the following way

     

    First thing to realise is that you iCloud ID does not actualy need to be the same than your apple ID

     

    So if you apple ID is jack@hotmail.com and you had j@me.com (typed incorrectly) as your original assosiated id but wanted jack@me.com then go to ipad iCould and delete the account under iCloud as explained in posts above

     

    then use jack@hotmail.com for all your store ID's on all devices so everyone in the family can get the same content at one purchase price

     

    Secondly go to https://appleid.apple.com/cgi-bin/WebObjects/MyAppleId.woa/19/wo/TS2zCayGY4ZI4K4 Sy5Snz0/5.0.29.145.1.0.8 log in using jack@hotmail.com and create a second e-mail associated with this account, e.g. jack@me.com, now verify it by logging into https://www.icloud.com/ and looking at the email sent to you

     

    when that is done use jack@me.com on your ipad, iphone and all your devices as your iCloud ID, in that way all your devices will be synced with your iCloud

     

    Now for the wife use jack@hotmail.com for the apple ID under store, so she can get your purchases, but use wife@me.com for her iCloud adress

     

    For your brother use brother@me.com and for your son use son@me.com for their iCloud ID's etc, but always use jack@hotmail.com under store

     

    hope that helps!

Previous 1 3 4 5 6 7 Next