Previous 1 4 5 6 7 8 Next 439 Replies Latest reply: Aug 1, 2015 3:02 PM by YouSuckiCloud Go to original post
  • alevine70 Level 1 (0 points)

    This worked great. Thx

  • Shibadad Level 1 (0 points)

    Matt's solution did work for me. I have two Apple IDs and wanted all my devices on iCloud with the same one. I followed Matt's idea and it worked like a charm. Thanks Matt.

  • toastaloha Level 1 (0 points)

    This worked perfectly for me!  Turning off Contacts, Bookmarks, etc. allowed me to delete the iCloud account and create a new one with my new email address.Thank you!

  • joshstcyr Level 1 (0 points)

    I am not completely sure if this will be a solution to your particular problem.  However, I had a .mac account as an apple id.  When I sign in iCloud on my mobile devices it automatically puts .mac as my iCloud email address.  I do no have a .mac address, when replying emails sent to my .me account it would attempt to send them from my apple id with the .mac address.


    I connected my mobile devices to my MacBook with my .me email account active and selected it to sync with my device and checked off the selection under advanced under the info tab  the box associated with "replace information on this iPhone/iPad." After doing that i went into setting on the device, iCloud, Account, Mail, and the .me account i had on my MacBook has replaced my dead .mac.



    Hope y'all can understand this and it helps.


    It worked for me!



    p.s. Turning off/deleting my iCloud account is what actually messed me up in the first place.  I was trying to make sure my notes were syncing, the solution to make them work was to delete the iCloud account and re-sign in.  That is what made my .me email attempt to reply with the .mac/apple id. I suppose everytime I sign out and sign back into iCloud on the devices I will have to "replace" the mail account off of my mac again.

  • xFactor69 Level 1 (0 points)

    I have a very rare issue with iCloud email:


    I was activating my iPhone 4S with a low-speed EDGE connection. At the iCloud, I was creating an email address like I got a message that says something went wrong and try again. When I tried again, it said the username has already been taken! And I finished the wizard. When I went to Settings > iCloud, I realized my first attempt has created my desired email. But when I go to Mail application and choose iCloud account, when it tries to load my mails, a pop-up shows up saying my iCloud username/password is wrong. But when I go to settings, all my iCloud items are functioning like they should. I have my Contacts, Calendar, Find my iPhone, etc. working wel... When I go to and try to load Mail application, it says it can't load mail. I clicked Report to Apple like a thousand times but I got no feedback. I'm so confused what's wrong! I tried all the methods above. None did resolve my problem Any ideas??!

  • wright0920 Level 1 (0 points)

    Thank You.  this worked well

  • Robert Rutledge1 Level 1 (0 points)

    The solution on "How to change the primary email address on an AppleID account" given by s102587 does not work for me.  When I open iTunes on my laptop, I see my AppleID in the upper right hand corner.  I click on the down arrow, and select "Account".  I see "Apple ID Summary", with my "Apple ID" listed, and an "edit" button on the right hand side, and I click on it. -- So far, this is all exactly as s102587 said it would be -- From the resulting page, I can change my password;  However, my AppleID email address is indicated in what looks like an editable text box, but it is greyed out, and I cannot change it. 


    I suggest that s102587 did not confirm that this method worked, prior to suggesting it: he merely saw what looked like a changeable appleID in a text box, but did not realize that it was greyed out, and could not be changed. Thus, this solution was not confirmed to work by anybody. 

  • gmardre Level 1 (5 points)



    Did you ever find a solution? I, too, got tricked into creating an @me account when creating an iCloud account.


    Everyone's previous solutions do not put your email in the cloud, unless you use the @me address. So... None are

    Synced. So, if you read and delete an email on your phone, it doesn't effect your iPad. Big problem.,


    I simply want to make my gmail account my iCloud email.....



  • tmarth Level 1 (0 points)

    Ditto - I simly want to make my gmail account my iCloud email....  Apple are you listening?  tm

  • wrenne Level 1 (0 points)

    I had the same problem you all are describing...I deleted account and deleted from iPhone and started over. Worked like a charm...Thanks Matt

  • gmardre Level 1 (5 points)

    No, you didn't.


    Your iCloud account got changed to ...whatever.


    But, if you lick on that account in Settings>Mail>iCloud...then when that opens up, look down at the bottom of the page. You may have to scroll up...


    You will see under Advanced....your iCloud email, which IS either an @me, or something like that. It is unchangable.



  • Trinads Level 1 (0 points)

    Ok, I read through all these pages of responses, and decided to try Matt's way from the original post. So, I was slightly confused, and i'm sure i'm not the only one, but this is exactly what I did to make it work: 1st off, my problem is that my iCloud ID shows an old email address that's not my current Apple ID, and it doesn't allow you to change it on the phone settings. So I went to settings on the phone, then clicked iCloud, then I turned off everything from Mail down to find my iPhone, but I left the Documents and Data on because when i went to turn it off, it said it would delete everything off iPhone, so i left it as it was. I then scrolled to the bottom, and hit the red Delete Account button, then it asks: Deleting will delete everything on iPhone, GO AHEAD AND HIT DELETE, then another prompt comes up that asks: Keep on iPhone, Delete everything, then you can chose keep on iPhone, after I did this, i went back into setting>iCloud, and my new Apple ID was correctly in place, so it worked!! now, this will only work if you have already gone on a computer, open iTunes, then go to settings then apple ID, make sure that your password is correct and that your Apple ID is correct. Then it is safe to delete and reinstall the iCloud on your phone, whatever Apple ID you have in itunes will show up in the iCloud after deleting and re-opening iCloud. Here's a direct link to Apple's website where you can change your apple ID: remember, do this first before deleting the iCloud account off of your phone:

  • wrenne Level 1 (0 points)

    Great explanation. I did all of that and it worked. I didn't have an @me account...I just had an old email address from iTunes that appeared in the email box. As far as I can tell, everything is working fine. I don't see the "advanced" section anywhere, so if the old email address is there, I haven't found it. Thanks so much for the comments!

  • runner95 Level 1 (0 points)

    I spent many hours trying to figure this out.  These were the steps that I followed:

    1. Go into Settings > iCloud

    2. Turn off all of the options

    3. Delete account

    4. Sign in using your Apple ID (your Apple ID should be your prefered e-mail adress and password)

    This should fix the problem. If not, you might want to check out your Apple ID and see if there are any problems there.

    Sorry if this doesn't work for you.

  • Livingwhite Level 1 (0 points)

    Great advise , I was afraid to delete the account as it says deleting will delete all info from ur iPad but when u press delete it will say keep everything on iPad u then choose this option ( keep everything on iPad)

    THen u add ur new account & email address etc. YOU MUST HAVE PREVIOUSLY SET THIS UP IN ITUNES ON YOUR PC.

    Good luck it's so annoying.

    There are alot of people with the same problem Apple should make it easier to do this, it would be more helpfull if there was a drop down menu giving options on what to do if u wish to change ur email address and a link to iTunes to make it easier.

Previous 1 4 5 6 7 8 Next