6 Replies Latest reply: Aug 18, 2006 9:21 PM by Old Toad
Peter Waldo Level 1 Level 1 (5 points)
After upgrading my library, I tried editing some photos.

On one, I made red-eye adjustment that looked just fine--that is until I saved the edit. Once saved, the red-eye correction was different (and not as complete) as I had seen in the edit window. Some of the corrections were good, but one I could not get to save properly!

Anyone else having this problem? Or better yet, know of a workaround or fix?

++ Peter

iMac 15" G4 800MHz   Mac OS X (10.4.4)  
  • Tom359 Level 1 Level 1 (0 points)
    I have the exact same problem...I thought it might have been a bug with Full Screen mode, but it also does it when I edit in a separate window. The red-eye is removed and I get the "saving changes" dialogue box. When I forward to the next picture, and then return, all my red-eye work is gone. Pretty annoying.
  • John Trares Level 1 Level 1 (5 points)
    I'm having the same problem - some times the red eye adjustment occurs in other places in the photo. It seems to be a bug that introduced pretty recently.

    The only workaround I've found is that you need to save some other change in the photo before you make the red eye adjustment. This does not seem to include a simple rotation which does not seem to force a normal save any more(i.e., there is no longer a delay when moving to the next photo).
  • Old Toad Level 10 Level 10 (123,340 points)
    John:

    Regarding the "other places" you might try changing the size and intensity of the red eye tool as follows to see if it makes any difference (this applies to the Retouch tool also):

    How to Change the Size of the Retouch and Red-Eye Removal Tool



    • Type Caps lockControl9

    • Undo caps lock

    • Click on Retouch tool

    • The tab key will toggle between cursor types, a cross or a circle

    • The "[" and "]" keys decrease or increase the size accordingly.




    NOTE: Using the "{" "}" keys will will change the value next to the circle and that represents the degree of change or intensity that the tool imparts on each pass.

    You can start the process either in the normal edit window or in the full screen mode. Once evoked in the normal edit mode it will stay evoked until you close iPhoto. However it won't carry over to the full screen edit. You'll have to restart the process then. Also, when evoked in the full screen edit mode it will stay active as long as you're in that mode. If you go back to normal mode and then back to full screen you'll have to restart it. Additionally, the redeye and retouch tools reset back to the default size between images (in both modes).
  • vmcaamano Level 1 Level 1 (0 points)
    I'm having the same problem, my edits are not being saved.
  • ingling Level 1 Level 1 (0 points)
    I'm having the exact same thing. I make red-eye adjustments, it says it's saving, but the red-eye tool changes are NOT saved. Here are some things I've tried doing before re-trying the red-eye tool, none of which have fixed the problem:
    1. Making other edits in iPhoto and saving them first.
    2. Making other edits in photoshop and saving them first.
    3. Duplicating the image in iPhoto.
    4. Reverting to original and starting over.
    5. Exporting the photo and re-importing it.
    6. Exporting the photo, editing it in Photoshop, and reimporting it.
    7. Exporting the original TIFF, converting to PNG, and re-importing it.
    8. Exporting the original TIFF, converting to JPEG, and re-importing it.
    9. Exporting the TIFF, scaling it down slightly, and re-importing it.
    10. Cropping it.
    11. Exporting as TIFF, downsizing to 2,000 pixels wide, and re-importing it.

    Here's what did work:
    - Exporting it as a jpeg scaled down from 3004 pixels wide to 2000 pixels wide and re-importing it.
    - Exporting as a TIFF, scaling down to 1000 pixels wide, and reimporting it.

    NOTE that scaling it down to a 2000 pixel wide JPEG allows the edit to work, but scaling down to a 2000 pixel TIFF does NOT! Yet scaling it down further as a TIFF does work! I also tried scaling it down just slightly as a JPEG- from 3004 to 3000 pixels, which did NOT work.

    I have no idea what's going on, but it's sure annoying. The red eye tool makes perfect adjustments, and then anytime I leave that image and go back to it, the changes are not there, despite iPhoto saying "saving changes."

    I'd be glad to send a test image this happens to to Apple, if anyone wants it, because this is definitely a bug, and an annoying one. It doesn't happen with most images, so if Apple doesn't happen to have an image around that this happens to, they won't be able to re-create the bug for testing.

    G5 Dual 2 Ghz   Mac OS X (10.4.7)  

    G5 Dual 2 Ghz   Mac OS X (10.4.7)  

    G5 Dual 2 Ghz   Mac OS X (10.4.7)   iPhoto 6.0.4

    G5 Dual 2 Ghz   Mac OS X (10.4.7)  
  • Old Toad Level 10 Level 10 (123,340 points)
    I can only suggest that you run the latest COMBO updater (10.4.7) and make sure you have the latest Quicktime version installed, all followed by a repair of disk permissions.