14 Replies Latest reply: Aug 4, 2015 7:51 AM by traceyfromclunderwen
DEFD Level 1 Level 1 (0 points)



I've just bought my new iPad 2.  iPad connects to wireless network but no internet access.


Apparently it cannot get an IP address (it has got the self-assigned 168..)


I am able to connect to the internet with my iMac, iPod touch and Lenovo laptop.


I already done *all* possible combination of switch on/off, reset of both router & iPad2, the "MAC" trick etc.


I tried both with WAP2 personal and no security


I tried all suggestions which came up from similar posts, but still no luck


Please, any *real* suggestion (please don't suggest "switch off and on" ) would be really appreciated.




DEF Dude



iOS 4.4.3,  Modem firmware 04.10.01, model MC775AE

iPad 2, iOS 4.3.2, iOS 4.4.3, Modem firmware 04.10.01
  • gatortribe Level 2 Level 2 (265 points)

    This site may help you.

  • DEFD Level 1 Level 1 (0 points)

    Thank you, gatortribe for the quick answer.


    Yes, tried that already (now it's one full day I'm on this and I exhausted all "first-level" tricks).


    Thanks anyway for the hyper quick answer! I appreciated


    DEF Dude

  • John Hammer1 Level 4 Level 4 (2,805 points)

    Is your wireless network using WEP security? If so, try entering the WEP-equivalent hex code instead of the ASCII password. I've found that makes the difference many times.


    Have you tried connecting to another wireless network, such as a free one at McDonald's, Starbucks, or a public library?

  • DEFD Level 1 Level 1 (0 points)

    Thanks John Hammer1,


    as per my post, I tried both WAP2 Personal and no security at all - it is not an issue in the security layer.




    DEF Dude

  • John Hammer1 Level 4 Level 4 (2,805 points)

    OK then.


    Are you able to connect to other networks and access the Internet from them? In other words, are you having this issue only with your own network, or with all you have joined? If only your own, please provide more details about your wireless network.

  • Philly_Phan Level 6 Level 6 (12,990 points)

    I have seen this condition whenyour Internet modem/router has a firewall that's too strong.  For reasons that I so not understand, it affects iPads before it affects other devices.  You'll need to get into the modem's administrative menu to investigate.

  • DEFD Level 1 Level 1 (0 points)

    John Hammer1,

    Thanks - good point - I just tried with my network BUT:

    - I set it to no security / no firewall

    - ipod, iMac and Lenovo all work

    Tomorrow I'll try at Starbucks, just in case, after that straight to Apple Store


    Philly_Phan, thanks - see above. I appreciate your quick answer!


    DEF Dude

  • DEFD Level 1 Level 1 (0 points)



    I tried at Starbucks and there it worked immediately with no problem.


    Mystery, since at home, I have several other devices (iMac, iPod, lenovo laptop), NO wireless security and ALL of them (except iPad) work just fine.


    iPad can connect to the network but cannot get IP / connect to internet.


    I'm using a WAG200G Linksys modem with no security. Signal very strong (I'm connecting from the same room).


    Please, anybody can point to a page where the "optimal" WiFi settings for iOS are listed?


    Thanks a lot in advance!! 


    DEF Dude

  • carynfromdurham Level 1 Level 1 (0 points)

    I am having the same problem. I too have other devices that are connected to my network without a problem, but my ipad connects immediately upon waking, but within seconds it disconnects. I am using a Netgear router, WRG614. I have also reset the modem, reset the router. Disengaged firewalls and security. I can connect to retail wireless as well as my neighbor's network. Insanely frustrating. Been happening for weeks, but now it's been 24+ hours without connection. The ipad sees the network, but won't stay connected.

  • Lafin_Larry Level 1 Level 1 (10 points)

    I was having the same proble too. the last thing i did was long on to some random unsecure wireless network & it hasn't worked since. the final answer was to power it down by holding down the power button for a few secs & when i restarted it works. Well i just learned how to do a full reboot, good for me but you didn't want that kind of answer. The second part to my story is that i realized my wireless network would only allow 2 connetions. after the laptop & iphone connected, i got the boot.  So i shut down the laptop but for some reason it was not releasing the IP to allow me on, until i rebooted the ipad2. So far it looks like everyone has more than 2 units so shut them down & restart the wireless (release /all), then ipad (only).  good luck

  • MJBTV Level 1 Level 1 (0 points)

    Me too, My iPad2 sees the Airport Extreme Router, I have NO internet Connection and my carrier AT&T is gone. I show a full power wifi signal and NO SERVICE for the AT&T cell signal. This all happened after I turned on CELLULAR DATA then cancelled it. I could not see paying for 3g when I have wifi here. However that's when everything stopped working. I did do a iPad restore through iTunes but that made no difference.


    I have two MacBook Pros, Imac, G4, 2 PC's all connected to the internet with no problems. I will be calling APPLE on Monday to take this thing back. What a waste of time and money. This crap is built in China so is the power cord which has already split at the iPad connector. Not a happy camper here!

  • DEFD Level 1 Level 1 (0 points)

    Hello All,


    thanks a lot for the support, in particular Lafin_Larry. I just wanted to close the discussion


    It turns out it was the provider's fault.


    How I did get to it:


    1 - iPad was working with Starbucks etc

    2 - iPad was not working at home but iMac, iPhone, iPad and Lenovo were

    3 - done ALL the stuff adviced in the forums (including no security, switch on/off, restarts, latest firmware etc etc)

    4 - Changed router, still iPad not working, other machines yes


    so in the chain     provider -> router -> firmware -> router settings -> ipad settings -> ipad  

    the provider was the likely culprit.  It turns out that, even though they don't have a limit on number of machines connected to a network.... they somehow do - fixed!


    Thanks again - apple users community rocks!


    DEF Dude

  • DEFD Level 1 Level 1 (0 points)



    DEF Dude

  • traceyfromclunderwen Level 1 Level 1 (0 points)

    My iPad did the same, I tried by restoring the iPad, nothing seemed to work, this may sound crazy, but. Try turning off the (ask to join network) option, it worked like magic on my iPad.