Previous 1 2 Next 18 Replies Latest reply: Oct 7, 2014 7:24 AM by charlesteton
Yarred Level 1 Level 1

OK, here's the deal. I recently upgraded my Mac Pro from Leopard to Snow Leopard (mainly to get ready for Lion, I've been running SL on my MacBook Pro for ages). I never had any problems with Logic 8 (or Final Cut Studio 5.1 for that matter) on my MBP running SL. But after upgrading my Mac Pro, I would get nothing but crashes any time I tried to bring up an Open or Save dialog box in any of Apple's pro apps. The crash log would always show something like this:


Thread 0 Crashed:  Dispatch queue:

0   libobjc.A.dylib                         0x91795917 objc_msgSend + 23

1                        0x95e11649 -[NSView _recursiveBreakKeyViewLoop] + 219

2                        0x95e10a2b -[NSWindow dealloc] + 641

3                        0x961ab298 -[NSSavePanel _bonafiedDealloc] + 75

4                0x931779d8 CFRelease + 152

5                0x931a45bd _CFAutoreleasePoolPop + 253

6                    0x95942f9f NSPopAutoreleasePool + 393

7                    0x95942d8a -[NSAutoreleasePool drain] + 130

8                        0x95c66539 -[NSApplication run] + 627

9                        0x009bb3f6 NSProApplicationMain + 326

10                    0x000027fa 0x1000 + 6138

11                    0x00002721 0x1000 + 5921


After pulling my hair out for hours, I finally solved the problem. I discovered that there was a /System/Library/PrivateFrameworks/ProKit.framework as well as a /S/L/PF/ProKit(SnowLeopard).framework folder on my Mac Pro. However, on my MBP, there was only the expected ProKit.framework folder.


So, (via the Terminal, sudo mv, etc.) I renamed ProKit.framework to ProKitFOO.framework and renamed ProKit(SnowLeopard).framework to ProKit.framework. Boom! Everything started working fine.


I Googled for a fix like this for hours earlier, so here's hoping that this might end up helping someone else out there, perhaps thinking of upgrading to SL to make way for Lion. Don't ask me why this ProKit installation was goofy, but at least now there may be a workaround.

Logic Studio, Mac OS X (10.6.8)
  • MadeBackwards Level 1 Level 1

    Thank you!


    This was the exact fix needed. Attempting to download via Software Update reported that all was well, and trying to reinstall the ProKit manually just reported that I didn't need it.


    To anyone not familiar with Terminal, just search for it in Spotlight then enter the following...pressing ENTER/RETURN at the end of each line.


    cd /System/Library/PrivateFrameworks/

    sudo mv ProKit.framework ProKitFOO.framework

    sudo mv "ProKit(SnowLeopard).framework" ProKit.framework



    PLEASE only attempt this if you've upgraded to Snow Leopard and are having ProKit file handling issues. (Saving patches/songs/bouncing in Logic, saving in Soundtrack Pro, Using CinemaTools etc etc.)


    cd changes the directory

    sudo forces OS X to make changes as a different user

    mv is used to request a RENAME - the first following filename being the file TO change, the second being the name you with to change it TO.

    You will be required to enter your administrator password each time.

    Exit and then Quit Terminal.


    Thanks again Yarred!

  • bobrpdx Level 1 Level 1

    I'm adding my thanks to this as well, and a few keywords to help people searching for answers, as this affected Motion for me first, and most threads out there about Motion don't lead a person to this solution.


    So for those having problems, after upgrading from Leopard to Snow Leopard, where Apple Motion 4 crashes when using File / Save As... or File / Open..., or for those using Compressor where it hangs upon exit (it is trying to display a "Do you want to save the changes" dialog but cannot), go look for the ProKit(SnowLeopard).framework file as mentioned above.


    It worked for me when all of the other commonly-recommended solutions (delete preferences, delete or reinstall packages, complete removal and reinstall, remove plugins, etc.) did not.


    Note that (at least in my case), after doing the rename/mv operation above and then subsequently running Software Update, it was detected that "ProKit 7.0" needed to be installed (reinstalled in my case).  That's fine, it did not break the fix!

  • Jer70s Level 1 Level 1

    Thanks for this.  Not sure how you managed to find it but solved a problem that had wrecked my head and (almost) a few projects.  Great fix.

  • FunkDaddy Level 2 Level 2

    Thank you! This saved my butt!

  • alanpoiuyt Level 1 Level 1

    I'm so glad you guys have posted this fix to ProKit. Compressor has especially been impossible to use after Snow Leopard install.

    Having never used Terminal, I'm a little confused as to the input method described. I'd really hate to mess up my system. I've launched Terminal, pressed enter and copy and pasted the 1st line of fix, then pressed return and repeated for each line. I've also pressed ENTER/RETURN at the end of each line as instructed.  I'm not getting any request to enter password so I know I'm doing something wrong. Could you give me a hand?-Thanks!

  • bobrpdx Level 1 Level 1

    When you start terminal it should display some basic information, such as "Last Login" and a line (called  a "prompt") which is the name of your Mac, a colon, and probably a tilde ( ~ ) and your user name, followed by a dollar sign.  Such as:


    ThisMac:~ JohnDoe$


    The dollar sign is the indication of where you should start typing or where you should past your text.


    So, if you've gotten that far, paste the first line of the fix after the dollar sign and then press return:


    cd /System/Library/PrivateFrameworks/


    The "cd" command tells the system to change the current directory, sort of like navigating to a particular folder in the finder.  Now, at this point you should get yet another prompt.  If not, something isn't working correctly the way you're pasting in the text.


    But if you've gotten to that next prompt, instead of doing the next line of the fix, simply enter the following two-letter command and press return:




    The command "ls" tells the system to list for you the names of all the files in the current directory.  You should see dozens of files, most of which end in ".framework".


    You can then continue with the rest of the fix.  (If you've already done the fix, you may see file not found errors when you try the "sudo mv" commands.)


    When done, the result of an "ls" should give you, among the big list, a file called "ProKitFOO.framework" and a file called "ProKit.framework".


    I hope that helps!

  • alanpoiuyt Level 1 Level 1

    thx for the quick reply - I am not getting last login info when launching Terminal - just a window with Terminal - login - 80x24 at the top. Any ideas?

  • bobrpdx Level 1 Level 1

    I'm not sure... My Terminal has always automatically logged me in as the current user.  I don't want to clutter up this thread with too many comments about getting logged in to the terminal... I did find an Apple Support Communities discussion about a stuck/blank terminal window which sounds like what you are experiencing... Looks like you may have to troubleshoot a different problem before you get to fix ProKit!


  • alanpoiuyt Level 1 Level 1

    thanks to all who responded! Got terminal working - did the ProKit fix - and Compressor responding beautifully.

  • Marko52 Level 1 Level 1

    (  After pulling my hair out for hours, I finally solved the problem. I discovered that there was a /System/Library/PrivateFrameworks/ProKit.framework as well as a /S/L/PF/ProKit(SnowLeopard).framework folder on my Mac Pro. However, on my MBP, there was only the expected ProKit.framework folder.  )


    I'm having the same issue with DVD Studio Pro.  I see the fix and this is also disscused on Digital Rebellion html.


    But my problem is that I cannot fine (/System/Library/PrivateFrameworks/ProKit.framework) on my mac anywhere. Not only that I have two other mac that do not have this either.  So I can't do the fix if I can't find the files that need to be fixed. 


    Anyone have an idea on this?


  • LLane Level 1 Level 1

    Thank You!


    Motion 4 kept crashing when trying to save a project. I had recently upgraded my MBP from Leopard to Snow Leopard. With your fix all is well now!

  • Nitsan Simantov Level 1 Level 1

    Hey, thanks!

    I was having the exact same problems in Final Cut Studio 2
    Motion crashes/closes on 'save as' or export.

    DVD studio pro crashes on import.

    Soundtrack Pro crashes on save as.

    Final cut pro 6 was the only one that worked fine. Not sure about LiveType, havn't used that in like 4 years.


    Final Cut Pro X will not open after this fix!
    Any ideas of how to get both FCS2 and FCPX working on the same machine in Snow Leopard? I like editing in FCPX (for my needs it's faster) but I still need DVDSP. :/
    Any point upgrading to FCS3 or will that crash as well?
    ---------------Or is there an alternative to DVD SP that's free or not too expensive????------------------


    For those that need it, here's the reverse process:

    (This worked just fine for me to reverse the process and get FCPX to work again, HOWEVER, I am NOT qualified to give this advice, I am not a programmer or developer! - do the following at your own risk.)


    Open Terminal and enter the 4 lines below and press 'enter' after each line:

    -------------------------------------------------------------------------------- --------------------------------------------


    cd /System/Library/PrivateFrameworks/

    sudo mv ProKit.framework "ProKit(SnowLeopard).framework"

    sudo mv ProKitFOO.framework ProKit.framework



    -------------------------------------------------------------------------------- --------------------------------------------



    I hope that's been helpful to someone.

  • shmeck Level 1 Level 1


Previous 1 2 Next