3 Replies Latest reply: Aug 3, 2011 8:04 AM by Keith Gardner1
carrdb Level 1 Level 1 (0 points)

ipad message advising unable to join the network.  Wireless application is fine, password correct, all other home PC's connected.


iPad 2
  • Rudegar Level 7 Level 7 (23,620 points)

    try restating the ipad

     

    if that don't help try restarting the wifi router even if it's working with the other connected devices

     

    if that don't help try making the ipad forget the network completely and re-add it

     

    if that don't help try updating the routers firmware to the latest version from the manufactory

     

    if that don't help try connecting to other wifi networks to verify that it's not your ipad which have a defect

  • JimHdk Level 7 Level 7 (28,240 points)

    If the advice from Rudegar doesn't work for you then some more information about your network would be useful in giving specific advice, i.e., what make/model router are you using?, what security type are you using? (WEP, WPA, WPA2), etc.

     

    Presumably you cannot connect because your password is being rejected?

     

    If so, are you using WEP security? If you are using WEP then text passwords are not handled the same way by different Operating systems if they are not the exact length required by the WEP variety being used. For more information read this article: http://support.apple.com/kb/HT1344

     

    WEP should be avoided. It is insecure and was deprecated by the WiFi Alliance in 2004 for this reason. Use WPA or, better yet, use WPA2 (as recommended by Apple).

  • Keith Gardner1 Level 2 Level 2 (215 points)

    I have this situation as well with a NetGear WAP610N. I had been using an Access Control List because I had had some problems with certain devices not able to connect, and the ACL was my way around that problem. That worked when there were a handful of wireless devices to be connected, but now that everybody and his brother has at least one wireless device, if not more, it's no longer a viable option. So I tried to switch first to WPA, and that worked for some but not all devices. Then switched to WEP just to see if the rest of those could join, and still not all. Finally turned off all security, which is not the way I want to leave it, but still, iPad and iPhone 3 cannot connect, though iPhone 4 and other devices can connect.

     

    Yes I would normally upgrade the firmware on the WAP, but of course the upgrade does not work. I've tried three different times, and am not sure whether I'm supposed to be using the .bin file or the .cpgz file, but in any case, neither upgrade ran to completion within one hour.

     

    I'm thinking it's time to apply the wisdom/logic of one Apple "genius" who was speaking to me on another topic: "Life is short. Do what works." I'm gonna go buy an AirPort Extreme.