3 Replies Latest reply: Jul 4, 2011 12:01 PM by MadisonP
Ron Stephens1 Level 1 Level 1 (5 points)

I have 3 macs, an iPhone and an iPad, all of which sync perfectly via mobile me. But... mac #4 - a Mac Pro dual quad... - will not sync with iCal (everything else syncs just fine).

 

When I open iCal I get this message: <The server did not recognize your user name or password for account “myname@me.com". Make sure you enter them correctly.> For some reason iCal - and iCal alone - is choking on my name/password, although other info (Bookmarks, Contacts, etc...) are not. I don't think it's even possible to enter the wrong login for just iCal alone - is it?

 

I've already trashed prefs, repaired permissions, unregistered & re-registerd this computer in the MoblieMe Sync Preferences, and tried to replace all info on this computer with the info on the server. Same result. It's all good except to iCal. Oh, and... this was happening prior to the 10.6.8 update.

 

Any sugestions?

  • MadisonP Level 5 Level 5 (4,735 points)

    Greetings Ron,

     

    1.) First make an iCal backup:  Click on each calendar on the left hand side of iCal 1 at a time highlighting it's name and then going to File Export > Export and saving the resulting calendar file to a logical location for safekeeping.

     

     

    2.) Go to Apple Menu > System Preferences > MobileMe > Sync -- Uncheck calendars so they do not sync.  Calendars no longer sync with the new MobileMe calendar.

     

     

    3.) Go into iCal > Preferences > Accounts and delete the MobileMe account from here.

     

     

    4.) Remove the following to the trash and restart your computer:

    Home > Library > Caches > com.apple.ical and/or just ical

    Home > Library > Calendars > Calendar Cache, Cache, Cache 1, 2, 3, etc. (Do not remove Sync Cache or Theme Cache)

    Home > Library > Preferences > com.apple.ical (There may be more than one of these. Remove them all.)

     

     

    NOTE: Removing these files will remove any shared (CalDAV) calendars you may have access to. You will have to re-add those calendars to iCal > Preferences > Accounts.

     

    5.) Once the computer is back up and running go to iCal > Preferences > Accounts, and add the MobileMe account using your MobileMe @me.com email address.

     

    Hope that helps!

  • Ron Stephens1 Level 1 Level 1 (5 points)

    Thanks for the comprehensive solution. Turns out all I had to do was delete and recreate the me.com account in iCal prefs and it's all good. Funny - I don't remember setting that up in iCal in the first place.

  • MadisonP Level 5 Level 5 (4,735 points)

    Glad to hear you resolved your issue.

     

    This is how the new MobileMe calendar talks to iCal.  All MobileMe users were upgraded several months ago (and received automated emails about the change): http://support.apple.com/kb/HT4037