14 Replies Latest reply: Aug 3, 2012 7:39 AM by Fieldman
docgecko Level 1 Level 1 (0 points)

I'm monitoring the status of my MacBook Pro using iStat, and every hour (or so) my CPU usage shoots up to 100%.


When I view my Acitvity Monitor, there is not one process that appears to be have a very high CPU, even though iStat shows my CPU usage go up to 100% (and the noise of the fan begins).


However, I have found that the process called "bash" is always either top or 2nd to the top of the list of CPU usage, even though itself is around 8-10%.


I have tried shutting down a number of the processes and they have no effect on the 100% CPU usage, except for "bash".  When I Force Quit bash, the CPU usage drops off back to a very low value immediately.


As such, I was wondering what may be causing "bash" to cause 100% CPU usage, and how I may resolve this.


Many thanks!




MacBook Pro, Mac OS X (10.6.8)
  • docgecko Level 1 Level 1 (0 points)

    Just to pass on a bit of information:


    I found another similar question on these forums about a potential issue relating to a job being stuck in the printer queue, like a rougue job.  If you access the printer queue via http://localhost:631/jobs/ you can cancel the rouge job.


    Cancelling the job actually cut down considerably the number of times per day my mac CPU went up to 100%.  It still happens but with longer durations between. So its possible that it is still an issue related to the printer software.  Btw, I am using a Brother MFC-845CW.


    If anyone has any other potential solutions, I'd love to hear them.


    Many thanks,



  • Fieldman Level 1 Level 1 (0 points)

    I had the same problem and found out the it was Send to Kindle app (actually virtual printer Send to Kindle). So I uninstalled it with uninstaller and the pron'blem cesaed. When I reinstalled Send to Kindle, it appeared again. So I have been consulting it with Amazon Support since...

  • Jon Henshaw Level 1 Level 1 (5 points)

    Uninstalling Send to Kindle worked for me too. Thanks for the tip Fieldman!

  • Fieldman Level 1 Level 1 (0 points)

    You are welcome. Amazon Support knows about the problem and they promised that next update should cover it.

  • Bob Kujda Level 1 Level 1 (20 points)

    A "Send to Kindle" uninstall fixed the bash high CPU issue for me also. Thanks

  • Robert Follis Level 1 Level 1 (5 points)

    THANKS FIELDMAN !!!! A "Send to Kindle" uninstall fixed the bash high CPU issue for me too.

  • Lisa B170 Level 1 Level 1 (0 points)

    OMG!!!  Thank you, thank you, thank you!  That's all I can say.  This issue was driving me crazy.  I just upgraded to Mountain Lion with the other 3 million folks and all of sudden, my MacBook Pro was heating up and the RPMs were off the grid.  Couldn't figure out why.  Before this, I almost never heard the fans going on (I know they run all the time) but the between the fan and the RPMs I was getting up to 4500 with nothing open and the temp was going back and forth between 85 to 90 degrees.  Needless to say, I was somewhat concerned.


    I have been on the Internet for about 2 days trying to figure this out.  I know that the computer was indexing after the upgrade but just could not find the source of the RPM problem.  Found lots of info about re-setting the SMC, but didn't try that yet.  This was going to be my last resort.  Downloaded SMC Fan Control and that helped somewhat.  Erased Sophos Anti-Virus which had Intercheck running and taxing my CPU.  Then I stumbled upon this particular thread and lo and behold - I had downloaded Send to Kindle.  I had noticed in the Activity Monitor that this "bash" process was running but didn't pay much attention because the CPU was at around 7 - 8%, not 99% of the CPU which would be obvious.  Decided it couldn't hurt to remove this app and the next thing I know my temp dropped down to 49 degress and the RPMs are at 2500 and NO FANS running like crazy.


    I just can't thank you all enough for this extremely valuable information - I hope Amazon fixes this.  I really loved Send to Kindle app but I love my MacBook Pro more so the choice was simple.  So glad I found this forum.

  • Fieldman Level 1 Level 1 (0 points)

    I'm glad that it helped. It has been a long serch for me too and trust me that your thanks are the perfect reward for the time spent searching.


    Amazon sent me official conclusion today:


    "We have researched on this issue and got to conclusion that during the backup/restore process, /var/spool/stkPrinter/ and its files are lost, causing the dependent script stkLaunchAgent.sh to spike the CPU usage.


    STK uses a communication pipe present in (/private/var/spool/stkPrinter/$USER/stkPipe) to communicate the printed file name to the STK app. STK Printer backend writes on the pipe and a bash script(/usr/bin/stkLaunchAgent.sh) listens on the pipe in a loop. When the bash script starts, it checks whether the pipe is present and if not creates it.


    This can be fixed by re-installing the app."


    I tried to install Send to Kindle again... and it works! So Amazon guys fixed it...



  • jollypants Level 1 Level 1 (0 points)

    I was also having a bash hog up cpu.  IM on a new retina, and still getting under 3hrs on each charge :-(

    Uninstalled and now nearly 6 when beating the crap out of the cpu with other things.  What an odd little issue (send to kindle).

    Thank you

  • Lisa B170 Level 1 Level 1 (0 points)

    So glad you were able to find this forum and more importantly, the solution to your problem.  I agree it is such an odd issue.  But all the THANKS goes to docgecko for putting the question out there and Fieldman for the solution. These forums are invaluable and if like me, the issue was driving you nuts, it is such a relief to find a "true" solution to an issue.  Glad to hear things are now back to normal.


    FYI - if you notice Fieldman's post from 7/31, you'll see he was notified that the issue has been fixed by Amazon and Send to Kindle is good to go now.  I re-downloaded Send to Kindle and so far, I have had no issues with the application. Good Luck!

  • jollypants Level 1 Level 1 (0 points)

    Me too.  So far so good.  Got tons of things running, moderate brightness, and it looks like it's working as advertised. 

    Very impressive that a device with this much detail and power can pull this long of a battery life. 

    Be well,


  • Bob Kujda Level 1 Level 1 (20 points)


    I've uninstalled Send to Kindle becasue of bash issue. However I cannot find the new Send to Kindle version for Mac to reinstall. Is it now a question of capatiability with OSX 10.8?



  • jollypants Level 1 Level 1 (0 points)

    Neither could I.  I had to change the settings in the security preferences.  I fear this aspect of the security of ML is taking developers a bit by suprise. 


    There are people out there who have been paying attention and disagree, and to you fine folks I *bow*.  For the rest of the dev. community who missed it.. we'll just have to use the same discression (as users) we did before we upgraded or began using ML.


    I think if you trusted it (developer, or co creating said app) before the upgrade, you should be able to trust it now right?

  • Fieldman Level 1 Level 1 (0 points)

    I'm still running Lion and don't want to upgrade until 10.8.1 is out... Just beacuse of those kind of issues - the newborn problems.