9 Replies Latest reply: Feb 19, 2015 9:10 PM by paigep
mattigitol Level 1 Level 1 (0 points)

my mac wont load any disks anymore! there is no disk inside but still wont accept.. please help


MacBook Pro, Mac OS X (10.6.8)
  • Linc Davis Level 10 Level 10 (154,685 points)

    What happens when you insert a disc?

  • CT Level 6 Level 6 (16,625 points)

    deleted

  • Allan Jones Level 7 Level 7 (32,390 points)

    "there is no disk inside but still wont accept."

     

    Do you feel something blocking the disk you are trying to insert, or does the disk fully enter but then eject a few seconds later? If the latter happens, the first thing to try is a drive cleaning disk. They are US$5-15 and much cheaper than a service call.

     

    If you feel something blocking, that will probably require professional help. If someone else had access to the computer and inserted an mini-optical disk or one of those odd-shaped ones, that's  serious problem. Only standard full-sized optical siaks are compatibel with slot-loading drives.

  • mattigitol Level 1 Level 1 (0 points)

    when i try to insert it in..it only goes in half way..and feels like something is blocking it..i just got the mac like weeks ago...

  • mattigitol Level 1 Level 1 (0 points)

    i am not so sure if anyone had used my mac but when i insert a disk..the regular kind it just goes in half way and thats it..

  • Linc Davis Level 10 Level 10 (154,685 points)

    The drive needs to be serviced or replaced.

  • M-Ego Level 1 Level 1 (20 points)

         1. Go into Spotlight from the top of your MacBook on the menue bar.

         2. And search for "CDs & DVDs" (It's also in the System Preferences)

    Click on it and a small CDs & DVDs window will pop up with options of what happens when you insert a disk into the drive

         3. By then, try inserting a disk in (while that window is open. This kinda wakes up your drive to accept the disk). It should accept it.

         4. If nothing happens, then manually open the program that should be opening when you insert the disk or go to Finder (Eg. if it's an audio disk, then open iTunes)

         5. If opening the program still does not activate the drive to start spinning the disk, then close the programs and windows you opened, and repeat step 1-4 and the disk should be spinning and automatically opening the proper program.

     

     

    Hope that helps!

  • shichido3 Level 1 Level 1 (0 points)

    This happened to me recently. I knew there wasnt a cd in the drive but it would only insert half way. I read about resetting various things but none of those tricks worked. So I will tell you what I did....but I am certainly not recommending it unless you are somewhat mechanically inclined.

    The problem is that there is a pin that helps to eject the cd from the drive. Occasionally it becomes out of sync with the mechanism that helps load/eject cds. What happens is when the cd is being ejected, the pin on the top pushes the cd out...but it stops halfway and doesnt continue to the top of the drive where its out of the way the next time you put a cd in.

    So thinking I could manually push the pin back into place, I opened up the back of the Mac, removed the cable from the dvd drive and took it out. After removing the screws and having a good look around and pushing a few things gently...I gave up. I knew the gears were out of sync but I didnt have the expertise to go any more than what I had done. So I put the whole thing back and restarted it. When it restarted I could hear the drive suddenly do something. Sure enough, it went back into place. Works fine. I'm not saying you should go through all that. My guess is that all I really needed to do was disconnect the cd drive and then connect it again and restart. Like I said, I'm not an expert and probably some people might tell you its not a good idea to do what I did. I'm just saying that it worked for me.

  • paigep Level 1 Level 1 (0 points)

    thanks for this… i was having the same issues, on CD would load and import to iTunes but the next CD would not even show up on the desk top!

    so i also tried the suggestions of the post prior to yours..by "M-Ego",  that didn't work… so i got a hammer and … hahaha kidding!

     

    but, the fact that you knew about a 'pin' and a drive out of sync made me think that a tap of two may help… it did.

     

    1st.  with the cover of my mac book pro closed i tapped the underside… didn't do anything, the CD kept being rejected,

     

    2nd.  with the cover open i tapped with my fingers right above the drive (on the speaker ports) with a few quick light taps and that did it….Fixed...

     

    thanks!