Skip navigation

New iMac WiFi problem

4607 Views 31 Replies Latest reply: Apr 7, 2012 9:14 AM by Informatie RSS
  • faustinoac Calculating status...
    Currently Being Moderated
    Jul 8, 2011 7:44 AM (in response to htmarco)

    Hi,

    I already did it but i continue with this problem.

    But if is because of the noise why i didn't hapend days ago?

     

    I just don't know what else to do

    thanks for your time

  • Calindri Calculating status...
    Currently Being Moderated
    Jul 10, 2011 2:41 AM (in response to htmarco)

    Try to change the router's radio transmission channel.

    I had the same problem, then I configured the router channel from "automatic" to a new channel and now it works fine...

  • LOtang Calculating status...
    Currently Being Moderated
    Jul 13, 2011 11:33 AM (in response to htmarco)

    I am having the same problem with a new i5 iMac.  After sleep, it is still connected to the network showing good airport signal strength but connection speed is horrible (judging by the airport extreme log).  I have an older intel core duo with 802.11g that works fine on the network and consistently has a better connection than all of my n devices (MBP and iMac).  I just repaired disk permissions from the iMac boot disc, we will see if that fixes the issue.  Little frustrating...... I too have tried changing transmission channels, and security protocols without success.  

  • LOtang Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 13, 2011 10:37 PM (in response to htmarco)

    To clarify my connection would drop out completely or show connected after sleep with no ability to load web pages, or get the exclamation point airport signal after sleep.  And repairing permissions did nothing.....

  • faustinoac Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2011 12:06 PM (in response to htmarco)

    Hey, i really can't solve this problem and it's getting worst.

    this week i tried to format and re-instal the OSX but nothing has changed.

    i gave up and send to the apple authorized assistence and they told me that there is no problem and everything is normal.

    It is really frustrating.

    i don't know what to do now

  • LOtang Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2011 12:15 PM (in response to faustinoac)

    This discussion may help, eventually:

     

    https://discussions.apple.com/message/15615928#15615928

  • charles260 Calculating status...
    Currently Being Moderated
    Jul 27, 2011 12:57 AM (in response to htmarco)

    I have an iMac 20-inch early 2008 with a 2.4 GHz Intel Core 2 Duo.  Ever since I have owned this computer I have had problems with the wifi dropping out and the only way I can get it to reconnect is to restart the computer.  Sometimes it will go for an hour or two and then disconnect from the router, other times it will do it within 2 minutes of switching it on.  I can turn the wifi off but then if I try to turn it back on it doesn't respond.

     

    Of course it would have been better if I had made a warranty claim in the first year but I didn't - I suppose because I assumed that it was a problem with my router or I hoped that a new release of OSX or driver upgrade would fix the problem.  Apart from this I love my iMac and have an Apple TV, iPhone4 etc so am a convert to Apple stuff.

     

    Since installing OSX Lion 10.7 last week it seems to have gotten worse.  I have been trawling the forums and iMac driver updates from time to time over the last few years to see if Apple had offerred a solution - but they have not.  My conclusion is that there is either a hardware issue with the internal wifi chip or some other physical design flaw with the imac which interferes with the radio signal, a wifi chip firmware issue or a driver issue and that the cost to Apple of admitting the problem and having to fix it for free on thousands of iMacs means that they have adopted the policy of not fixing it and leaving thousands of users hanging out to dry.

     

    I have changed ISP at least 4 times in the past four years (I live in London so there is plenty of choice) and got a new (different brand) of wireless router each time - so I don't think it is a router issue.  I have an iPhone4 and iPad1 which never drops the wifi signal and an IBM laptop which never drops out.  It is only the iMac.

     

    I have been through most of the fixes suggested - changing the channel to 11 or a lower number, removing and adding a new WiFi interface, turning off the IPv6 (or whatever its called), changing from WPA to WEP etc etc - all with no success.  Since it has gotten worse this week I am now going to buy a mac-compatible wifi dongle and see if this helps.

     

    I guess I will eventually just buy a new iMac and hope the Wifi works properly on the new one, but I live in hope that Apple will do the right thing and recall the product including the ones out of warranty (paying such a high price for a product means that under consumer protection law it should work for longer that the statutory warranty period of one year - but who is bother with the expense of going to go to court over that: maybe we should start a class action!).

     

    (I just tried to post this reply and what do you know - my internet has dropped out so the webpage is not responding.  I will have to restart my computer and log back in to this forum and post the reply.  I saved the text in textedit as I have learned to take precautions after dealing with this issue for over 3 years!)

  • renatofromcorte palasio (lo) Calculating status...
    Currently Being Moderated
    Aug 19, 2011 9:33 AM (in response to htmarco)

    benvenuti nel problema WiFi, Io riuscivo, bene o male a navigare ,( io ho un iMac 20 pollici dei primi del 2008), dopo aver installato LION non sono più riuscito a navigare, nemmeno via cavo, io credo ci siano problemi sulla scheda Airport che non è stata aggiornata, spero trovino la soluzione.

    Come voi altri miei computer lavorano perfettamente.

    Fatemi sapere se siete riusciti ad avere qualche risposta.

    Saluti

  • cjoe71 Calculating status...
    Currently Being Moderated
    Sep 16, 2011 1:04 PM (in response to charles260)

    Hi Charles,

     

    My iMac just started doing exactly what you describe. I installed OSX Lion, and there you go....my wifi started jumping on and off without any notice or me doing anything. It is so frustrating. Apple - I think you have a soft or hardware problem that is creating this problem. Please do something about it!

  • renatofromcorte palasio (lo) Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 16, 2011 1:22 PM (in response to htmarco)

    Mi sembra che il problema sia conosciuto e che tutti abbiano lo stesso difetto, che non dipende dal Router o dalla connessione, ma da un problema di compatibilità della scheda airport con il nuovo sistema LION.

    Ho le prove di questo perchè sullo stesso iMac ho montato sia Lion che Snow e questi problemi li ho solo con lion.

    Devo dire però che neanche questo è del tutto vero, infatti con il MacBook sul quale ho installato il sistema operativo Lion, tutto funziona perfettamente; ho provato a impostare l'iMac come il iMacBook, ma senza risultati.

    Il 22 di settembre ho un appuntamento telefonico con l'assistenza Apple, vediamo un po cosa mi dice.

    fatemi sapere se avete risolto il problema.

    Ciao

    Renato49

  • Jabbamanno Calculating status...
    Currently Being Moderated
    Oct 25, 2011 9:08 AM (in response to htmarco)

    Ciao a me è capitato di risolvere il problema sull'iMac di una amica.Soluzione:

    è un problema di kext(kernel extension) della scheda Atheros installata e del cattivo funzionamento con Lion;quindi seguendo questa guida si installa il kext della scheda di SnowLeopard(previo backup dell'originale)e si riparano i permessi:

    http://rys.pixeltards.com/2011/09/04/osx-lion-wifi.html

    Dopodichè si setta in "Network"-->"Avanzate"-->"configura iPv6-->"solo link locale" e sotto Hardware il valore personalizzato di "1492" invece che automatico a 1500.

    ciao

  • jeroen184 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 2, 2012 3:24 AM (in response to htmarco)

    All,

    I have the same issue with a brand new Lion iMac, not with a Snow Leopard MacBook Pro. When I switch off N-Band of my AVM Fritz!Box router (operating in 801.11b-g ONLY) the problem disappears. If connected to a Time Capsule on 802.11n: no problem.

    Seems to me it's Apple 802.11n in Lion causing the problem, and maybe only in certain Airport cards.

    Hope this helps, seen no Apple fix yet.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.