Skip navigation

iPod with usb cable and iTunes logo!?!?!

10138 Views 9 Replies Latest reply: Nov 12, 2012 11:24 PM by nancydgf RSS
sabrinafrombaltimore Calculating status...
Currently Being Moderated
Jul 7, 2011 3:19 PM

My iPod is keep showing a USB cable with an arrow pointing to the iTunes logo.

What do i do?

  • lllaass Level 10 Level 10 (135,430 points)

    What it is indicating, connect the the iPod to its syncing computer (that has iTunes) via the USB cable.  If you do not get a message from iTunes of what to do, restore the iPod via iTunes.

  • roman40 Calculating status...

    I have exactly the same problem.. Mine went into freeze mode whilst trying to update pod thru itunes..

    I too do not know what to do from here... I have tried some of the solutions offered but still no luck..

    I have to confess i do not know how to restore i-pod touch thru i-tunes... can someone give some direct instructions for those of us who are not so technically savy.... thanks... much appreciated.....

  • lllaass Level 10 Level 10 (135,430 points)
    Currently Being Moderated
    Jul 7, 2011 3:38 PM (in response to roman40)

    To restore, following the instructions in the restoring topic of:

    iTunes: Backing up, updating, and restoring your iPhone, iPad, or iPod touch software

  • Evilw0rm Calculating status...

    Just like lllaass replied to me in my post, going to http://support.apple.com/kb/TS1538 helped me a lot. I was updating my drivers, but I didn't try to _only_ update the usb root as described (not the 2 exclamation marked drivers). Btw, I use Win Xp, so I followed that part in http://support.apple.com/kb/TS1538

     

    Good luck!

  • roman40 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 7, 2011 3:45 PM (in response to lllaass)

    Thanks for such a quick reply lllaass...... really appreciate ya feedback....... will get back on tmrw and have and have a crack once i`ve given my throbbing brain some pillow time....... Thanks again........

  • MightyCrunch Calculating status...
    Currently Being Moderated
    Jul 8, 2011 1:45 PM (in response to lllaass)

    Hi. How many hours is this supposed to take? I had the same problem when restoring mine. I've been waiting for two hours waiting for this icon to be replaced with the usual opening screen. I went to itunes, synced with my library and hit restore and now nothing.

     

    Message was edited by: MightyCrunch

  • roman40 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 8, 2011 1:54 PM (in response to lllaass)

    Hi.... have tried to update to new itunes version in order to restore frozen ipod... but half way thru the download... i`m warned that the software isnt compatible with my windows xp, and that it will corrupt my laptop if i continue.

     

    Do you know where i would find the compatible xp download in order to proceed from here.,,.... It seems that every solution creates a new problem..... All other apple downloads appear to hit my system without any issues, apart from itunes newest version.. which without it , obviously brings me again to a brick wall... Any info greatly received.. Thanks..

  • MightyCrunch Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 8, 2011 4:28 PM (in response to MightyCrunch)

    I searched some more and found a couple of things which seem to have worked for me. First, I went to control manager, typed in Services ( for Vista in this case) and opened to Apple Mobile Devices. I stopped the service, then started it again. I selected properties and made sure it did so automatically. Then I restarted my computer. The first part of my problem could have been iTunes.

     

    Then I found this elsewhere:

     

    Note: If you see the message "Charging... Please Wait" or you see the screen pictured below, let the device charge for at least 10 minutes to ensure the battery has some charge and then start with step 2 again.

    Continue holding the Home button while iPhone starts up. While starting up, you will see the Apple logo.

    When you see "Connect to iTunes" on the screen, you can release the Home button and iTunes will display the recovery mode message:

     

    Once I plugged in while holding the Home button my iTunes asked again if I wanted to restore. I tried it one more time and this time it seemed to go through the entire process which it didn't the first time as it never gave me an option to restore from my iPod. This time it did a restore, synced up for a while and now seems to be fine.

     

    My original problem by the way that had me restore it was my battery life was really short on an iPod Touch 4 less than a year old. The Apple Store in my town told me to try this as their diagnostics indicated that the battery was fine but it seemed to be telling me it was down to 20% long before it was. Though letting the battery run out didn't take more than 1/2 an hour or so after getting my low battery message. Hopefully this is fixed too.

  • nancydgf Calculating status...
    Currently Being Moderated
    Nov 12, 2012 11:24 PM (in response to sabrinafrombaltimore)

    What worked for me is I changed the USB port on my computer... sounds silly but I have 2 USB ports 3.0 which are faster. I plugged it to the regular one and it worked. Hope it helps!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.