Previous 1 2 Next 25 Replies Latest reply: Jan 8, 2013 10:49 AM by Kyle McCormack Go to original post
  • Lonewolff Level 1 (0 points)

    Yeah, I have a free dev account. So, I'll have a dig around and have a look.


    Thanks for the link and all of your help,


  • Lonewolff Level 1 (0 points)

    Oh man, you would not believe it.


    Apple have done this on purpose. I found in another thread that if you turn off time sync and take the date back a year it installs perfectly.


    So, Apple have purposely neutered the packages, to force people to upgrade,


    It has all installed ok now (after the 20th attempt). Now I just need to reset the date again.

  • HyperNova Software Level 6 (8,615 points)

    Well, for one thing, the version of Xcode you're using is older than the hills.


    The latest version is 4.3.2 which does require paying the $99 fee but if you're at all serious about developing for OS X, that's what you should do.  The free stuff is just for playing around.


    Plus, the paid account offers a boatload of resources that you won't get anywhere else.


    Good Luck in whatever you do.


    I sincerely hope you don't give up on Mac development.

  • Lonewolff Level 1 (0 points)

    Not to forget the fee of having to upgrade to Mountain Lion too. As, Xcode 4.3.2 will not run on Snow Leopard.


    The latest for Snow Leopard 4.2 apparently needs the 'date rewind' as well, as apparently the package expired a few weeks ago.


    See link below;



    Thank for your help though, Michael. I do plan on toughing it out and giving Mac's a fair go. It is just a frustrating start, thats all.


    It just seems that Apple purposely go out of their way to force unneccesary upgrades, for people who just want to give it a go (to start out).


    It feels once you start a relationship with Apple, they are in your pocket for life. Same deal with my iPod Touch I bought a few years ago. Had it for a week and then had to pay $5 for the next iteration of bug fixes.


    Who knew that Microsoft was getting a bad rap all these years for nothing. Once you buy the OS, all developer tools are freely available for life. Knowledge, time, and staffing constraints aside, it doesn't cost an extra cent to develop AAA titles such as Crysis, Halo, etc..


    Sorry about the rant. I really want to keep an open mind (and just start developing).

  • Keith Barkley Level 5 (5,925 points)

    Visual studio free?

    Not hardly, try $500 for the "Pro" version: overview


    And you have no idea whether Visual Studio Express versions will be "free for life."

  • Lonewolff Level 1 (0 points)

    The express version has been free for the past 10 years (admittedly 2003 was compiler only).


    So 'kids' can try their hand at programming for free and not have uncle Steve standing out the front of their house holding a bag of candy for 'just $99 (per year too!) + $35 for OSX 10.7.3'. If people dont want to use the express versions of they can use a plethora of free alternatives.


    You don't require the 'Pro' versions to code anything 'better'. The express versions dont hinder the actual coding in anyway.


    The Pro versions only give access to better tools for debugging, content creation, etc...


    If the code compiles on the Pro versions, it will compile on the Express editions as well.


    And yes Microsoft's own site states that the Express editions are 'Free for life'.

  • greid Level 1 (0 points)

    I have had this problem too and I think the reason the installer is failing now (in 2012) is different than before.


    In particular, if you view the Log File in the intsaller app (an often-overlooked feature of Installer) you get to see the actual error in install, which for me was that the IOS SDK installer is untrusted (i.e. the certificate has expired).  I think that the workaround proposed by one poster to set the date back on the computer works around this, but a better solution would be for Apple to update the certificate, which seems unlikely because they don't care about the past so much.


    I deleted the .dmg after the third failure but I might try one more time, resetting the date, to see if that in fact works around the "untrusted" cert issue.  I will report back if I do that.

  • greid Level 1 (0 points)

    I did try the install with the date set back one year, and it succeeded. This was the same installer, and same system, which gave the "untrusted" error before.  So I think it is an expired certificate in the IOS SDK installer, and setting the date back a year works around it, FTW.

  • qufighter Level 1 (0 points)

    Running software update fixed the problem for me.  I had recently installed the combined 10.6.8 v1.1 update, and the installer was failing with "this installation failed" unknown installation error.  The logs had similar errors about invalid certificates to those other users are reporting. 


    I ran software update again suspecting something new was available, and sure enough there was Security Update 2012-002 and Java for 10.6 update 8 and a Safari update.  After updating those I tried the installer again and it seems to be installing fine.  Perhaps some certificates were out of date and the upgrade fixed this issue.

  • SameSky Level 1 (0 points)

    Thanks! Rolling the date back a year worked for me, at least it is writing files now, after 3 downloads and 4 install attempts!

  • Kyle McCormack Level 1 (0 points)

    I am doing this exactly same thing and yet my Xcode won't install!

Previous 1 2 Next