Previous 1 2 3 Next 36 Replies Latest reply: Dec 4, 2014 6:45 PM by William Boyd, Jr. Go to original post
  • jacob.schooley Level 1 Level 1

    Actually, I think it is an issue with the AirPort. I had this same problem and was able to fix it. All credit goes to mike from


    Unplug all external drives, including your Time Machine drive (God bless you if you have a Time Machine drive). Start up the computer and immediately hold down ⌘R (Command and R) until the spinner comes up. Or you can hold down ⌥ (Option) and then click on Recovery. Wait for the recovery to load.


    Now click on Utilities in the menu bar, and click Terminal. Terminal will open and display a prompt.


    Type and run these commands:


    cd /Volumes



    It will display 3 or 4 items. Ignore the ones with a dot in the front. One of them should say "OS X Base System". Ignore that. Another one will display "Macintosh HD" or whatever your startup disk is named. Run: (replace Macintosh HD with whatever your startup drive is named. Make sure to include the quotes if your drive name has spaces in it, which it most likely does.)


    cd "Macintosh HD"



    It should display the contents of the root of your drive, including Applications, Library, System, Users, and a zillion folders with dots on the front. Ignore the ones with dots on the front. These are hidden files that are invisible in Finder and messing with them could really mess up your computer and your important files. Run:


    cd /Library/Preferences/SystemConfiguration


    Now the important part. Rename the config file that controls the AirPort to something the computer won't recognize. Do this by running:





    Your computer will now reboot. When it boots up it should do so normally without freezing. From now on, keep the AirPort on!!! I know you may want to turn it off to save battery life once in a while, but if your Mac is like mine it will unexpectedly freeze in the middle of something and I'll have to force reboot, and if the AirPort is on the computer will get stuck.


    Hope this helps you!

  • aqualover001 Level 1 Level 1

    Hey Jacob. Thanks a lot for sharing. I think I have the same problem as you.


    Do you know why this happens? Is this some sort of software error? If so I'm guessing reformating the mac would settle it no?


    Have you heard of another way of fixing this though? From what I read, your explanations help unfreezing the computer but won't prevent it from freezing if we turn off airport again.

    I also had one last question. I followed all your instructions but when I type cd/Volumes it tells me that the directory doesn't exist. Do you know if I am doing something bad?


    Thanks a lot! This post really saved my life!



  • jacob.schooley Level 1 Level 1

    You type "cd /Volumes" not "cd/Volumes". cd is the command and /Volumes is the directory.


    And no, I haven't found a way to get this to stop. I wish apple would read these forums and fix the issue. Just wondering, what Mac do you have the problem on? Mine is a 2007 MBP (MacBookPro3,1) but it would help to know all the Macbook models that have this issue.

  • Eric Root Level 9 Level 9
    Mac OS X

    Apple doesn’t routinely monitor the discussions.


    Send Apple feedback. They won't answer, but at least will know there is a problem. If enough people send feedback, it may get the problem solved sooner.



  • aqualover001 Level 1 Level 1

    Thanks a lot Jacob. I haven't turned off my airport since my problem so I haven't had the chance to test that. I'll def try and remember the space next time


    I have a MBP bought in June 2007. 17''.


    Maybe one day I'll go to the apple store and try to see with the genius bar if they know the problem. But since I don't have a warranty anymore I'm pretty sure that whatever they say, I won't fix it.

  • rubefink Level 1 Level 1

    I tried this fix but the file doesn't even show up under my SystemConfiguration folder.

    When I try the command it says no such file exists. Any idea why and where it might be. I'm running mountain lion on a early 2008 macbook pro.

  • William Boyd, Jr. Level 6 Level 6

    rubefink wrote:


    I tried this fix but the file doesn't even show up under my SystemConfiguration folder.

    When I try the command it says no such file exists. Any idea why and where it might be. I'm running mountain lion on a early 2008 macbook pro.

    When you write "When I try the command" what command do you mean?


    Using the Finder, open the top level of your boot volume. You should see folders starting with Applications (probably) and ending with Users. (If you don't see  Users folder you're in the wrong place.) Open the Library folder. In that open the Preferences folder. Look for the SystemConfiguration folder and open it. On my Mac that folder contains 18 items, although your count may be different. Do you see any files with names that start with

Previous 1 2 3 Next