Previous 1 2 3 4 Next 49 Replies Latest reply: Apr 4, 2014 4:44 AM by DG1234567 Go to original post
  • dustobub Level 1 Level 1

    Would you please refer me to other places that have discussed this issue? I do believe there is a bug in here somewhere as strange as it might seem. Displaying the photo in means nothing as it's just showing the embedded jpeg in the nef. I'll be doing some more testing this weekend.




  • David Gordon Level 1 Level 1

    Quote "Aperture _never_ modifies the original files."


    Not strictly true. Writing IPTC to Master files obviously modifies the original file, as does changing the file name and applying to Master. The OP hasn't said if they are doing either of these. I have had Aperture destroy TIFF files when changing the file date and having the app write that back to the original -- although that bug seems to have been squashed some time ago.


    Although I tend to agree about a faulty card reader ...

  • dustobub Level 1 Level 1

    I haven't seen anymore corrupt files yet, but I haven't taken a close look through my whole library. The strange thing was that the files that I saw corruption on were files that I had previously edited and definitely had no corruption. Further evidence of something fishy was that when I restored a Time Machine version of that master (from the Aperture masters folder) it solved the corruption. So I don't believe my issue is related to a faulty card reader, though I can't speak to the OP's issue.

  • dustobub Level 1 Level 1

    So I've replicated this issue once again and still don't have any idea what's going on. If I export the master NEF and then re-import the exported NEF it's fine. Both NEFs (original + copy) are the exact same file size in bytes as reported by finder get info. Exported jpegs from the corrupt master does not show the corruption. Check the attached photo. Anyone have any ideas?




    Screen Shot 2012-05-13 at 10.23.12 PM.png

  • David Gordon Level 1 Level 1

    So if you can export either a Master or JPEG and they show no signs or corruption, the original cannot be corrupt. Surely only the preview image in Aperture is corrupted.


    What happens when you rebuid the preview for a corrupted image?


    And if you manually copy a 'corrupted' image file (using Finder) and open it in another application, is it still corrupt? If not it would point back to the Aperture preview being the problem, not the original file.

  • dustobub Level 1 Level 1

    I am able to see the corruption when zooming in 100% as well. Regenerating thumbnails/previews doesn't fix it. The NEF appears to be good, but aperture is doing something funky with it. I actually just restarted the computer and both files appear fine now. However, when this happened a few weeks ago, a restart didn't fix it. I guess I'll need to wait for it to happena again.

  • joshb Level 1 Level 1

    I'm seeing this same corruption. I can only find that I can "mask" it in Aperture by switching to JPEG as the original. And if I duplicate the version the new one is just as bad. However if I then go look at the disk (Show the contents of the Aperture library) I see the original is just fine and the duplicated file on disk has the corruption in it. I can copy the original file out. Delete it in Aperture. And re-import it and all is good. A pain to do so and I'd hope something more concrete comes up soon.




    Searching “2012”-3.jpg


    It also does not appear to have anything to do with editing in my case as it happens to images that haven't been edited or which haven't been recently changed.


    Message was edited by: joshb to reflect it's not just on edited images

  • joshb Level 1 Level 1

    I've done some more investigaiton today having found a lot of corrupted RAW (NEF) images in my main library (iMac Late 2009 with an external Promise SmartStor DS4600). I imported most of the images originally on a laptop to a different external drive. So far every one of the "bad" images in the library on the DS4600 are fine when I look at them on the disk they were originally imported to.


    Despite what I'd said previously many of the "original" NEF files in my library on the RAID are indeed bad. My guess is that if the album has been moved the image corruption is made permanent.

  • Ernie Stamper Level 8 Level 8

    Promise SmartStor DS4600)


    How is this external disk formatted?  Is it properly Mac OS Extended (Journalled)?



  • joshb Level 1 Level 1

    Good question. It is Mac OS Extended but not (Journaled). is a bit ambigious in this regard as the title mentions only Extended but the instructions say journaled. I'll get some more space and try transitioning it.

  • MacCanon Level 1 Level 1

    Good news from my side: no more corruption of my raw images and no more corruption of my photobooks in Aperture. After a couple of weeks in the shop and a significant number of tests, the conclusion was that there is nog enough RAM. All other components seemed to work fine. So, shifted from to 2GB to 4GB and just ordered my photobook without problems. Not sure if his will help the problems you are experiencing, but it helped for me at least.

  • HSK Level 1 Level 1

    Wow! I'm glad I'm not the only one with this problem.


    I began to migrate a large single library from an external drive to a new drive. I decided to trim down the size of the library by splitting it into smaller projects. The data corruption issue began as soon as I tried using the new external drive.


    I get this:


    Screen Shot 2012-09-12 at 10.44.06.png


    I've been through all the usual fixes, and even importing the library into a new blank library doesn't fix it. Hopefully all my master RAW files are clean, but I can tell you it's taken a **** of long time to get nowhere fast.


    2007 MacBook Pro, Lion 10.7.4, Aperture 3.3.2. Libraries live on external drives due to lack of hard disk space in the MBP. Currently, I have four libraries spread across three disks, and my original old "Master" library is still intact, and fixed at 31 August.


    The problems began after starting to use the new external disk. I think there may have been a low-level error with the factory formatting (was Mac OS X compatible, G-Drive mini 500GB). I've reformatted it, and the problems have happened again.


    So, do we think this is an Aperture bug? Or is it hardware related? I've not had any issues with the software or hardware setup until this last week. If Apple wants me to switch to Lightroom (which I really don't want to do), they are making a damned good job of it.

  • joshb Level 1 Level 1

    In my experience there may be two things contributing (or maybe 3).


    I saw this on a machine with these three factors:

    1. Locally attached but slow (firewire 800 RAID-5) disk writes
    2. Memory bound machine (2009 iMAC) ... not always memory bound but sometimes encountered lots of swapping with iTunes memory leaks and over-eager backup processes
    3. Disk was formatted with Extended (but not Journaled)


    By contrast using a G-Drive on a newer mac mini hasn't expereinced these problems.


    Unfortunately in my case when I look at the master photos (raw) in the aperture library in the finder the photos are corrupted there as well. In a few cases the JPEG photos exhibit similar corruption. For me the solution was that I'd fortunately imported most of these photos originally in a separate library and I can copy over the un-corrupted files folder by folder within the Aperture library and that sorts things out.


    I recently moved to a Western Digital thunderbolt drive with RAID-1 instead of RAID-5 and so far things are happier.

  • DG1234567 Level 1 Level 1

    I too use Aperture, and I too get random corruption.  About 75% of the time I am able to quit Aperture and restart it, and the corruption is gone.


    I run a mid 2011 IMAC with 16 GB of ram, so I am definately not memory constrained. Hopefully an update will correct this problem.  I would say that it is looking like it is an issue at reading the NEF AFTER it is imported, not a card reader error, unless the error is something that crops up at random times, long after the image is read in.


    I cannot recall seeing this problem with JPG files.

  • DG1234567 Level 1 Level 1

    I was still getting random corruption in RAW images, but noticed there were other strange issue with my IMAC, ran the Apple Hardware Test, and then memtestx, both utilities pointed to memory errors, further testing narrowed the error down to a single dimm.  Pulled that offending dimm out, and everything has run fine so far on 12 GB instead of 16, including Aperture.


    Might want to consider adding memory errors to the list....


    Hopefully this also cured my ITUNES .ITL corruption as well.  It sort of all fits.