3 Replies Latest reply: Aug 14, 2011 6:45 PM by adamviolin
i2 Level 1 Level 1 (80 points)

After I installed OS 10.6.8 when I try to sign out of Hotmail I get an error message from Windows Live that says that it couldn't sign me out because my Safari 5.0.5 browser is blocking cookies. This perhaps is a false error message. I do have the Preferences set to always accept cookies and Hotmail wouldn't let me sign in without cookies being enabled. If I turn Private Browsing on, the sign off works normally. Also, Firefox works normally with 10.6.8. I have seen several other threads that are reporting cookies always accepted after the 10.6.8 update. I have tried a number of fixes: Repair Permissions, Reset Safari, delete Cookies folder, delete top sites, etc, but I still get the (false?) error message. When I boot off a hard drive with OS 10.6.7 that I cloned before the 10.6.8 update, I don't get the error message.

 

Any suggestions?


iMac 2007 Intel Aluminum Core 2 Duo 2.4 GHz, Mac OS X (10.6.8), PowerBook G4 TI Mac OS X (10.4.11)
  • Carolyn Samit Level 10 Level 10 (95,950 points)

    Try the Mac OS X 10.6.8 Update Combo

     

    Then restart your Mac.

     

    You could also try deleting your Hotmail keychain. Open Keychain Access.

     

    /Applications/Utilities. Select Passwords on the left. Delete the Hotmail keychain.

     

    Quit then relaunch Safari. Navigate to your Hotmail account. Enter your user name and password. You should be prompted to save that data to a new keychain.

     

    You might want to consider accessing your Hotmail account via Mac Mail rather than using web based mail.

  • i2 Level 1 Level 1 (80 points)

    There was no Hotmail keychain in Keychain Access. There is no prompt to save it when I log into Hotmail.

     

    I used the OS 10.6.8 Update Combo when I did the update originally, but I may reinstall it if I can't figure this out. I didn't want to try a reinstall until I had tried other approaches.

  • adamviolin Level 1 Level 1 (0 points)

    The same thing is happening to me and nothing I have tried or that people have suggested in any other forum has worked. I just updated to 10.6.8 and then updated Safari to 5.1 and it's still not good. Alot of people have been complaining about this and also the cookie handling in 5.1 and so far Apple just isn't addressing the issues. Hotmail help according to alot of people is also useless. I'm using Firefox until they get this all fixed, but I have to say, I'm very disappointed in Apple this time around, especially since people have been talking for over a month and they haven't fixed it.