8 Replies Latest reply: Aug 1, 2013 12:43 PM by lidiafromlondon
mz charles Level 1 Level 1 (0 points)

I'm not sure it's relevant, but, apparently (I didn't try to turn it on since then), ever since I had Snow Leopard re-installed (unrelated problem) at the Apple Store Genius bar, I can't turn on my built-in Airport (??!!?).

I turn it off when I'm at my desk - I prefer a wired Ethernet connection to the I/Nt there. But, of course, I turn it back on when I'm mobile with my MacBook Pro.

So, I haven't been "mobile" since my Apple Store Genius visit on 16 Jun '11.

Yes, I intend to go back to them, but I thought I'd give this blog a shot first …

 

Any ideas out there ??


MacBook Pro, Mac OS X (10.6.8)
  • Tesserax Level 8 Level 8 (49,860 points)

    Please try the following steps, in order, or until resolved:

     

    Step 1

    • In Finder, go to /Library/Preferences/SystemConfiguration
    • Move (not copy) the preferences.plist file to the OS X desktop.
    • Restart the computer.
    • Verify if you have connectivity. If not, go to the next step.

    Step 2

    • In Finder, go to /Library/Preferences/SystemConfiguration
    • Move (not copy) the NetworkInterfaces.plist & com.apple.airport.preferences.plist files to the OS X desktop.
    • Restart the computer.
    • Verify that you have connectivity. If not , go to the next step.

    Step 3

    • In Finder, go to /Library/Preferences/SystemConfiguration
    • Move (not copy) the entire SystemConfiguration folder to the OS X desktop.
    • Restart the computer.
    • Verify that you have connectivity. If not, go to the next step.

    Step 4

    • Open a Terminal session. The Terminal application is located in /Applications/Utilities.
    • At the command prompt, enter ifconfig -a
    • Locate the network interface that is giving you trouble. (Note: en0 = Ethernet; en1 = AirPort)
    • Look to see if Terminal indicates the problematic interface is not enabled.
    • If not enabled, enter sudo ifconfig en0 inet up (Note: Replace en0 with en1 as applicable.)
    • At the command prompt, enter ifconfig -a
    • Verify that the problematic interface is now active and various network interface related data should now be listed.
  • mz charles Level 1 Level 1 (0 points)

    I'm sorry I couldn't respond until now, but thnx Tesserax - your Step 1 did the job, altho I couldn't move that file to the desktop (it copied it, no matter which keys I pressed), until I got around it by moving it to the Trash (w Admin pernission), then took it out of the Trash to the dsktp. And, of course, I lost my other memorized locations, but that's a minor point.

     

    The question still remains in my mind as to why this happened in the first place: the OSX reinstall?? Why the corrupted pref file? I've had previous WiFi connections prblms with my previous MacBk (Tiger?) which was resolved w an OSX update, but never until this one w my MacBk Pro.

     

    Thnx again for the help …

  • Tesserax Level 8 Level 8 (49,860 points)

    The question still remains in my mind as to why this happened in the first place: the OSX reinstall?? Why the corrupted pref file? I've had previous WiFi connections prblms with my previous MacBk (Tiger?) which was resolved w an OSX update, but never until this one w my MacBk Pro.

    Preference files (aka .plist files) can get corrupted or go "missing" for all sorts of reasons. These are normally created by either the operating system or specific applications. At any time, something can (& will go) wrong when these files are either created or updated.

  • mz charles Level 1 Level 1 (0 points)

    OK, Thx again, Tesserax …

  • Rudalz Level 1 Level 1 (0 points)

    I have macbook unibody 2008 2.4 GHz and I had this problem previously. Luckily, Tesserax's solution solved my it at the step 1. Thanks man!

  • pascalstoffels Level 1 Level 1 (0 points)

    Tesserax you rock !!

     

    I used your command line on a macbook unibody 13" that wouldn't activate it's airport in no other way.

    It worked like a charm !!

     

    sudo ifconfig en1 inet up     ..... did the trick !!

     

    thank you!!

  • J. Koch Level 1 Level 1 (0 points)

    I had the same problem--MacBook Pro (4,1), OS 10.6.8, kept selecting "Turn AirPort On" but nothing happened.  Found this posting, and Step 1 fixed the problem. 

     

    I've saved the list of steps to my hard drive, just in case.  Thanks, Tesserax!

  • lidiafromlondon Level 1 Level 1 (0 points)

    Thank you so much for this ultra clear solution.

    Likewise  I have just upgraded to 10.6.8 and wireless disappeared.

    Step 1 of your instructions solved the problem