1 Reply Latest reply: Jul 11, 2011 2:27 PM by lllaass
SpoileddBabee Level 1 Level 1 (0 points)

Ohk so I've only had my Ipod touch 4th generation for about 3-4 weeks now. No problem but recently my itunes wouldn't open when I plugged it in. Only the other thing to import pictures. So I tried opening itunes seperatly, it wouldn't. So my sister had turned my computer completely off for something else and before that I had downloaded the newest version of itunes and when she turned it back on it opened and is working fine , I guess it worked bc I downloaded the latest version even though i had to before to plug in my new ipod. So now I wanted to maybe get some new apps but I can't find the ipod in the itunes , where it usually lets you click on it . Like it isn't even plugged in apparently ! So i check my itouch and it isn't even charging ! Likee *** ? I don't know what to do. I have my old ipod nano and plugged it in using the same cord I got with the new ipod . It is charging that one and then I retried my itouch but it won't charge it. Iknow the cord is ohk bc the i touch was off and when I plugged it in , it turned on. Why won't it charge though?!

 

Please HELP !

Thank youu (:


iPod touch