13 Replies Latest reply: Jul 14, 2011 9:26 AM by Linc Davis
aac0300 Level 1 Level 1 (0 points)

When i power my Macbook, it goes to a blue screen and continues trying to load but never gets passed this blue screen. What do i have to do?


MacBook Pro, Mac OS X (10.6.8)
  • Joe 2792 Level 1 Level 1 (25 points)

    There are a few things to try:

     

    1) When you boot, hold down the shift key and boot into safe mode.  Does it then start up?

     

    2) If possible, boot from a known-good install on an external drive.  Does it boot to a desktop?

     

    3) If possible, boot the OS recovery DVD that came with the system.  Does it boot to a desktop?

     

    4) If possible, boot the Apple Hardware Test DVD that came with the system. Does it boot? Did the unit pass?  If it failed, what was the failure code(s)?

     

    You did not say what kind of Macbook Pro you have.  Which model is it?

     

    It is possible that you have a hardware problem.  The blue screen right before the MacBook switches into "regular" graphics mode.  There are a few things that happen then, including the powering-on of some peripheral interfaces, like the FireWire port.  There may be something not starting up that is "holding" the OS boot while the OS waits.  Safe mode may bypass a failed piece of hardware and allow a boot.  This would require a logic board repair or replacement.  You may also have a problem with a peripheral like a camera, Bluetooth card, Airport card or an optical or hard drive.  You would have to disconnect these in sequence to see which one is failing.

     

    It is also possible that you simply have corrupted software or a software conflict has developed.  This happens quite often.  Luckily it is usually easy to fix with a Mac.  If the system boots and works from a known-good install, you are fine.  If you can boot the install DVD or Apple Hardware Test (and it passes), you are probably OK.  The best thing to do in the case is to boot the installer DVD and do an "Archive and Install".  Archive and Install will create a new system folder, transfer your settings and preserve your applications and data.  As always, it is advisable to do some sort of backup before an install, if you can.  In your case, this would involved booting from an external drive and copying you important files.  The Archive and Install should work, but better safe than sorry.

     

    Joseph Kouyoumjian

    MicroReplay

  • johnl927 Level 3 Level 3 (565 points)

    Turn off the machine!!!
    1) press the power button
    2) Press and hold command + S
    3) The screen will turn black and a bunch of text will appear, when it all stops!
    4) Type fsck -f ( this will do a file system check )
    5) Once that is done ( stopped )
    6) type reboot

     


    Let us know the outcome!!!

  • mysterycommand Level 1 Level 1 (0 points)

    I also am having a problem like this. MacBook Pro Intel i7 purchased 10/12/2010. I have tried:

     

    1. Start up the regular way. Chime. Apple logo. Blue screen.

    2. Start up with Shift key down (safe boot). Chime. Apple logo. Grey progress indicator. Blue screen.

    3. Start up with AppleCare disk and D key held down (hardware test). Passes the regular test. Didn't do the extended test. Restart. Chime. Apple logo. Blue screen.

    4. Start up with Cmd S keys held down (single user mode). Run "fsck -f". Wait. Run "reboot". Chime. Apple logo. Blue screen.

    5. Start up with original Mac OS X Install DVD and C key held down (boot from disk). Chime. Apple logo. Lots of disk noise. Joy!

    5.a. Repair Disk. The volume appears to be OK.

    5.b. Repair Disk Permissions. Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAg ent" has been modified and will not be repaired. Permissions repair complete.

    5.c. Quit Disk Utility. Quit Mac OS X Installer. Restart. Chime. Apple logo. Joy!

     

    Hopefully this is a permanent solution, and not just a temporary fix. Hopefully this helps someone else.

     

    //Matt

  • Linc Davis Level 10 Level 10 (169,200 points)

    The only part of what you did that actually changed anything was the safe boot. It rebuilt system caches that may have been outdated or corrupt. That should always be the first resort in case of a boot failure.

  • mysterycommand Level 1 Level 1 (0 points)

    That's curious to me, since I did the Safe Boot in step two (the first thing I did when I saw there was a problem) and it didn't boot to a desktop in "Safe Mode" and it didn't boot to a desktop at all through three more steps. Steps which you seem to be saying didn't do anything anyway.

     

    As a side note, my computer has been running with fans at full blast since it finally started up. Not sure what that's about either since it doesn't feel particularly hot.

  • Linc Davis Level 10 Level 10 (169,200 points)

    As a side note, my computer has been running with fans at full blast since it finally started up.

     

    Launch the Activity Monitor application. Select "All Processes" from the menu in the toolbar, and click on the heading of the "%CPU" column to order the process table by CPU usage. You may have to click it again to get the table in descending order. What is the most active process (excluding activitymonitord) and what is its usage?

  • mysterycommand Level 1 Level 1 (0 points)

    Dock 100% … that doesn't seem right, right?

  • mysterycommand Level 1 Level 1 (0 points)
  • Linc Davis Level 10 Level 10 (169,200 points)

    In that case, the safe boot didn't do anything either, except temporarily.

  • mysterycommand Level 1 Level 1 (0 points)

    Okay, so I'm still having problems. Last night when I shut down my computer it hung at a blue screen and never totally shut down … there was a spinning indeterminate progress wheel, but otherwise just the standard blue screen.

     

    This morning when I realized that my computer had been sitting all night like that, I held the power button down to force shut down the machine. When I started it up again I got the old familiar blue screen. Then:

     

    Force shut down again.

    Start up in safe mode.

    It worked!

    Restart.

    Blue screen.

    Force shut down.

    BLUE SCREEN!

    Force shut down again.

    Start up in safe mode AGAIN.

    It worked!

     

    So, my problem seems to be intermittent … that is, sometimes safe boot works, sometimes not, but pretty consistently regular boot doesn't seem to want to work. Is there anything else I can try? Moving some items from the Users/matt/Library?

     

    Thanks,

    //Matt

  • Linc Davis Level 10 Level 10 (169,200 points)

    Launch the Terminal application, copy or drag -- do not type -- the following command into the window, then press return:

     

    kextstat -kl | awk ' !/apple/ { print $6 } '

     

    Post the lines of output, if any, that appear below what you typed. You can then quit Terminal.
  • mysterycommand Level 1 Level 1 (0 points)

    com.kaspersky.kext.klif

    com.parallels.kext.prl_hypervisor

    com.parallels.kext.prl_hid_hook

    com.parallels.kext.prl_usb_connect

    com.parallels.kext.prl_netbridge

    com.parallels.kext.prl_vnic

  • Linc Davis Level 10 Level 10 (169,200 points)

    Uninstall the Kaspersky garbage and never install any commercial "anti-virus" product again. If that doesn't solve your problem, uninstall Parallels.