8 Replies Latest reply: Jul 12, 2011 6:10 PM by AussieDJ
abillmann Level 1 Level 1 (0 points)

Soon after upgrading my white Intel iMac from Tiger to Snow Leopard, I started having a problem with garbled audio. Audio-only sources (like CDs, streaming radio, iTunes, etc.) is perfectly fine.

 

But audio from QuickTime movies, MP4s, and Flash is horribly garbled. Even small 640 x 480 QuickTime movies have these audio problems.

 

The machine itself is a Core Duo, 2GB RAM and has lots of free hard drive space -- more than 200GB.

 

I'm hoping this might be as simple as trashing a prefs file somewhere, but I really don't know where to start. Any suggestions would be as welcome as a cold beer in mid-July.

  • AussieDJ Level 4 Level 4 (1,435 points)

    Hi abillmann,

     

    That does sound odd. So we can isolate the issue:

     

    What programs have you tried playing the various movies in? iTunes/Quicktime/VLC etc.

     

    Also does the problem exist when you plug headphones in?

     

    Do you / have you ever had an external soundcard installed?

     

    Thanks.

  • abillmann Level 1 Level 1 (0 points)

    The garbled sound happens in every application where there is both audio AND video -- QuickTime, FlashPlayer, iMovie, Final Cut Express. If I pull up a YouTube video, the sound is horrible. If I watch a QuickTime movie or MP4 on my local hard drive, the sound is horrible. (But alternatively, a CD or audio file, by itself, plays fine.)

     

    It almost seems like the processor is being dragged down by something, but Activity Monitor shows very little going on.

     

    The problem is present whether I'm using the iMac's built-in speakers, headphones, and even the optical output.

     

    If it's helpful, it does seem like the bigger the file, the worse the audio. So, the audio on a small QT movie isn't too great, but it's MUCH better than an HD MP4.

     

    (No external sound card... it's an iMac.)

  • AussieDJ Level 4 Level 4 (1,435 points)

    Ok, you could try a PRAM Reset which may lose you some other settings as per the link.

     

    Also, are you booted in 32 bit mode, or 64?

     

     > About this Mac > More Info > Software > 64-bit Kernel & Extensions: yes/no

     

    If no: try rebooting while holding the numbers 6 + 4.

     

    If yes: try rebooting while holding the numbers 3 + 2.

     

    Lastly you could try manually downloading the combo update matching the last one you did (presuming you did one), and re-applying it.

  • abillmann Level 1 Level 1 (0 points)

    Still no luck.

     

    - Tried multiple PRAM Resets

    - Tried booting in 32- and 64-bit modes, as you described

    - Deleted all prefs in Macintosh HD>System>Library>Preferences>Audio

     

    For what it's worth, the video plays perfectly -- very smooth, no problems. The problem is only the audio. It sounds like it's quickly cutting in and out.

     

    I'm running QuickTime 10.0, with all updates applied. (The iMac is running 10.6.8).

     

    Frustrated!

  • AussieDJ Level 4 Level 4 (1,435 points)

    Ok.

     

    Try creating a new user account, log into it & see if the problem occurs there.

  • abillmann Level 1 Level 1 (0 points)

    Yep -- that's the next step. I'll report back later -- I'm stuck in meetings all afternoon. 

     

    Thanks so much for your help so far... I'll be back with more info.

  • abillmann Level 1 Level 1 (0 points)

    I got it -- problem solved! Here's what happened:

     

    I created a new user account, expecting that to solve the problem. But it didn't. I was shocked. Still horribly bad audio but perfectly fine video. Tried a Safe Boot, but apparently QuickTime won't run at all in that mode. Grrrrr.

     

    So I went back to the main user account.

     

    In looking at Activity Monitor again, I realized its list was in alphabetical order, not sorted by greatest CPU usage from most to least. As a result, I wasn't seeing the whole list. When I sorted the list by CPU usage, a support application called "RadioShark Server" popped up to the top of the list, constantly using anywhere from 30% to 40% of the CPU. (Radio Shark is a USB device from Griffin Technologies that tunes in typical AM/FM radio on the Mac. It comes with some marginally crappy software.)

     

    Apparently, with older versions of OS X, RadioShark Server behaved and didn't cause any problems. With Snow Leopard, for whatever reason, it's a background CPU hog. Or at least it was for me.

     

    I selected RadioShark Server in Activity Monitor, and "quit process." I tried a number of QuickTime files and Flash video, and they played perfectly! I rebooted the machine, letting RadioShark Server run in the background again, and again, the audio of the files was awful. Back to Activity Monitor, "quit process" and the audio was fine.

     

    Knowing that was the culprit, I tracked down its location in Library>Application Support>Radio Shark and pulled it out. I rebooted the machine, and like magic, all my audio is perfect again. And as an added bonus, my machine is definitely a little snappier overall. (Funny what a 30% drain on the CPU can do, eh?)

     

    So there it is: RadioShark Server was the problem.

     

    (In fairness to Griffin, there's probably a newer version of the RadioShark software that might work just fine. Admittedly, the version I had was several years old.)

  • AussieDJ Level 4 Level 4 (1,435 points)

    Nice!