Previous 1 2 Next 27 Replies Latest reply: Jun 15, 2015 9:36 AM by JCVela
1 Open Loop Level 2 Level 2 (350 points)

I opened up FCPX and discovered that the test project I created shows the Modified File alert icon for the only media I imported. The clip is red, with the Modified File icon.

 

I checked the FCPX user manual under "Solutions to common media management issues." There I found the description to the Modified File Alert Icon, but there was no solution. It simply states, "A media file has been changed by an application other than Final Cut Pro." It would be nice to find a "solution" to this issue in the "Solutions" section of the manual. It's interesting that Apple also calls the section "common media management issues." Well, they got half the title to the chapter correct.

 

First of all, I'm not sure why I have the issue. I didn't move or rename the file. I took the time to view (purchase) the Ripple Training series on FCPX by Steve Martin. So, I know that FCPX does not want you to move or rename media files outside of FCPX.

 

In FCPX I choose the Reveal in Finder option for the media and it opened up a Finder window showing the file, where it's supposed to be. (Users/Me/Movies/Final Cut Events/Test Project/Original Media) The file is actually an Alias, since I choose to not copy the file from it's location on an external RAID drive. In the Finder window I choose Show Original and it did. It found the file (where I left it) on an external RAID drive.

 

The definition of the issue states that the file has been changed by an application other than Final Cut Pro. Interesting that it does not say which "version" of FCP. I didn't think I had touched the media file with any other application. (apparently, I had)

 

So, I attempted to fix the issue. In FCPX, I re-imported the file. That did not fix the issue. I simply wound up with two files, same name, start, end, duration, content created. One version is fine, the other still shows the Modified File Alert Icon. Although, when I look in the FCPX Original Media directory, it now has two Aliases (as expected) but the new one added "(fcp1)" to the end of the file name, as in TestProject(fcp1).mov

 

Now that I had a new version of the file imported, I tried to see if I could recreate the issue.

 

I closed FCPX. I opened up FCP7, created a new project, imported the media file, put it in a sequence and did some color correcting on it. I saved the project and quit FCP7. I opened FCPX and everything was as I left it. The original import of the media file still had the issue. But, the newly imported file did not. So, having FCP7 "touch" the file did not create the Modified File issue.

 

I closed FCPX and tried the exact same thing with Premier Pro. (Hey, it was 50% off since I just became a proud FCPX owner) The result was the same. Importing and color correcting the media file with FCP7 and/or PP did not cause an issue for FCPX. Just for kicks, I opened and closed the media file with Quicktime and as expected it did not create an issue. I'd like to know what caused the issue. I can't avoid an issue if I don't know what caused it.

 

Even if I will never find out why I have the issue, I'd be more happy to simply fix the issue. As Apple clearly states in the FCPX user manual, this is a common issue. They are correct, as it didn't take me long to experience it. But, they don't list a solution to it, even thought the issue is in the "Solutions" section of the manual. Perhaps the person who wrote the manual (not the SW) realized it's a common issue and therefore should have a Solution.

 

Not only is the media file missing. But so is all the work I did. I was using this media/Project to test out FCPX. Now that FCPX can't find the media, all the work I did in the Magic (sorry, Magnetic) Timeline is gone. All the work I did on the Timeline has the same Modified File Alert Icon along with the wonderfully soothing bright red color where media should be.

 

If I can't actually fix this issue (which I have no idea how it happened), then I actually did just loose all my work. (granted on a test project of no real value) No undo, no open up a previous "Saved As.." version. Go directly to FCPX Jail, do not pass Go, do not collect $200. (that was humor, not a rant)

 

If that's the case, then FCPX is not usable. At all. For anyone. Regardless of whether you make a living using it or not. If iMovie worked like this (maybe it does, I've never used it), I doubt anyone would find iMovie usable either. Same goes for iDVD, iPhoto, iWeb, iTunes, etc.

 

Therefore, there must be a solution to this issue. I'm sure someone will post the  solution that I could not locate myself.

 

Thanks in advance.


Mac Pro, Mac OS X (10.6.8), FCP 7 and FCP X
  • 1 Open Loop Level 2 Level 2 (350 points)

    Update ...

     

    When I look the Inspector for the the Project, It shows the one clip in use and the fact that it's been modified. When I click on Modify Event References, the pop up dialog says the media cannot be found, try reimporting the media.

     

    For some reason, I cannot reimport. When I choose, File > Import > Reimport From Camera/Archive... The option is grayed out. I can't select it.

     

    I tired selecting it with the Project highligted, with the Event highlighted and with the clip highlighted. No matter what I highlight, the Reimport feature is grayed out.

     

    I'm assuming this would fix my media issue.

     

    But now I don't understand why can't I access the Reimport feature?

  • hafken Level 4 Level 4 (1,225 points)

    I agree, this is a major problem with FCP X.

     

    I read someone might have come up with a work-around, so you should give this a try.

     

    In the Event Browser, select the clip that has the modified media. Now choose "Open in Timeline" (it's in one of the menus).

     

    Now, select the reimported clip, and overwrite (D) everything in the timeline. (so make sure the playhead is at the very beginning).

     

    Now go back to your original project and see if that fixed things.

  • 1 Open Loop Level 2 Level 2 (350 points)

    Well, I got some progress.

     

    I followed your suggestion. However, it didn't completely fix the issue.

     

    Now, in the Event Browser, the Clip shows the Modified Media Alert for the first part of the clip, about 3:48. After that, the clip looks fine. However, the Clip on the timeline still shows the Modified Media Alert for the entire clip.

     

    I would think that the clip has either been modified or not. I don't see why only a portion of it would be modified.

     

    I then selected the clip and choose Open in Timeline. In the Timeline, the clip showed up as two clips. The first one (3:48 long) has the Modified Media Alert. The second clip is the remainder of the clip and it looks fine. I can't extend the Modified Media clip, it won't extend past 3:48. The opposite goes for the good portion of the clip. Keep in mind, the re-imported version of this clip is fine from start to finish.

     

    I suppose I will have to call Apple later and see if they have any suggestions.

     

    Thanks.

  • hafken Level 4 Level 4 (1,225 points)

    Sorry it didn't work out. I can't believe how fragile this system is.

  • lrox88 Level 1 Level 1 (0 points)

    I am working from an external HD and had the same problem. In the event browser, I right clicked, selected reveal in timeline and deleted the corrupted alias. From there just reimport the original media to the same event and it should be fine.

  • joellm Level 1 Level 1 (0 points)

    I recently had this very same issue.  Source file was stored on a NAS, I imporrted it into FCPX and began to make multicam clips with it, put it into my timeline, edit together a project, etc. Finished with my editing, I left FCPX to render for a few minutes. Got up from my desk, took a stroll, came back, and found my footage has turned to all red, "MODIFIED FILE" message.  This issue only happened with one piece, out of many, of my source media.

     

    My solution: Open up the affected Event folder in the Final Cut Events folder, go to Transcoded Media>High Quality Media, find the file, which was an 11 gig video of all red, "MODIFIED FILE" message, and move it to the trash. Returned to FCPX and looked at my project: everything was back to normal. Somehow, FCPX had "rendered" this source file into a high quality, transcoded piece of media that was worthless.

     

    I still don't know why it happened in the first place, but I have now replicated the problem 3 times under similar circumstances.

  • Isaac Sloan Level 1 Level 1 (5 points)

    I'm also having this error. I got this error twice last night and once today. I've been doing multicam in final cut for a couple years now and have never had this problem. It's driving me crazy. I just finished editing a video and now I have to do it all over again.

     

    Like someone mentioned above you can just go into High Quality Video and delete the red files... Everything will then work. Unfortunately final cut will render them all to broken high quality video next chance it gets.

  • Ernie Stamper Level 8 Level 8 (37,555 points)

    Just experienced this for the first time, today.  Tried deleting the high quality, and commanding to optimize it again.  Broke shortly after again.  Deleted the clips entirely in FCPX, and tried to reimport.  Would get to point of selecting what to import, but simply not do anything, nor provide any message.

     

    Only way I could reimport was into an entirely new Event.  Doing some backup now, and will again attempt the Multicam Clip creation.

     

    I have done many such MC, but only recently in Mavericks -- previously in Mt. Lion.  But his topic would suggest it is not new.

     

    Ernie

  • Tangier Clarke1 Level 2 Level 2 (275 points)

    Thanks for this solution.  It worked great.  Giving credit and posted on creative cow.  I had the same problem today with FCP X 10.0.9

  • DallasTexasAggie Level 1 Level 1 (0 points)

    This worked for me too!  I went to the finder window to find the event on my external hard drive, go to Transcoded Media>High Quality Media, find the file, which was an 11 gig video of all red, "MODIFIED FILE" message, and move it to the trash.  Then I clicked on FCPX working window and there it is again!!!  I was about to go back to the old FCP because this is my first project on FCPX and most of my work is multicam editing. This was a fast and easy fix for me...if it happens again, I won't stress anymore.

     

    THANK YOU SO MUCH!!!  YOU SAVED HOURS OF WORK!!!

  • F this. Level 1 Level 1 (0 points)

    Ughhhhhhh!!! Why does this keep happening!!??  This is a new problem for FCPX.  Apple, please fix asap.  I have too much video to keep rewriting the files.  Deleting the red high quality media files from Finder worked for me yesterday.  Crossing my fingers that it works again.  But I'm gonna burn a processor re-rendering all of these files!

  • Zambonisurfer Level 1 Level 1 (0 points)

    This was exactly what I was looking for! Thank you! I just updated to Mavericks today, and it's the first time I've ever seen "Modified File". IS everyone else on Mavs who had this problem?

  • rbfilms Level 1 Level 1 (0 points)

    I'm on mavs with exactly the same problem. I've been using FCPX since it came out and never seen this happen. Since I've been on mavericks I've seen it happen 3 times when transcoding multi-cam clips.

     

    Big issue, massive time waster.

     

    Hafken said this earlier and it's been a massive help for me:

     

    "In the Event Browser, select the clip that has the modified media. Now choose "Open in Timeline" (it's in one of the menus).

     

    Now, select the reimported clip, and overwrite (D) everything in the timeline. (so make sure the playhead is at the very beginning).

     

    Now go back to your original project and see if that fixed things."

  • MattHagen Level 1 Level 1 (0 points)

    One more poor sap here on Mavericks and FCP X who put together a Multicam clip, started transcoding it and went out to run some errands only to find several of the files rendered as described above: 195 MB of one still frame.  I need that like I need a hole in the head.

     

    I had not transcoded high-quality versions of everything earlier, and these got transcoded automatically when I started working on the multicam clip.  Perhaps there's some correlation.  Right now I'm backing up all my source data before diving back into the project.

     

    Anyway, thanks a million to Joellm above for the clue to the solution.

     

    Screen Shot 2013-12-01 at 2.56.35 PM.png

Previous 1 2 Next