7 Replies Latest reply: Aug 19, 2012 11:00 AM by zk16
MacBook8 Level 1 Level 1 (0 points)

Up until about a month ago, I had absolutely no issues with Wordpress and Safari.  I remember the day it changed:  I went to sign into Wordpress and it was like the keyboard on my MacBook Air was dead.  Nothing would click.  I eventually managed to sign in, then had problems editing anything from my Wordpress blog.  I tried changing the theme in Wordpress and that helped somewhat, but not completely.

 

I have tried FireFox and the same issues are there, which leads me to assume - perhaps incorrectly, that it is Wordpress, and not Safari that is at fault. 

 

I then downloaded Opera and have no issues at all using Wordpress.  While Opera works well, I do all my Internet browsing in Safari and it's a pain to go to Opera just to update my Wordpress blog.

 

Any suggestions or comments as to why Safari and Wordpress no longer are compatible??


MacBook Air, Mac OS X (10.6.8)
  • Carolyn Samit Level 10 Level 10 (100,390 points)

    With Safari open go to the menu bar click Safari / Preferences - Security. Click: Show Cookies. Delete all Word press cookies.

     

    Then select the Autofill tab from the Preferences pane. Click the Edit button next to: Other forms. Delete the Word press url.

     

    Quit then relaunch Safari.

  • MacBook8 Level 1 Level 1 (0 points)

    Thank you, Carolyn, for your reply.  I tried this - following your instructions to delete all Wordpress cookies, quit Safari and restarted, however, it hasn't changed anything.  I wish it had!

     

    I'm still at a loss as to why Wordpress is suddenly acting up in Safari.

  • Carolyn Samit Level 10 Level 10 (100,390 points)
    following your instructions to delete all Wordpress cookies, quit Safari and restarted

    Did you delete the web address as I suggested before from Safari / Preferences - Autofill - Edit ??

  • MacBook8 Level 1 Level 1 (0 points)

    When I went to delete the web address, the window was empty.  I did the procedure twice to make sure I deleted the cookies and the web address, but both times the web address was not there.

  • Carolyn Samit Level 10 Level 10 (100,390 points)

    Ok..

     

    Quit Safari.

     

    Open a Finder window select your Home folder in the Sidebar on the left. Then open the Library folder, then the Caches folder, then the com.apple.Safari folder.

     

    Move the cache.db file from the com.apple.Safari folder to the Trash. Relaunch Safari.

  • MacBook8 Level 1 Level 1 (0 points)

    Carolyn, I have to thank you for your perseverance, however after following your instructions, nothing is changing it seems.  Today, I have gone back into Wordpress and nothing is working.  It's almost like the keystrokes within my blog are dead.  For instance, if I click on 'My Blogs,' at the top of my Wordpress blogs page, then click on 'Dashboard,' nothing happens.  I click on Edit beside one of my posts, and again, nothing happens - like the keys are dead.  This is the only site I am having problems with and have used Safari and Wordpress for years.

     

    Thanks again.  I'll have to switch to Opera to use Wordpress.

  • zk16 Level 1 Level 1 (0 points)

    Hi Macbook8, am a new Macbook Air user and am having the same issue with Wordpress - it isn't working across browsers. I will try Opera now, but wanted to check, did you eventually find a solution to get it to work in Safari?