8 Replies Latest reply: Jul 18, 2011 10:51 AM by wsrphoto
wsrphoto Level 1 Level 1 (30 points)

Anyone know what this means and how to fix it?

 

Jul 15 15:21:37 Scotts-Mac-Pro com.apple.kextd[10]: Can't create kext cache under / - owner not root.

Jul 15 15:21:37 Scotts-Mac-Pro com.apple.kextd[10]: Rescanning kernel extensions.

Jul 15 15:21:37 Scotts-Mac-Pro com.apple.kextd[10]: Can't create kext cache under / - owner not root.

Jul 15 15:22:32: --- last message repeated 8 times ---

 

It's launched by root, usually PID 1.


Pro, Mac OS X (10.6.5)
  • 1. Re: com.apple.kextd
    ds store Level 7 Level 7 (30,305 points)

    Repair permissions has already been tried right?  Disk Utility in the Utilties folder?

     

     

    Stupid, but I got to ask.

  • 2. Re: com.apple.kextd
    wsrphoto Level 1 Level 1 (30 points)

    Yes, and rebooted. It starts shortly after rebooting with few apps running. It seems harmless but wondering if it's related to some third party app started under my userid.

  • 3. Re: com.apple.kextd
    Topher Kessler Level 6 Level 6 (9,340 points)

    Get information on your hard drive, and in the "Sharing & Permissions" section let us know what is listed. You should see the following:

     

    System     Read & Write

    Wheel       Read Only

    Everyone   Read Only

  • 4. Re: com.apple.kextd
    Topher Kessler Level 6 Level 6 (9,340 points)

    This problem is ultimately not serious. The system is trying to create a boot cache to allow your system to boot faster, but cannot because the access permissions for creating the cache are not as expected (or needed). The main system launcher "launchd" which is started by the kernel under the root account, is given the process ID of 1, which is why you see this error being associated with it. The launcher process is failing to start the "com.apple.kextd" launch agent, which is the configuration file for creating the kernel extension cache.

     

    Without this cache the system will still boot fine, but may take a few seconds longer to do so.

  • 5. Re: com.apple.kextd
    Linc Davis Level 10 Level 10 (118,505 points)

    First, back up all data if you haven't already done so.

     

    Launch the Terminal application, copy or drag -- DO NOT TYPE -- the text below into the window, and press return. You'll be prompted for your password, which won't display when you type it. You may get a one-time warning not to screw up. Quit Terminal.

     

    sudo chown root:admin /

  • 6. Re: com.apple.kextd
    wsrphoto Level 1 Level 1 (30 points)

    This was the trick. A file in the LaunchDaemons folder (com.bjango.istatlocaldaemon.plist) has everyone (permissions) set to none. Changing it to read-only appears to work as the error message hasn't shown up since. Many thanks to all.

  • 7. Re: com.apple.kextd
    Topher Kessler Level 6 Level 6 (9,340 points)

    That's odd. The kextd process does not interact with anything in the LaunchDaemons folder. The only thing I can think of is if the iStats plist was somehow interfering with launchd's ability to run the kextd process, but that's a bit of a stretch IMO. It might make sense if iStat installed a kernel extension, but it doesnt and instead only has a background monitor (daemon) that is managed by launchd through that plist you mentioned.

     

    Regardless, its good to see that you got it fixed.

  • 8. Re: com.apple.kextd
    wsrphoto Level 1 Level 1 (30 points)

    I don't know why either but installing an update to Integro Manager Pro creating the same error messages when I restarted the Mac (required to uninstall and reinstall the app) and reseting the permissions to the same file removed the error message. This is the plist file:

     

    <?xml version="1.0" encoding="UTF-8"?>

    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

    <plist version="1.0">

    <dict>

              <key>Disabled</key>

              <false/>

              <key>GroupName</key>

              <string>wheel</string>

              <key>KeepAlive</key>

              <true/>

              <key>Label</key>

              <string>com.bjango.istatlocaldaemon</string>

              <key>OnDemand</key>

              <false/>

              <key>Program</key>

              <string>/Library/Application Support/iStat local/iStatLocalDaemon</string>

              <key>RunAtLoad</key>

              <true/>

              <key>StartOnMount</key>

              <false/>

              <key>UserName</key>

              <string>root</string>

    </dict>

    </plist>