Previous 1 24 25 26 27 28 Next 453 Replies Latest reply: Aug 8, 2015 4:52 PM by rosfun54 Go to original post
  • Guarino.R.Colli Level 1 (0 points)

    I purchased a Promise Pegasus R4 4TB (4x1TB) RAID System 13 days ago, along with a 27-inch iMac, Late 2012, 3.4 GHz Intel Core i7 (OS X 10.8.5). I purchased the unit to be used primarily as a backup system, via Time Machine. I decided to purchase the unit because I could get it via the Apple Store, along with the computer, and also because of the Thunderbolt interface. It was easy to connect and get it running, except that it took approximately 48 h to "automatically initialize and synchronize" (this is what is written in the documentation that came along with the unit). After selecting the unit for Time Machine, I had the first backup (really fast!). I also used the unit to store my Aperture Vault (also very fast when setting up for the first time).


    I was very happy with the purchase until the morning of the third day after setting up the system. When I woke up the computer, there was an error message indicating "The disk was not ejected properly. If possible, always eject a disk before unplugging it or turning it off." First, I though it could have been an electrical problem, however, the unit was safely connected to an APC Smart-UPS 1500 and the UPS didn't shut down (the computer was also connected to the UPS). I checked all cables (power and Thunderbolt cable) and they semmed properly connected. By the way, I was using an Apple 0.5 m Thunderbolt cable.


    The unit was still on, albeit unmounted. However, after several attemps to re-mount it, including disconnecting and re-connecting the Thunderbolt cable, restarting the computer, turning the computer off and on again, I tried to turn the Promise Pegasus off and, to my surprise, it wouldn't go off, no matter for how long I kept the power button pressed! Finally, I relied on brute force and disconnected the power cable on the back of the unit. After reconnecting the cable, the unit went on and mounted on the Desktop. Everything was back to normal, until the next morning... The same problem again! After waking up the computer, the same error message. I had to use the same procedure of unplugging the power cable.


    After some thought, I decided to turn off the "Put hard disks to sleep when possible" option under Preferences->Energy Saver. Next morning, the same problem again!


    I decided to search for the cause of the problem on the internet and found this Discussion. This made me VERY concerned about the purchase! Two days ago, I decided to move my iTunes library to the unit. After buying the new computer, I had to download the entire library from iCloud (using iTunes Match). The process took about 30 h. During this period, the computer went to Sleep mode and, after resuming, the Promise Pegasus unit was still mounted (but iTunes was still downloading music). This morning, after waking up the computer, iTunes had finished and the Promise Pegasus was unmounted again! Apparently, as long as there is I/O activity, the unit will stay mounted. After a prolonged period of inactivity (and the iMac in Sleep Mode), the RAID unit unmounts itself, misteriously.


    After that, and considering this Discussion, I called Apple Support and asked for a refund. I was promptly attended and already got the return labels by e-mail. I was very frustrated with the experience, especially by figuring out that I cannot trust the quality of a product just because it is being sold on the Apple Store (never had a problem like this before!). Finally, considering the ads, this Discussion, and the bad experience, I consider this product a piece of junk, that didn't go through proper testing before being marketed.

  • Cowboooy Level 1 (0 points)

    Hi Guarino


    If its any consolation my Macbook Pro does exactly the same thing thou this time with a USB 3 portable drive, what I think is happening is that the energy saving settings put the computer to sleep when perhaps an app is still running thou dormant.

    In my case if I leave FCPX running and walk away for 20 min the laptop will have ejected the USB 3 disk with the message "disk not eject properly".

    I know you have unchecked "put disks to sleep when possible" but try moving the slider to "never sleep" for the computer, maybe its a Mac OSX bug ?? ejecting disks when apps sleeping still need them.


    My Pegasus has given me stirling service, I would be lost without it a great unit. Maybe consider getting another one.

  • JulieCor Level 1 (0 points)

    I have had this exact problem except I have had my Pegasus 6 for 6 months now without an issue. This started 6 days ago just after a system update/restart. And to add to this issue of the drive unmounting itself and not being able to remount it short of pulling the power from it - it will not turn off - my 27iMac will now not boot up if the Pegusus 6 thunderbolt cable is plugged into the computer!

    I need to figure out an answer. I have 1.5 Tb of clients photos on that drive right now. Thanksfully/hopefully they are also saved to crashplan on line.  But  I can't keep pulling the power cord to get it to remount so I can work on photos.

    Anyone have any wisdom to share on this?

  • Steve McRea Level 1 (95 points)

    Has anyone seen any Thunderbolt connectivity issues on Maverick?


    I use an R4 RAID 10 as my startup disk. Although issues have been reported (on this thread) in the past with the Pegasus, My setup has ran perfectly for the past several years with zero disconnects. That is until last night when I decided to upgrade to Maverick.


    I upgraded to the R4 drive when it asked me which disk to upgrade to.. halfway through the install everything went grey and it hung!.. After leaving it for several hours it was still hung


    Debug steps:


    - Booted my iMac from its internal drive which it did OK and was on OSx 10.8 Checked Disk utils to see the Pegasus and it was not mounted.


    - Disconnected the thunderbolt cable from the iMac and booted a Macbook Pro with my Pegasus as startup drive over the thunderbolt  and it worked!!


    - Conclusion was my Pegasus looked OK although I was still on OSx 10.8. Problem must be somehow my iMac 10.8 had got it's Thunderbolt port screwed up.


    - As things couldn't get much worse and considering I'm covered with Applecare I decided to upgrade the iMac to Maverick and see if this fixed my Thunderbolt port issue.


    - It did!!.. Running from the iMac OSx 10.9 I could see the Pegasus mounted in Disk Utils!! :-)


    - Changed my startup disk back to the Pegasus and I'm now booting up ok  and up and running from the OSX 10.8 on the Pegasus!!


    Now I'm totally reluctant to try and update the OSX on the Pegasus to 10.9!!!


    I know that my setup is a bit unique but has anyone heard of Maverick breaking the thunderbolt port?

  • ke3z Level 1 (35 points)

    Well, that makes me nervous. I haven't yet upgraded to Mavericks because I have a critical app that I need to upgrade first, but my situation sounds a lot like Steve's -- iMac (27" mid-2011, 3.4-GHz i7) and using a Pegasus (R6 in my case) as the startup disk for a couple of years without problems. Now I'm conflicted about upgrading. Has anyone done the upgrade sucessfully when using a Pegasus as the startup disk?


    Steve, what iMac model do you have?

  • Steve McRea Level 1 (95 points)

    Your clone... imac 27" 3.4Ghz with the i7. Purchased Nov 8 2011!


    I've never had a single instance of a disconnect until last night when I upgraded to Maverick!


    And it certanly looks like it had nothing to do with the Pegasus and everyhing to do with the imac.


    What has me scratching my head is how upgrading the OS on an external startup disk such as the R4 can screw up the thunderbolt ports on the imac?


    This is telling me that the OS upgrade maybe doing some Firmware change in Non Volatile memory on the imac as well as upgrading the OSx resident on the hard drive.. which does actually make sence!


    It will be interesting to see if this is an issue with the TB port regradless of the perifieral type? From what I could see, this had nothing to do with the fact that the R4 was my startup disk.. the fact that the entire disk remained unmounted or I suspect more that the TB port went dead!.. which is really scary!


    I'm going to leave well alone until I am convinced that we're good to go!


    As some of us are in the same boat with using R4's and R6's as our startup drives can we share any info on this that we may come across?





  • ke3z Level 1 (35 points)

    It sort of makes sense that they would roll out a firmware change coincident with the OS X upgrade, but I would think they would also make that change available separately, and I haven't seen one.


    Once I'm at the point where I'm ready to do the upgrade, I'll just make sure my TM backup is current in case the upgrade totally hammers things. Good to know that upgrading the internal copy of the OS put things back into working state.

  • Steve McRea Level 1 (95 points)

    Yep, It's always good to back up!! .. I have three tiers of backup, TM, Deja Vu and also a Crashplan backup.


    The problem last night was  that my imac lost ALL connectivity to the external drive so I couldn't do anything! My pegasus became a useless metal box!

  • Matchless297416 Level 1 (0 points)

    Back-up routines using a Pegasus have become a must for me.


    I have been using my R6 together with my iMac 27 2011 as a startup disk, but after several sudden disconnections I was forced to find a different arrangement, and use the R6 just as data storage.


    I must add that the sudden disconnections still occur every now and then - a quite annoying experience - and that the upgrade to Mavericks does not appear to have any influence: the R6 disappears from the desktop by itself just as before.


    A bitter and meager consolation: most of the times the R6 disks reappear by themselves just as they disappeared!

  • Steve McRea Level 1 (95 points)

    After my issues the other day I'm back up and running with the R4 as my startup with no issues.


    I really think that this had nothing to do with the R4.. I was thinking about doing a seperate post oin this to see if anyone has seen TB port issues after upgraded to Maverick!

  • Bosto Level 1 (0 points)

    After installing Mavericks on my one year old iMac (loaded) Time Machine failed (Pegasus Promise Thunderbolt 3TB).  I tried unmounting it, didn't work.  Rebooted: Time Machine failed again [Time Machine couldn’t complete the backup to “Time Machine”. Unable to complete backup. An error occurred while creating the backup folder.] was the only message. Had to reboot to get Pegusus accessible again.  Tried re-intalling Maverick (old Microsoft thing... reintall the OS).  Didin't do anything for Time Machine, same failure.  Booted into safe mode: nothing, same probelm.  Repaired permissions: no joy there either.  So, now have no Time Machine backups at all. And Time Machine won't work with the Pegasus. [same error message after 30 min or so every time].  ordinary file saves work fine though.


    I put an old USB drive on and Time Machine is working fine with that... so Pegasus R4 and Mavericks don't play well?


    Ideas please?

  • Bosto Level 1 (0 points)

    Warning: the Promise Pegasus R4 is NOT compatible with OSX Maverick.  Promise has no idea why. Time machine will fail, and in some cases maverick will not even recognise it as a HD. Some report WD Hd problems as well.

  • Steve McRea Level 1 (95 points)

    Bosto, Did you speak to Promise? if so what did they say apart from what you previoulsy said .. "Promise has no idea why"


    I'm still stunned that Apple allows Promise to get away with this. After all it seems to be a product that Apple endorses!.. Have they heard of 'Interoperability Testing" ???? Did anyone at either Apple or Promise create at least a high level test plan and execute it?... Sorry Apple and Promise I have to say that this is very unprofessional and unacceptable. Site admin, YES I did just give Apple a hazing and YES please escalate the comment!

  • Bosto Level 1 (0 points)

    Hi Steve,


    Here's what Promise said about the problem: (complete and exact quote yesterday) "I do not know what the problem is".


    Update: Finally...


    At least for the Promise Pegasus R4... but I noticed on other threads that WD drives are also acting up too so this might work with them too.


    I turned off Time Machine, and deleted that pesky .plist file, again. I unplugged the R4, power and thunderbolt, then played whack the gopher with the drives swapping them around randomly.  I reintalled Mavericks from a fresh download, yet again, then set Time Machine to backup on a fast USB 3TB drive (which it did in 6 hours or so).  Then I turned off Time Machine, deleleted that .plist file again, rebooted the iMac, plugged in the R4, reformatted it again with Disk Utility, then hooked it to Time Machine, said a few slightly heretic prayers to whatever demons came with Maverick, and 2 minutes later Time Machine started to backup and report 1 hour to complete... the hour isn't up yet, but I'm crossing everything I have 2 of...


    Another update (Oct 31st):


    OK, the first-pass Time Machine backup worked, but it FAILED again on the first incremental. No useful error message: just 'Time Machine cannot use Pegasus..." no file error warning, nothing useful.  The Pegasus won't eject, OS says it is still in use.


    SORRY APPLE: there is definitely something screwy between Maverick, Time Machine, and the Promise Pegasus R4.

  • LyndonKL Level 1 (0 points)

    I have had trouble with my Pegasus R4 for the last four months...basically self-ejecting for the reasons stated in these posts. Reconnecting is haphazard if not worse.

    I have been in contact with Promise for the last two months and the response and service is unacceptible. Eventually they agreed to swap the unit (still under warranty) for a new one however that has been two weeks since I returned it to their agent here in Malaysia. Now when I ask on their service website the shipping status of the new unit I get no response...none just like the R4.

    Apple from whom I purchased the unit tells me this is not an Apple product therefore they cannot help me.

    I am still waiting to hear from Promise but now am not hopeful there will be a solution and now not even hopeful I will get a new unit or even my old unit back.

    My advice? Seek other solutions....Promise is not one of them

Previous 1 24 25 26 27 28 Next