1 26 27 28 29 30 Previous Next 447 Replies Latest reply: May 9, 2014 1:44 PM by rzanc Go to original post
  • 405. Re: Thunderbolt Pegasus R4 Experience?
    廣晃from品川区 Level 1 Level 1 (0 points)

    My company has delayed the upgrade to Mavericks due to this issue.  We can't afford to have the drive messed up since it will mean the loss of our FTP server and such.  I was using the utility already under Lion, and hopefully as long as I update the firmware as you say it won't be a problem when it comes time to bite the bullet and upgrade.  I would love to hear from other users about their experience with Bosto's process. 

  • 406. Re: Thunderbolt Pegasus R4 Experience?
    Matchless1895 Level 1 Level 1 (0 points)

    It appears this nightmare is here to stay.

     

    I tried and followed the method suggested by Basto, since I had been already using the Promise Utility, but:

     

    - the existence of a firmware upgrade is duly reported by the Utility;

     

    - I accept to download it, it duly donloads, then

     

    - the Utility reports that the update cannot be located and remains just stuck with that.

     

    And this has nothing to do with Mavericks: I tried under Mountain Lion and got the same error.

     

    Promise people, I promise: never again.

  • 407. Re: Thunderbolt Pegasus R4 Experience?
    Pegasus2_Promise Level 1 Level 1 (0 points)

    Hi Matchless1895

     

    Not sure exactly what is causing the problem you are having with the utility. Not sure if you maybe have the FCS (First Customer Ship) release of Pegasus firmware and software. None the less surely we can get this up and going in no time.

    As an alternative we flash the firmware from CLI (should not be necessary) but you can.

     

    If you are interested shoot me an email.. victor.p@promise.com

    we can pick this up offline..

     

    Thanks

    Victor

  • 408. Re: Thunderbolt Pegasus R4 Experience?
    Matchless1895 Level 1 Level 1 (0 points)

    Thank you, a message has been sent to the address you indicated.

  • 409. Re: Thunderbolt Pegasus R4 Experience?
    LyndonKL Level 1 Level 1 (0 points)

    So my problem (see previous post by myself) has been the impromtu disconnect/eject. This was under Lion and Mavericks, firmware/utilities all fully updated to no avail. Sleep/hibernate set correctly according to Promise support. This has been going on since september when I forst contacted web support. Slow responses finally ended up with an RMA for replacement except that...and I quote from my last web support submission today..

    " I have requested a status report of my replacement unit on Oct 28th, Oct 30th, Oct 31st, Nov 7th with the only reply was that the unit was to be shipped Nov 4th. It is now Nov 14th and I have no word from Promise confirming the shipment date nor the status of the unit nor any shipping waybill number so that I can track the unit.

    Am I to assume that Promise has now lost my replacement or that Promise does not intend to replace the unit?

    Please advise today.

    You may also see a copy of this post later today in the Apple website that covers member's distressing times dealing with Pegasus units as well as the abysmal support from Promise."

    And accordingly I have not heard a peep from them so what am I to assume? Oh yeah, I also forgot to mention that their rep in Taiwan in the middle of the RMA process (and after I sent the unit back as requested to the address as requested (personally delivered) has now requested the unit be sent to them! So now two branches of the same company want the one unit!!!

    Weird eh?

    I shall update once Promise has found one of my real and one of the imaginary units.

  • 410. Re: Thunderbolt Pegasus R4 Experience?
    LyndonKL Level 1 Level 1 (0 points)

    So after some time my unit is finally on its way home tonight, Nov 15th. My R4 troubles are in prior posts (2) and finally after sending an email on Nov 14th to Victor things progressed at a very rapid rate and explanations given. If this last bit of service is what Promise can achieve on a regular basis then it would make them proud and the customer a very satisfied customer.

    So, now I am indeed a happy customer thanks to the efforts of Victor, Alan and Bulermo who assured me 'action' and a good result is what they delivered.

    So, thank you Victor and your team for taking my issue on board.

  • 411. Re: Thunderbolt Pegasus R4 Experience?
    Steve McRea Level 1 Level 1 (95 points)

    I recently posted that I had trouble installing Maverick on my R4 that I use as startup disk.

     

    I have just performed a successful firmware update on the R4 and now was wondering if ANYONE has SUCCESSFULLY upgraded to Maverick when using the Pegasus as startup?

     

    Please let me know.. thanks!

  • 412. Re: Thunderbolt Pegasus R4 Experience?
    Matchless297416 Level 1 Level 1 (0 points)

    How is your Pegasus configured as to Raid level?

     

    I have heard that the use of a Raid 0 array as startup disk would not be advisable nor convenient.

  • 413. Re: Thunderbolt Pegasus R4 Experience?
    Steve McRea Level 1 Level 1 (95 points)

    My Pegasus is configured as a RAID 10.

  • 414. Re: Thunderbolt Pegasus R4 Experience?
    rpknick Level 1 Level 1 (0 points)

    Steve... as I am now staring at a Peg 4 that's fully lit up with solid blue lights... I would really appreciate it if you could perhaps share the steps to your success in performing the upgrade. I'm thrilled you got it done but it would be extremely helpful if you could recount the steps.

     

    My Peg R4 and Mini have been running seamlessly around the clock for months and months without a problem. I've had the Promise Utility installed but haven't updated the firmware or the utility app in a long time. Everything was running perfectly stable without a hitch.

     

    Today I got trampled on by Mavericks. I wasn't actually intending to do the update to 10.9 but somehow or another on a reboot it did what it did and since that time I can't even power off my Peg R4. It's lit solid blue in all four bays along with the power light and the thunderbolt. Sadly, when I tried to launch the Promise Utility and ask it to check for updates, I get a connectivity error of some sorts. I've also luanched terminal to try and access it that way. Unfortunately, I just won't budge from it's bright blue light blaze.

     

    I rely on this configuration and in spite of some of the problems voiced in earlier posts and threads, I've been quite pleased with the Peg 4. But GOOD GRIEF! FUBAR is an understatement. I've just sent Victor a note directly but I'm guessing he is buried at this point. I really need to get this resolved and quickly as they office is open tomorrow and I'm traveling 2 days later. Victor? Promise? Anyone? Please. I need some help here.

     

    I've tried to update the device using the CLI and Terminal reports there's not device connected. Wonderful. So I can't turn it off and power cycle it and I can't see it in order to do anything in it, on it, around it.

     

    I would really appreciate your help.

     

    Robert

  • 415. Re: Thunderbolt Pegasus R4 Experience?
    Matchless297416 Level 1 Level 1 (0 points)

    In answer to

    Re: Thunderbolt Pegasus R4 Experience?

    Nov 16, 2013 7:17 AM (in response to Matchless297416)

    My Pegasus is configured as a RAID 10.

    I understand than that you have two pairs of disks as Raid 0 mirrored one pair into the other. I used to have a similar configuration with my Pegasus 6, that is two sets of three disks each as Raid 0 mirrored into an identical set for a total of six disks.

     

    Everything was ok until I was hit by the self-ejection accident, and after that I decided to stop using Raid on the Pegasus.

     

    But I had been reading on various places that using a Raid set as startup disk was not a good idea, since the gain in transfer speed would be offset against increasing latency, and latency is the most important factor in the performance of the operating system, where accesses to the disk are very frequent but only for small chunks of data,

     

    This would require the shortest possible access time or latency, while transfer speed impact would be negligible.

     

    I am not an expert myself, I just rely on opinions by people in the know, and I would be pleased if somebody would like to share his experience.

  • 416. Re: Thunderbolt Pegasus R4 Experience?
    Steve McRea Level 1 Level 1 (95 points)

    Hi Matchless & NPK Nick,

     

    I'm pasting the post that I did a coupd of weeks ago when I was in a panic!

     

    I don't really have a solid explanaton on why I git back up and running..

     

    It seems that installing Maverick on the main computer and not on the external HD fixed the issue... but no idea why!

     

    Not sure if this helps?

     

    Previous post....

     

    I use an R4 RAID 10 as my startup disk. Although issues have been reported (on this thread) in the past with the Pegasus, My setup has ran perfectly for the past several years with zero disconnects. That is until last night when I decided to upgrade to Maverick.

     

    I upgraded to the R4 drive when it asked me which disk to upgrade to.. halfway through the install everything went grey and it hung!.. After leaving it for several hours it was still hung

     

    Debug steps:

     

    - Booted my iMac from its internal drive which it did OK and was on OSx 10.8 Checked Disk utils to see the Pegasus and it was not mounted.

     

    - Disconnected the thunderbolt cable from the iMac and booted a Macbook Pro with my Pegasus as startup drive over the thunderbolt  and it worked!!

     

    - Conclusion was my Pegasus looked OK although I was still on OSx 10.8. Problem must be somehow my iMac 10.8 had got it's Thunderbolt port screwed up.

     

    - As things couldn't get much worse and considering I'm covered with Applecare I decided to upgrade the iMac to Maverick and see if this fixed my Thunderbolt port issue.

     

    - It did!!.. Running from the iMac OSx 10.9 I could see the Pegasus mounted in Disk Utils!! :-)

     

    - Changed my startup disk back to the Pegasus and I'm now booting up ok  and up and running from the OSX 10.8 on the Pegasus!!

     

    Now I'm totally reluctant to try and update the OSX on the Pegasus to 10.9!!!

     

    I know that my setup is a bit unique but has anyone heard of Maverick breaking the thunderbolt port?

  • 417. Re: Thunderbolt Pegasus R4 Experience?
    Matchless1895 Level 1 Level 1 (0 points)

    I have no final explanation either, but I strongly doubt that Mavericks had any thing to do with your problem.

     

    My experience shows that a very delicate issue concerning the Promise is the firmare and its compatibility with the operating system being used.

     

    It may well be that the firmware update performed under Mavericks, but (obviously) with a firmare version issued before Mavericks came out, resulted in the freezing, or that some other unknown factor occurred during the updating process and prevented the completion of the latter.

     

    All I know is that my Pegasus had self ejecting and freezing problems before upgrading to Mavericks, that the same problems persisted after upgrading to Mavericks and that they finally disappeared after the Pegasus firmare upgrade to the last available version. Mavericks had no influence whatsoever.

     

    My suggestion is that you should go on and install (or upgrade to) Mavericks on the Pegasus: if the Raid is not broken and the Pegasus is duly detected I can see no reason to hesitate.

  • 418. Re: Thunderbolt Pegasus R4 Experience?
    LyndonKL Level 1 Level 1 (0 points)

    As per my previous post Pegasus returned my R4. Since then it has worked flawlessy on my iMac and MBP, switching (cables) so that TM backups can be made. No more self-ejects or lost drive. Works as well as it did when I first purchased the unit...so very happy.

    When first purchased R4 was fully updated and running under 10.8. I continued with all updates for R4 and iMac/MBP up to and including Mavericks. The unit slowly degraded under 10.8 and finally refused to connect several weeks after running under Mavericks.

    Promise undertook repairs (replaced failing HDDs???) and the unit works perfectly.

    Therefore I can only conclude that the problem was not a result of the OS or upgraded OS or firmwares...just a failed unit.

  • 419. Re: Thunderbolt Pegasus R4 Experience?
    Bosto Level 1 Level 1 (0 points)

    hello again to everyone,

     

    i posted earlier on, but have been following at least 4 threads on this mavericks and hd issue, including pegasus units.

     

    in summary, i have two bloated new imac systems (jan 2013), 3 27" displays, pegasus r4's, 3tb usb wd hds, etc.

     

    both went to mavericks, never having installed any promise software, utilities, drivers, whatever.  both worked flawlessly as time machine archives, and weekly time machine backups to the wd drives (also no wd softare or drivers ever installed, immediately reformatted on installation as we do all ext hds).

     

    one system reported time machine unavailable for 5 days but that was ignored (not my system...) and my imac did the same immediately after installing mavericks... where as i freaked, tried a long list of 'fixes' from reformatting, re-installing mavericks (3 times), hard reset of time michine, repairs to ssd in imac and pegasus, all to no avao=il.

     

    i reported the problem to promice on their support site, only to discover just yesterday that you must have pop-ups unblocked or you can never get to see their responses... yah, they gotta fix that, and a few other things.

     

    so, i ranted here and other threads like a madman (like most others have done) and promise contacted me directly and were enormously helpful in sorting most of this out... it DOES seem to be a combo-problem, with just a tad of error, err, not-error-handling added in by mavericks.

     

    wd has already issued lots of 'yatta' and other thread-posts about their complicity, so i'll skipp all that here.

     

    for the pegasus, my system, after loading a new updated promiseutils, and after promise had me update the pegasus firmware, and after promise gave me good instructions on command lines that needed to be done via 'terminal' because their utility doesn't actually do it under mavericks yet... hmmm, they'll fix that eventually too, but they did jump in here to honestly help (go back in the posts and you'll find victor's email address at promise).

     

    and a yton of littl epicky things to do... but finally it all works perfectly again:

     

    so, here's the pointers i learned:

     

    in general: go to system preferences, spotlight, and add your externals drives (especially your time machine drive) to the privacy window so that processor hog pita spotlight doesn't spend days indexing it!).  it 'seems' that if spotlight is indexing it time machine will choke faster than a yorkie with a chicken bone!

     

    pegasus:  for sure, contact promise via email to victor as online support is lacking, takes along time, and... well, they aren't the brains behind promise support, victor and his guys are.  make sure you have the latest promiseutils installed and working, and thus you can get the latest firmware update... afterwards, power-down your pegasus unit, and cold boot your system then repwoer the pegasus.  after several cold mavericks reboots, and 2 weeks of time, suddenly mavericks discovers a 'new thunderbolt bridge'??? ***, who snuck a tiny mavericks update in while i was blind? seriously... this imac has been running since january and suddenly it has a new thunderbolt bridge two weeks after installing mavericks? yorkie >> chicken bone.

     

    IF your promiseutils app (you must run it) shows that any of their toshiba (or whatever) hds have a 'bad block' that has supposedly been isolated and the r4/r6 should work anyway as designed to be a good raid system... mavericks >> yorkie >> chicken bone!! i suspect (have no proof and don't want to go look for any either) that mavericks will choke on any timeout of error message/state from any hd, and particularly a fw hd or thunderbolt drive, regardless of what their 'software' tries to do. it appears any timeout and mavericks will take an apocalyptic viewpoints and try to eliminate the alien in your system and re-write its DNA. as soon as i 'hot-yanked' that not-even-failed- hd from the pegasus, poof, it handled the raid issue like it was supposed to, and time machine worked, and mavericks stopped going all terminatrix on it.

     

    the other imac system with the odd time machime failure? meh- 5 or 6 days later it just started working after spotlight (under mavericks) finally finshed hogging it and using 90+ percent of the processors. it still doesn't have a firmware update, and it still doesn't have promiseutils on it... so, betcha it doesn't have a 'bad block' anywhere either. we just keep a little statue of bhudda close by with a little bit of rice and fruit going rotten, have a crucifix on the wall, and tiptoe silently near it (mostly to just not wake up that scientist, i think).

     

    ps.  there's no way i am going to put mavericks on my imac at home, yet...