3 Replies Latest reply: Apr 25, 2013 12:04 AM by 3gs iphone
OzziesMAC Level 2 Level 2 (150 points)

Went to play some music and my iPhone now lost all it's sound?

 

If I do Airplay it will send the audio out, and if I plug in the headset

it works fine via headset, but other than that no sound from the iPhone

speakers.  I have re-booted it and no change.  I have also check the

audio settings and turned everything off then back on, but still no sound.

 

Any ideas?


iPhone 3GS, iOS 4.3.2
  • OzziesMAC Level 2 Level 2 (150 points)

    I saw in another link to vacuum the dock connector which I just did and thats not working either.

    If I connect it to my sound dock it works just fine as well as headphones, just not a dang sound out

    if its internal speakers.

     

    The ringer is dead as well so that kills my phone.  Out of ideas now.

  • Caessar87 Level 1 Level 1 (0 points)

    I'm going through the same. My iPhone 4s is not emitting any sound through the internal speakers, but the headphones work fine. It is very weird because the volume control disappeard from the "now playing" screen when playing music and the same happens with every video. The volume buttons are not working at all but it is not a mechanic failure since they work fine with the headphones. I'm going crazy, all the Apps lost their sounds, this is very wrong! And of course is not the mute switch, that was the first thing I tried

  • 3gs iphone Level 1 Level 1 (0 points)

    i think apple should look into this problem. especially to those who upgrade their IOS. not just let us the end user to discuss and expect to find out solution.