Previous 1 2 3 Next 72 Replies Latest reply: Feb 29, 2016 6:11 AM by squirrelonfire
leon21 Level 1 Level 1

2.4 GHZ intel core 2 Duo,  4GB Ram.


just click on a cell can take 1-3 min


if i need to change anything in a cell it can take any where up to 5 min (eg, changing melbourne to Melbourne)


ever worse if working of a server

MacBook Pro, Mac OS X (10.6.8)
Solved by Rodrigo Baltuilhe on Apr 20, 2013 1:10 PM Solved

This really solved my problem!!! Thanks!!

Reply by torasama on Jan 9, 2013 10:22 PM Helpful

I never had any problems with Excel until I got a new Macbook Pro over the holidays (Jan 2013) with Mountain Lion pre-installed.  Then Excel just began running incredibly slow as everyone here has experienced.


It definitely seems to be a Font related problem, and since I could create a new user on my machine and Excel ran fine from that login, I did some detective work with fonts and worked out a way to strip down fonts in my regular account log in.


Keep in mind that I don't do any work with fonts really, so it didn't matter to me if I lost any special fonts because I never actively installed any...just accumulated alot of extra fonts over the years from various apps and rolling my data over through multiple Macbook incarnations.


This is how I got everything running at normal speed again.


1) Open Font Book Application




3) Automatically resolve any duplicates found


4) Select all fonts, then under FILE select VALIDATE FONT


5) Remove all fonts showing any type of error or warning.  Some will be system fonts and will require you to enter your password…go ahead and do it…get them all out of your system.


6) Under FILE, select RESTORE STANDARD FONTS.  This will pull out everything except standard fonts.  You will probably get a message saying that some of the standard fonts are missing and asking you to restore them by reinstalling the operating system…don't bother doing it though.  The missing fonts are likely ones that got tossed out when you VALIDATED FONT and threw out the ones causing warnings/errors.


7) Open your OS Library and look for the FONT folder.  You should also see FONTS (REMOVED) and FONTS DISABLED.  Open the FONTS (REMOVED) folder and find the MICROSOFT folder.  Drag this back into your FONTS folder…it will proceed to copy over. i.e. a copy will remain in FONTS (REMOVED) and a new copy will be formed in FONTS.


8) Finally, for good measure use Disk Utility to repair disk permissions and then restart.


This processed worked on my brand new Macbook Pro running Mountain Lion, as well as my wife's 2 year old Macbook Pro running Mountain Lion.


I spent 3 hours searching forums and testing things yesterday and this finally worked...hopefully it can save others from wasting as much time as I was forced to.

Reply by sig on Jul 18, 2011 7:36 PM Helpful

The version of MS Office you don't mention. In any case post to the MS support:

All replies

Previous 1 2 3 Next