Previous 1 2 Next 28 Replies Latest reply: Dec 13, 2011 8:34 AM by Nat Zammito
swiftorific Level 1 Level 1 (0 points)

After upgrading from Snow Leopard to Lion, IMAP to my office e-mail has stopped working in Mail.app. My g-mail and other organisation IMAP services are still functioning fine.

 

Asking around the office, this seems to be a common problem with Lion. Any ideas?

 

Many thanks.


Mac OS X (10.7)
  • leonino_c Level 1 Level 1 (0 points)

    Does you IMAP account have SSL encryption ? I have the same problem with mine.

     

    Looks like an horrible bug ?

  • swiftorific Level 1 Level 1 (0 points)

    It does but it happens with SSL on and off. My other IMAP accounts have SSL on and authenticate just fine.

  • johnfromluxembourg Level 1 Level 1 (0 points)

    have the same problem with my pop account

    I created a new account imap and taaadaaa it worked

     

    sending on pop was OK receiving is not working

  • steven228 Level 1 Level 1 (5 points)

    I have the same problem on an IMAP server I host for myself using SSL. From the server side it looks like the client drops -- from the Mail.app log it looks like the server rejects AUTHENTICATE PLAIN **** as having a bad argument.

  • thomasfromstratford Level 1 Level 1 (0 points)

    OK this worked for me so please give the 3 steps a try

     

    1. oppen mail

    2. click the show button on upper left hand side.

    3. you will see all of your mailboxes righ click or control click and pick the opption for "take all accounts online"

     

    That should fix your problem and your mailboxed should start to dawnload any new messages.

  • johnfromluxembourg Level 1 Level 1 (0 points)

    This was the first I tried :)

    But until now nothing helped

  • Tim O\'Connor3 Level 1 Level 1 (10 points)

    Had the same problem with one IMAP account... here's what my genius of an ISP guy told me:

     

    "go into the preferences in

    Mail and look at the settings, for the imap

    server and try turning off the "Use SSL", save it and see if it works.

     

    If it does, go back in and turn SSL back on.

     

    My theory is with the SSL cert, maybe it wasn't moved or another copy taken

    which is used to encrypt the connection."

     

    Worked for me! (Thanks Bruce)

  • swiftorific Level 1 Level 1 (0 points)

    steven228 wrote:

     

    I have the same problem on an IMAP server I host for myself using SSL. From the server side it looks like the client drops -- from the Mail.app log it looks like the server rejects AUTHENTICATE PLAIN **** as having a bad argument.

     

    You're absolutely right. Checking the log...

     

    READ Jul 21 07:55:53.774 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.myhost.com -- port:993 -- socket:0x7f97c7d5f220 -- thread:0x7f97ca65df60

    * OK [CAPABILITY IMAP4REV1 I18NLEVEL=1 LITERAL+ SASL-IR LOGIN-REFERRALS AUTH=PLAIN AUTH=LOGIN] mailsrv1.myhost.com IMAP4rev1 2007e.404 at Thu, 21 Jul 2011 07:55:53 +0100 (BST)

     

     

    WROTE Jul 21 07:55:53.778 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.myhost.com -- port:993 -- socket:0x7f97c7d5f220 -- thread:0x7f97ca8428a0

    1.15 AUTHENTICATE PLAIN ********************

     

     

    READ Jul 21 07:55:53.779 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:imap.myhost.com -- port:993 -- socket:0x7f97c7d5f220 -- thread:0x7f97ca8428a0

    1.15 BAD Missing or invalid argument to AUTHENTICATE

     

    So... how do we fix this?

  • steven228 Level 1 Level 1 (5 points)

    I think we open a bug report, or don't use SSL. Any other IMAP client will also work temporarily -- I downloaded http://sparrowmailapp.com/ and it works fine, so it's not an SSL or keychain issue, just a Mail.app issue.

     

    (I'm opening a bug report when I get some spare time today)

  • johnfromluxembourg Level 1 Level 1 (0 points)

    Thanks for all the answers..

    SSL was not helpfull with my account...

    deleting the account and created a new one ... and now it works

    strange

  • nojb Level 1 Level 1 (5 points)

    I have exactly the same problem (bad AUTHENTICATE PLAIN request).

    I have filed a bug report. This is a serious issue (especially

    if you don't have the option of _not_ using SSL).

  • bram_ltk Level 1 Level 1 (0 points)

    Good job! I never thought of quickly setting up an IMAP server and trying against it. So far, I have the same problem with my IMAP server at work.

     

    However, there is one issue: the connection to the MobileMe server (which is also IMAP) works perfectly.

     

    When investigating from the Connection Doctor, with the server from work I get this:

    CONNECTED Jul 21 11:02:28.233 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:mail.myhost.com -- port:993 -- socket:0x7f91b9d79540 -- thread:0x7f91b98514e0

     

    READ Jul 21 11:02:28.297 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:mail.myhost.com -- port:993 -- socket:0x7f91b9d79540 -- thread:0x7f91b98514e0

    * OK [CAPABILITY IMAP4rev1 UIDPLUS CHILDREN NAMESPACE THREAD=ORDEREDSUBJECT THREAD=REFERENCES SORT QUOTA IDLE AUTH=PLAIN ACL ACL2=UNION] Courier-IMAP ready. Copyright 1998-2008 Double Precision, Inc.  See COPYING for distribution information.

     

    WROTE Jul 21 11:02:28.302 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:mail.myhost.com -- port:993 -- socket:0x7f91b9d79540 -- thread:0x7f91b8541180

    1.19 AUTHENTICATE PLAIN

    With the server from MobileMe, I get this:

    CONNECTED Jul 21 11:02:28.515 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:mail.me.com -- port:993 -- socket:0x7f91b9e64f30 -- thread:0x7f91b9857670

     

    READ Jul 21 11:02:29.633 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:mail.me.com -- port:993 -- socket:0x7f91b9e64f30 -- thread:0x7f91b9857670

    * OK [CAPABILITY mmp0291 IMAP4 IMAP4rev1 ACL QUOTA LITERAL+ NAMESPACE UIDPLUS CHILDREN BINARY UNSELECT SORT CATENATE URLAUTH LANGUAGE ESEARCH ESORT THREAD=ORDEREDSUBJECT THREAD=REFERENCES CONDSTORE ENABLE CONTEXT=SEARCH CONTEXT=SORT WITHIN SASL-IR SEARCHRES XSENDER X-NETSCAPE XSERVERINFO X-SUN-SORT ANNOTATE-EXPERIMENT-1 X-UNAUTHENTICATE X-SUN-IMAP X-ANNOTATEMORE XUM1 IDLE AUTH=PLAIN AUTH=PLAIN] Messaging Multiplexor (Oracle Communications Messaging Exchange Server 7.4-20.01 (built Nov 21 2010))

     

    WROTE Jul 21 11:02:29.744 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:mail.me.com -- port:993 -- socket:0x7f91b9e64f30 -- thread:0x7f91b9cd9a60

    1.20 AUTHENTICATE PLAIN ****************************

     

    READ Jul 21 11:02:30.070 [kCFStreamSocketSecurityLevelNegotiatedSSL]  -- host:mail.me.com -- port:993 -- socket:0x7f91b9e64f30 -- thread:0x7f91b9cd9a60

    1.20 OK User logged in

    So, the AUTHENTICATE lines differ. I don't know what those '*'-s mean.

  • knhor Level 1 Level 1 (10 points)

    If you are using imap-uw / imapd-2007e, check here https://discussions.apple.com/thread/3191688?start=45&tstart=0

    I made a one line change in the imap server source, recompiled, and restarted to fix the bug.

  • acolin Level 1 Level 1 (0 points)

    I was having the same problem connecting to my employer's IMAP server. What Tim's IT guy suggested (toggling "Use SSL" on and off) seems to have solved the issue.

Previous 1 2 Next