Previous 1 2 3 Next 30 Replies Latest reply: Sep 18, 2013 10:09 AM by BIERRIA
pdellaert Level 1 Level 1 (0 points)

After installing Lion on my 27" iMac (jan 2011 model), i now can no longer login with my user... And yes, i have tried every password i have ever used on my iMac, several times.

 

I booted in single user mode and ran the commands:

/sbin/fsck -fy

/sbin/mount -uw /

and tried passwd <username>

 

got a nice error:

passwd: The daemon encountered an error processing request . The daemon encountered an error processing request.

 

/var/log/system.log shows (typing this over from my screen):

 

SecurityAgent[192]: User info context values set for USERNAME

SecurityAgent[192]: Unknown user "USERNAME" login attempt PASSED for auditing

UserEventAgent[11]: ServermgrdRegistration cannot load config data

UserEventAgent[11]: ServermgrdRegistration oldConfig is nil during net changed notification

 

 

It looks like it can not find my user...

 

 

Another thing indicating this, in single user mode:

ls -lha /Users/

...

drwxr-x---+ 501 staff 1.7k Jul 20 16:00 USERNAME

 

 

So, it is just completly unable to find my user

 

Another thing that suggests it lost all my users:

grep -Ri 'USERNAME' /etc/*

 

returns nothing... but that might not mean to much, as on my macbook, it doesn't either. And i can login there

 

Apple, *** did you do to my system?


iMac, Mac OS X (10.7)
Previous 1 2 3 Next