Previous 1 4 5 6 7 8 Next 174 Replies Latest reply: Jul 22, 2015 10:47 PM by QueenAvalon Go to original post
  • putnik Level 3 (780 points)

    Then Disk0s1 is the EFI volume. It just shows the importance of a correct installation procedure.


  • velofahrer Level 1 (0 points)

    Yes, that is indeed true and I assume it's the issue (footnote 1) at least in my case. 


    There's empty space at the front of the Macintosh HD partition that I presume used to be occupied by the EFI partition.  I can easily use iPartition to create an EFI partition in that space - the only question is, how do I fill it with content?  Of course I could reformat and use Disk Utility but that'll mean a complete restore from an image backup which I'm very keen to avoid.


    I have no idea what happened to the EFI partition but I suspect it had something to do with updating the firmware on the SSD - I'll have to look the next time I have to do it.  Oddly enough the mac boots fine without the EFI partition.


    Thanks for the help


    Footnote 1: Well, at least ONE of the issues, I'll fix this and see what happens next.

  • larsonski Level 1 (0 points)

    I had the same error that Mac OS X can't repair the disk Macintosh HD. I tried all the diskrepair and verify options, but nothing helped. The disk was locked so the only option for me was to reformat the drive.

    I used an external USB/FireWire 2TB disk, I installed a fresh copy of Lion on it and used it as a bootdisk. When I started Lion, it found the "old" internal HDD and came with the same message, but I was able to read the disk and copy everything to another external HDD.

    So now I can reformat my internal HDD and the do a new clean install of Lion and restore everything.


    It's not my prefered way of upgrading, but at least I have my data back and I have Lion.

  • Hellsum Level 1 (0 points)

    I had the same issue, and my partition was not a valid one to install Lion.

    I have 6 partions (OSX-W7-DebianRoot-Swap-DebianHome-MP3storage), and also refit on my hd.

    What I did was just burn Lion on a dvd, boot from it, shrink my OSX partition, repair permissions (only on osx partition), reboot.

    Voila, I am luckily installing Lion

    Hope it helps.


    Other stuff: I've upgraded my hd with a 500gb 7200rpm ssd hybrid, and my ram to 8Gb, so yes, you can install Lion on a non original HD.

    Also my OSX partition was 210Gb, now is 199,90~.

  • R C-R Level 6 (17,385 points)

    putnik wrote:

    Mind you, I would like to know what Disk0s1 is here, and how to remove it:

    Disk0s1 normally is the EFI partition. To confirm that it is, click on its entry in the Disk Utility list & at the bottom of the window you should see something like this:

    EFI info.png

    I strongly advise you not to remove the EFI partition. While it isn't used for anything during a normal startup into OS X, it sometime may be used as a transient location for Mac firmware updates, & if you ever decide to boot into another OS it may be used during its startup process.

  • Alexander Chan1 Level 1 (20 points)

    Ah, I dunno if you already solved your problem on this thread or another, I did get mine to work. At the very top of my boot disk (In the same area where you find Library, Users, Applications, etc.) was a folder called "backup.backupdb". Apparently that was the reason my computer/Lion saw it as a Time Machine disk.


    I just deleted it and the installer worked fine. Lion was a bit hiccupy during the Spotlight indexing process but it's running buttery smooth now!

  • Carlson Cabral Level 1 (10 points)

    Guys, this is getting a bit ridiculous! I tried Hellsum's solution and all I get is a "partition failed" message. It says that the file system could not be verified... I burned the install image to a DVD, booted using it and launched Disk Utility to do this. Nothing! What gives? Please hel!! I am starting to lose my faith in Apple. Again, I am using an OCZ 180 GB, firmware update 1.33 (latest). Thank you all.

  • Carlson Cabral Level 1 (10 points)

    Is this a hidden folder? I can't find this on my hard disk... This seems to be the solution that works well so far, but if I can't find it, or don't have it, what else can be done? Thanks.

  • R C-R Level 6 (17,385 points)

    velofahrer wrote:

    There's empty space at the front of the Macintosh HD partition that I presume used to be occupied by the EFI partition.  I can easily use iPartition to create an EFI partition in that space - the only question is, how do I fill it with content?

    Don't fill it with anything. As I mentioned elsewhere, the EFI partition is not used during a normal boot into OS X but may be used for things like as a temporary storage location for an Apple firmware update. So it may be empty to begin with, or whatever is there now may be overwritten as part of the firmware update process.


    BTW, the resize the OS X partition trick sometimes works because not all utilities that create or modify partitions on a drive formatted with the GUID Partition Table (GPT) partition scheme do so correctly (at least as far as the OS X installer is concerned). Slightly changing the OS X partition size using Disk Utility will rewrite the GPT scheme info, correcting most errors of this type. It doesn't matter how much you shrink (or enlarge, if that option is available) the OS X partition; the key is getting Disk Utility to rewrite the partition scheme.


    Technically, the GPT scheme info is not contained in a partition but in a specific, reserved section on the beginning logical blocks (LBA's) of the drive. Thus, it won't show up in Disk Utility. It only occupies 16KB so its presence is essentially undetectable by normal means.

  • Carlson Cabral Level 1 (10 points)

    Now, this is getting better by the minute. I fond the [in]famous Backups.backupsdb folder on my HD. Deleted it and the installer recognized the hard drive. Great, I thought. I started the installation to after abut two minutes into it, receive a message that the installation failed because the HD is damaged and cannot be repaired! Anyone experiencing the same issue?

  • R C-R Level 6 (17,385 points)

    Carlson Cabral wrote:

    Is this a hidden folder?

    The "Backups.backupdb" folder is at the root level of the volume & not normally hidden. It is created when a volume is designated for Time Machine backups (which normally occurs when a user chooses it in the Time Machine preferences).


    But only if the installer complains that the volume is being used for Time Machine backups will the folder be present & removing it solve anything. If you are not getting that error then something else is the cause of your 'can't install' problem.


    This topic now covers quite a few different situations. To save time & even more frustration, please read carefully to see if a suggested remedy applies to yours. For instance, if you have not used some non-Apple utility to create or modify the bootable partitions on your drive, the suggestions for that situation won't apply to you.


    Ideally, each situation should have its own separate discussion & each affected user should describe in detail anything that might distinguish it from the others. This makes it much easier to tell what might be causing the problem & to suggest applicable remedies. As it is, things are getting very confusing very fast.

  • R C-R Level 6 (17,385 points)

    Carlson Cabral wrote:

    I fond the [in]famous Backups.backupsdb folder on my HD. Deleted it and the installer recognized the hard drive.

    Do you mean before deleting the folder the installer would not recognize the disk at all, or that it was refusing to install the OS on what it said was a disk being used for Time Machine backups? Please be as specific as possible. This will help others trying to sort out which remedies are effective for which symptoms.


    I started the installation to after abut two minutes into it, receive a message that the installation failed because the HD is damaged and cannot be repaired!

    Try running Disk Utility's Repair Disk (not permissions) fix from your Snow Leopard install DVD. This should give you a specific error message if it fails (which unfortunately is what probably will happen). Report the error here. Some HD damage can be repaired with more powerful utilities like Disk Warrior -- Disk Utility will not try some repairs if there is a risk of data loss -- but depending on the error & extent of the damage you may have to reformat the drive to recover.


    Since that will erase everything on it, I hope you have good backups.

  • Carlson Cabral Level 1 (10 points)

    Yes, before I deleted the "Backups.backupsdb" folder, the installer would not recognize the drive. After I deleted it, it did recognize it and the installation proceeded. It rebboted the machine and the installation reported 30 mimutes remaining. Then I received that error message. As fate has it, I am outside the country now on business, and I don't have my Snow Leopard disk with me... I did back up using Time Machine before I left, so I am ok there, I suppose. In the event that I do really need to reformat, how do I install Lion then? I made an installation DVD, but I am not sure this will work to install the full OS... will this suffice? Thanks for trying to help.

  • Carlson Cabral Level 1 (10 points)

    Sorry I made a mistake in my previous message. The installer DID RECOGNIZE THE DRIVE but it said it was being used as a Time Machine backup drive.

  • Kaos2K Level 1 (0 points)

    Ok i have just solved the problem.



    I wanted to install Lion on my iMac 27 which had 6 partitions: EFI, Mac (HFS+), Storage (NTFS), Windows (NTFS), Linux root (ext4) and Swap in a triple-boot configuration all managed by reFit. Lion installer was giving me the same error as many of you are having "This disk cannot be used to start up your computer." I tried to resize Mac partition with Disk Utility with no luck because i got the already commented  error message "Partition failed: Mediakit reports no such partition" and some other annoying errors trying to delete or resize, repair or check for errors on the rest of the partitions. Uninstalling reFit was ok but didn't help to get the installer working. I tried to use Disk Utility booting from Lion boot DVD and nothing. But after all of that i found the solution.



    To get it working i used an Ubuntu 9.04 LiveCD, booted the iMac with it (Pressing and holding Alt key after the "Gong" sound), used Safe Graphics Mode to boot because graphic card didnt work well on Ubuntu (Press F4 in ubuntu LiveCD first screen). When Ubuntu was fully loaded i opened GParted (Partition Editor with GUI included in Ubuntu) and first of all i deactivated the Swap partition to been able to delete it, after that i deleted Windows and Linux root partition, leaving unused space unformatted (I was planning to format it later with HFS+ on Snow Leopard) , the only partitions i left untouched were EFI, Mac (HFS+) and Storage (NTFS). Quit Ubuntu an rebooted iMac, login in Snow Leopard, run to execute the Lion installer, no luck, went to Disk Utility, reduced size of Mac partition, executed Lion installer again and the magic appeared ¡¡¡NOW I CAN INSTALL LION!!! Went again to Disk Utility to leave the partition as it was after the resizing, went again to Lion installer and worked again.



    I hope this helps.



    By the way, i installed Lion with no problems on my MacBookPro which has the same partition scheme (reFit for triple-boot included) as my iMac except for the Storage partition which its file system is HFS+ instead of NTFS. I didn't have to delete partitions or do some weird stuff, just launched the Lion installer the first time and worked like a charm including reFit which it's still present at boot for selecting the OS i want to boot.

Previous 1 4 5 6 7 8 Next