Previous 1 2 3 Next 37 Replies Latest reply: May 29, 2014 3:34 PM by mcjudy
VirtualCheese Level 1 (0 points)

I have about 32 GB of space left on my hard drive running the latest version of Snow Leopard. Lion won't install because it says it can't create a recovery system. How do I fix this?


MacBook Pro, 17", 4GB RAM
  • rmorr Level 1 (20 points)

    Run "verify disk" from disk utility to make sure the disk is OK. I had this happen and used a boot disk to repair the volume. The install was fine after that.

  • VirtualCheese Level 1 (0 points)

    I just verified it and the disk is OK. I also have never installed Bootcamp and used this hd as the main  one. Upgrade to Snow Leopard went great. So, not sure what the issue is.

  • rmorr Level 1 (20 points)

    And that's the only partition?

  • Pondini Level 8 (38,740 points)

    The Recovery HD (partition, actually) is "carved out" of the end of your OSX partition.  It may be that some files are in the last few hundred MBs of the partition, so Lion can't use the space.

     

    I'd recommend waiting a bit, to see what other users find.

     

    You may have to make a "clone" of your OSX partition, boot up from it, erase the OSX partition, and clone back to it.  That will put everything in the first part of the partition.

  • VirtualCheese Level 1 (0 points)

    I thought so. But I have VMWare Fusion running. If that is the cause how would I deal with that?

  • Proggie Level 4 (1,300 points)

    I have the same problem. I don't have bootcamp nor any other partitions. I ran Disk Utility repair permissions before doing the install.

     

    diskutil gives me the following:

    diskutil list /dev/disk0

    /dev/disk0

       #:                       TYPE NAME                    SIZE       IDENTIFIER

       0:      GUID_partition_scheme                        *250.1 GB   disk0

       1:                        EFI                         209.7 MB   disk0s1

       2:                  Apple_HFS Macintosh HD            249.7 GB   disk0s2

  • Pondini Level 8 (38,740 points)
  • Proggie Level 4 (1,300 points)

    found this support article which claims you have to install it first on an external HD. What a pain!

     

    http://support.apple.com/kb/HT4718

  • Proggie Level 4 (1,300 points)

    For some reason on second install attempt it worked fine. I didn't do anything different except restarting after the first failed install, and then rerun Disk Utility and also running the Software Update and updating to a couple of the new for Lion updates (including Software Migration).

  • VirtualCheese Level 1 (0 points)

    I updated everything, verified the disk, fixed permission issues, got 32 gb of hd space and I still get the same message. This really reminds me of my windows days where for unspecified reasons stuff would not work.I have no idea what else to do or where to check. So far Lion is just a binary heap of junk. frustrated.

  • Roosevelt Jones Level 2 (380 points)

    You might try running the BootCamp Assistant to see if it has an issue creating a partition at the end of your disk drive. If there is not an issue creating the Windows partition, remove it using Disk Utility and see how the Lion installation behaves.

     

    I do not think my installation created the recovery disk, because I have a BootCamp partition and I used TechTools Pro to create its version of a recovery disk. All I got from the Lion installer was a warning that some features would not be available. It let me go ahead and install Lion.

  • Franz_P Level 1 (0 points)

    Hey all..

     

    Rosevelt Jones was right in my case.. So thanks rosevelt for the hint..:] Boot camp assistant wouldn't allow me to partition the disk and said that the disk needs to be formatted as macintosh journaled GUID which mine is.. I then used drive genius to look at the partitions and found one that was about 600MB and said that the format is unknown.. I deleted that partition which I suppose was a leftover from an earlier windows partition I had on that drive or something and now the installation works.. I would try checking your partitions with another program not disk utilities or boot camp assistant as they didn't show the actual partitions on my drive properly..

  • Pondini Level 8 (38,740 points)

    Franz_P wrote:

    . . .

    I then used drive genius to look at the partitions and found one that was about 600MB and said that the format is unknown.

    That sounds like your Lion Recovery HD

     

    Power down, then start up while holding down the Option key.  See if a Recovery HD is one of the options:

     

    shapeimage_1.png

  • Franz_P Level 1 (0 points)

    Ups..I meant Roosevelt jones of cours..

Previous 1 2 3 Next