Previous 1 2 3 4 Next 56 Replies Latest reply: Mar 12, 2013 9:10 PM by ionepoch Go to original post
  • SRGDC79 Level 1 Level 1

    So now I guess the question is do I re-do the install all over again to get it working? It seems that I have done this twice. When you change the computer name or something then it just stops working. No work around and a way to fix it. I might just go back to 10.6 and request a refund on the server part and wait for them to fix the issues.

  • Spinland Level 1 Level 1
    Mac OS X

    I actually just fixed this problem tonight. I ran the scripts contained in the folder called out in this thread:



    A couple turned out to depend on others in there, so at the end I just ran them again. When all was done my webmail started working and the errors in the Server App Wiki and Profile manager went away. Why those scripts don't get run at install time is beyond me.

  • Newtron40 Level 1 Level 1

    with regards to the


    sudo serveradmin command web:command=restoreFactorySettings


    from Apple, they suggested to restart the machine after the restore command, once back up turn off and then turn on web and then wiki. 


    Apparently in Lion, Wiki services do not require Web to run.  Totally separate.


    Worked for us.

  • andrew2011 Level 1 Level 1

    I have also had the 'Error reading settings' problem in Profile Manager, despite trying everything in the discussions and clean reinstalls (which work for a little while only).


    It seems that various different fixes work for some people but not others; and the underlying cause of the problem has not been resolved.


    There are now numerous threads on this problem (there are yet others with similar problems):



    I have posted this in each to try and pull things together a bit.


    Does anyone know if Apple has acknowledged the issue and offered an official response?

  • Engender Level 1 Level 1

    I got the 10.7.2 update and the Lion Recovery update, ran "verify permissions" from the lion recovery partition, and my Profile Manager is still giving me the "error reading settings" error.


    Supposedly, the Lion Recovery update is supposed to have some fix for problems with the Profile Manager but, in my case at least, it's not through verify permissions. Does anyone have any idea how Lion Recovery is used to or supposed to fix this problem?


    I've tried all the scripts to the best of my abilitys to no avail, for the record.

  • Miggl Level 1 Level 1

    For me none of the above solutions worked either. Then I tried a hunch:


    1. Toggle the selector in Hardware > Settings > Dedicate system resources to server services.
    2. Make sure the settings take (wait until the spinning gear at the bottom right is done).
    3. Toggle the selector to be checked, if not already checked.
    4. Enable all your desired services.


    After I did that everything seemed to work much smoother. Perhaps Apple "fixed" the previous issue with this setting.



  • Engender Level 1 Level 1

    I solved my problems with a dirty re-install of Lion. On my Mac Pro, I cloned my harddrive to an internal drive. Then, I logged into the Lion Recovery partition and erased my boot drive. I reinstalled Lion, and imported all of my files from the clone of my boot drive through the process. This brought everything with it except for Lion Server. I had a "?" on my dock where used to be. After doing a full time-machine backup and cloning my Server-free harddrive to an external drive, I reinstalled Lion Server from the App Store. Ta-da! No more errors in Profile Manager or Wiki.


    If you're sick of it, like I was, I would suggest the dirty resintall. Especiallly if you've got a Mac Pro and you can clone your HD to an internal drive, which makes the process take a couple of hours rather than the four or so with firewire drive.

  • Miggl Level 1 Level 1

    Quick update: this didn't work for me. The problem re-emerged today. I think I will take Engender's route and reinstall -- for the billionth time. I still cannot believe how crappy LION SERVER is, compared to how good SNOW LEOPARD SERVER ran.

  • Miggl Level 1 Level 1

    Ok, so I now tried a dirty reinstall using the restore-from-time-machine-backup-after-clean-install method when promtped to do so during the setup process. What a waste of time. After completing the restore and installing Server app and Server Admin tools, my server was completely hosed. All my users were missing, all the bad server settings seemed to be saved, but Open Directory had set itself up as a completely different animal, and no longer worked the way it did before.


    I am now forced to do a clean reinstall, reconfigure all the settings from scratch, then migrate all the data manually. WHAT A FRIGGIN PAIN IN THE ***, APPLE!!! WHAT THE **** WERE YOU DOING?


    How is the server restore process supposed to work? Am I missing something? My experience with LION SERVER, from release on, has been nothing but dissappointing.

  • Engender Level 1 Level 1

    Maybe you could try cloning your HD and then using it as the source of your dirty reinstall? I don't know why that would be any different than using a time machine back-up, but it may be in so far as what it brings over and what it doesn't.

  • and99 Level 1 Level 1

    Error reading settings on Wiki Server


    I just switched on the Wiki server and restarted Lion Server. The settings then worked fine for me. However if I switch off the Wiki Server the same problem occurs. I just leave Wiki server on when using Lion Server.


    This work around maybe useful for you.

  • Brett Higginbotham Level 1 Level 1

    This worked. Thanks

  • switchbacker Level 1 Level 1

    Upgrading to Lion borked my web sever. I'm happy to start from scratch.


    I ran "sudo serveradmin command web:command=restoreFactorySettings" but there was an error, something about virtual_host_global.conf" not being found. There was "virtual_host_global.conf.default" and two other variations, so I copied virtual_host_global.conf.default to virtual_host_global.conf and reran "sudo serveradmin command web:command=restoreFactorySettings".


    Now, at least, I don't get an error message when starting There is a site listed, which surprises me because I thought I would be starting with a clean slate at this point. It's really confusing. There really ought to be a nice GUI for all this (the prior server admin app seemed to work fine).


    No real question here unless someone can exlain why there is still a site listed in

  • and99 Level 1 Level 1

    The easiest thing to do is reinstall Lion Server.

    Go to-

    System/Library/Core Services/ serverversion.plist

    move serverversion.plist to trash   but keep to put back later

    Now move the server app from applications folder to trash

    Download Lion Server from the app store and run an install

    You will find services are configured afresh but it may not launch so just cancel at the end

    put back the serverversion.plist from the trash

    Open the applications window then launch Timemachine and restore the Lion server app.

    I used the Lion server app from last known good confuuration when it was working well.

    This procedure above works for me as a shortcut reinstall of lion server.

    Instead of using Timemachine you could try putting back the server app from trash instead. I have not tried that as I wanted the app itself from last known good confuration where it was working well in case the app itself has problems.

    The problems with Lion server in my experience that can occur are usually ones related to configuration of services it provides.

  • dypost20 Level 1 Level 1

    Make sure is closed for all of this.


    So, after extensively searching all over the web to fix the Profile Manager 'Error Reading Settings' issue, I had managed to fix the Wiki problem. This is a combination of many different posts. I'm hoping to save people time with this post.


    First things first, for me I had to uncheck Hardware>System>Dedicate system resources to server services then restart.


    To fix the wiki:

    sudo /System/Library/ServerSetup/CommonExtras/


    Then, to fix Profile Manager:


    sudo /System/Library/ServerSetup/CommonExtras/postgresqlextras/create_devicemgr_db.s h


    Then open


    I tried a bunch of things, so if this doesn't work, let me know. I may have missed something while I was reading posts for 6 hours.