Previous 1 2 3 4 Next 56 Replies Latest reply: Mar 12, 2013 9:10 PM by ionepoch Go to original post
  • °Bernz° Level 1 (10 points)

    Like all of you, I'm a "me too" person. Me too, I believe Lion Server is awful.


    Anyways, to try to assist, I've noticed in my case that one of the culprits is postgreSQL.... There seems to be a bad (very bad) configuration around it. Did they put a newbe on this??


    So, after having terrible "Error reading settings" errors, I've run the following script:




    This solution comes straigt from thread:


    Good luck to everyone, this is really a doozy...

  • rhej Level 1 (0 points)

    You are a life saver!  I had this issue and vaguely remembered there was a reset command but couldn't remember it for the life of me.  After seeing your reminder, I backed up my current /etc/apache2 directory, did an "apachectl stop" followed by "sudo serveradmin command web:command=restoreFactorySettings" and all was happy again.  After I verified all was working, I then reapplied my customizations, restarted apache using serveradmin stop/start and all is once again well in the world.  Thanks!

  • Level 1 (0 points)

    And that fixed the last of my server problems!  All the new Lion features now work!

  • Jade Curtis Level 1 (80 points)

    After running this command I get the error no files or folders.  What might be causing this error? I also go the error

    reading setting on server, when clicking on web server.

  • Randall Newman Level 1 (10 points)

    Thanks Alexander,


    Your solution fixed my problems



  • SRGDC79 Level 1 (5 points)

    Is there still issues with this even with the udpate? I need to know because I was going to start testing again to see if it will work.

  • hiveadmin Level 1 (0 points)



    I found this thread after suffering this effect on all but two of my services in I have only recently installed OSX Lion Server 10.7.4 (clean on a brand new MBPro) and was in my initial config phase.


    During this period I decided to change the hostname to an “FQDN” to provide the full range of remote connectivity options. It didn’t happen immediately but I ended up with the dreaded “Error Reading Settings”.


    While looking around I found a post by “Miggl” referring to the checkbox under Hardware/Settings/Dedicate system resources to server services. I remembered having checked this the day prior so I returned to it to do as recommended and “toggle” it.


    Upon attempting this it advised me, as it had originally, that this change would require a restart to take effect. I had chosen previously to “restart later”.  Having not restarted the first time I chose to do so now as I was in troubleshooting mode.


    Once the computer came back up I had lost a number of insignificant customizations I had made to the UI, and I had to re-install but the hostname change persisted and all the services are once again available for activation.


    I read all the other fix recommendations but did nothing until I came upon this and without modding config files and suffering some of the other side effects I read about throughout this thread, I was able to achieve resolution as described.


    Though my circumstances were not identical to “Miggl’s” there were associated and fixed through this investigation, so either of these situations sounds like yours, give it shot, it worked for me. Good luck and thanks to the community for “staying classy”!

  • Miggl Level 1 (75 points)

    Hi hiveadmin,


    I'm glad my partial solution helped you out. I ended up with some other issues after that and ended up reinstalling from scratch. I have found that to be the only real solution thus far. I'm waiting to see if Mountain Lion Server runs smoother. Lion Server seems has that Vista after taste to it.


    Good Luck!


  • chimpster07 Level 1 (0 points)

    I just went through the process of creating a RAID 1 using two of the drives in my Mac Pro Server and then restored the system from the last time machine back-up on my external. Now I'm trying to get profile manager back up and running but it keeps displaying ERROR READING SETTINGS  no matter how many times I run the terminal command fixes listed in the replies above. Does anyone have a sure way to get this service back up and running in the program so that I can continue installing trust and remote management profiles on end-user machines?


    Screen Shot 2012-07-02 at 11.56.33 AM.png

  • dmoakes Level 1 (0 points)

    Has anyone had this issue after installing aftermarket RAM? I upped the stock 4GB to 8GB (Crucial DDR3 PC3 10600) on my Mac Mini Server running 10.7.4 and things really haven't worked right since then. I spent several hours on the phone last week doing a reinstall and "proper" setup all on the stock RAM.


    Thinking things were working well a reintalled the aftermarket 8GB. Profile manager worked for about a day and then a got the "Error Reading Setings" message. I put the stock 4GB back in and Profile Manager sprung back to life.


    I'm working on returning the 8GB now...

  • Flynnsta Level 1 (10 points)



    Saw the exact same screen following the exact same procedure (except on late 2012 Mac Mini Server, 16GB after-market RAM, 2 x 1TB 5400rpm SATA reconfigured to RAID 1).  Baffled for a couple of days, but by chance noticed that in my Server | [hardware] | Overview tab, my server uptime was reporting something like "- 198,877 days."  With other supporting evidence that the date may be a contributing factor (as also seen in my PostGres error log following set up) I was getting the nasty "Error:    time zone displacement out of range:"


    That pointed me to the fact that I purchased and installed this system in Thailand, and the default Region settings reflected the Buddhist calendar (rather than Gregorian).  As the Uptime relfected, approximately 543 years in the future, not coincidentally the difference in the base year between the two calendars, it appeared that my self-signed certificate was invalid.


    I tried a lot of hand-editing and selective deleting, but eventually gave way to reinstalling ML 10.8.2 from scratch and subsequently re-adding  Ran it this time with US-default settings and EVERYTHING worked perfectly.  No intermittent pop-up errors indicating "Error reading settings" for Wiki.


    (And just a question of curiosity - has anyone else experienced Mac mini's COMPLETE INABILITY to boot from a properly-formatted USB or DVD?  And yes, it has GUID Partition, Mac OS Extended [Journaled], etc., that works on EVERY other Mac desktop/MacBook I have...  Drove me absolutely bonkers that I had to repeatedly re-install ML 10.8.2 using the Internet Recovery option - and while I'm at it, Apple, do you have any plans to beef up your Software Distribution servers is S.E. Asia anytime soon??? :-)

  • ionepoch Level 1 (0 points)

    dypost20 ...


    just spent a couple hours going through a bunch of  and  commands that did not work


    I stumbled across your post only after I found it.    I think the version I'm running may be newer than yours?  My folder paths are:


    /Applications/ tras/PostgreSQLExtras $ ls -la

    total 0

    drwxr-xr-x   4 root  wheel   136 Mar 12 20:40 .

    drwxr-xr-x  35 root  wheel  1190 Mar 12 20:40 ..

    -rwxr-xr-x   1 root  wheel   117 Mar 12 19:46

    -rwxr-xr-x   1 root  wheel   433 Mar 12 19:46



    I'm putting this here for others:




    I ran the following:


    **WARNING** this will reset your calendars, profile manager, and possibly a whole bunch of data on your server.   Make sure you know what you're doing and have adequate backups.



    cd /Library/Server/PostgreSQL\ For\ Server\ Services/


    mv Socket SocketOLD


    ln -s /private/var/pgsql_socket/ Socket


    serveradmin stop postgres

    serveradmin start postgres




    /Applications/ tras/PostgreSQLExtras/

    /Applications/ tras/PostgreSQLExtras/




    /Applications/ tras/




    /Applications/ sh




Previous 1 2 3 4 Next