Previous 1 2 3 4 Next 55 Replies Latest reply: Jun 12, 2012 4:52 PM by peppyspnkr
Max Velocity Level 1 Level 1 (0 points)

I just upgraded to 10.7 Lion and have the following problem.

 

Some times my Macbook Pro 13  (Mid 2010) don't let me control the volume with the vol up and down buttons. The speaker symbol appears

while pressing the buttons but the speaker is greyed out. While that, sound plays with the last adjusted volume.

 

Most times the problem appears after standby mode.

 

A restart don't help in my case! Sound settings are all correct. I tried to shut down, restart in Win 7 via Bootcamp, restarted in OS X Lion.

 

Still no sound control available :-(

 

So I've searched the web.. It seems the goal is to reset Core Audio Daemon :

 

Open Terminal, type in or copy :

 

sudo kill -9 `ps ax|grep 'coreaudio[a-z]' |awk '{print $1}'`

 

type in your password and confirm - voila : volume control works again!

 

But this is very annoying, because the last 5 years i've used os x  i've never had a problem like this!

 

Is this a known problem ? Any known workarounds or patches available ?

 

Hope anybody can help and/or Apple fixes asap!


MacBook Pro, Mac OS X (10.7)
Previous 1 2 3 4 Next