Previous 1 2 Next 20 Replies Latest reply: Jul 25, 2013 5:51 PM by FJRuiz
Stokesy Level 1 (0 points)

Hi i am unable to completel the import of old mail format and upgrade.  Error message says mail index is damaged.  Help!

Imac 24, Mac OS X (10.7), 4GB 800 MHz
  • designdirector Level 1 (0 points)

    Same here. I phoned Apple and they asked me to restart Mail. It tries to import messages but mine gets immediately stuck and is now saying there is 5000hrs remaining. Any suggestions anyone?

  • timothy adam Level 1 (0 points)

    I receive the following message when I launch Mail and try to upgrade/import:


    The import failed.

    An error occurred during the import.  Make sure you have available space in your home folder and try again.


    I looked in (in Applications/Utilities) and found the following error:


    Mail: Copy from /Users/myuser/Library/Mail/V2/MailData/Envelope Index to /Users/myuser/Library/Mail/V2/MailData/Envelope Index-4 failed with 14: not an error


    It continues to increment each time I attempt to run the import.  The file permissions on "Envelope Index" seem kind of interesting:


    myuser (Me) Read & Write

    myuser (Me) Read only

    everyone Read Only


    Compared to the permissions of the copies its made:


    myuser (Me) Read & Write

    staff Read Only

    everyone Read Only


    Does this mean anything to anyone?

  • timothy adam Level 1 (0 points)

    Thanks to deivy for pointing this out here.

    Mail uses files called “Envelope Index files” to keep track of messages in your local mailboxes. If there are problems with information in your mailboxes, you might see an alert message saying that Mail needs to repair your mailboxes by reindexing your messages for you.

    At other times, you may want to reindex messages yourself—for example, when searching mailboxes using Subject, To, or From doesn’t return the correct results.

    1. Quit Mail if it’s open.
    2. In ~/Library/Mail/V2/MailData, delete any file that begins with “Envelope Index,” such as Envelope Index or Envelope Index-shm.Your home Library folder is hidden by default. To display it, choose Finder > “Go to Folder” and then enter “~/Library.”
    3. Open Mail.Mail creates new Envelope Index files. This process may take a few minutes, depending on how many messages Mail is reindexing.

    Trashing the envelope files did the trick.  Although, I did try repairing my permissions that did not inevietably solve the issue.


    The new Mail is cool. 

  • Stokesy Level 1 (0 points)

    Hello - followed these instructions but each time a new Envelope Index file is created.  Still no luck!

  • David Hazinski Level 1 (35 points)

    I just went through this procedure and MAIL still won't launch. Get the spinning wheel of death. I get the dot in the dock that says it's running but it isn't. When I check "force quit", it says Mail isn't responding.


    In addition to getting rid of all these envelope files.... I had three, I also ran disk utility and restarted a couple of times. Nada.


    So how do we get this puppy running again?

  • ozwheels Level 1 (0 points)

    Deleting the "Envelope Index" files didn't work for me. I searched the Console log and found an error message saying the process didn't have permission to copy "~/Library/Mail/MessageSorting.plist". As it looks like this only sorts the messages - I deleted the file and the upgrade worked fine!!!!

  • elpelso Level 1 (0 points)

    Still no joy either.  When the envelope index file is deleted, Mail will start importing all the mail messages again (takes well over half an hour, since there well over 380.000)...  Then quits unannounced and unceremoniously at the 'optimization' stage...  Console logs yield this :


    21/07/11 13:42:52,639 Mail: Upgrading Library from 4.89 to 4.89

    21/07/11 13:43:00,394 Mail: Property list invalid for format: 200 (property lists cannot contain objects of type 'CFNull')

    21/07/11 13:43:29,692 Mail: *** Assertion failure in -[MFMailMigrator _migrateFromV1ToV2Layout], /SourceCache/Message/Message-1237.1/Library.subproj/MFMailMigrator.m:697

    MailAccounts were initialized before migration from V1 to V2!


              0   Message                             0x00007fff8386e4a9 -[MFAssertionHandler _handleFailureWithPreamble:description:arguments:] + 116

              1   Message                             0x00007fff8386e63f -[MFAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 185

              2   Message                             0x00007fff838724d8 -[MFMailMigrator _migrateFromV1ToV2Layout] + 392

              3   Message                             0x00007fff83870931 +[MFMailMigrator migrateFromV1ToV2Layout:isComplex:progressDelegate:] + 87

              4   Message                             0x00007fff8381fd00 -[LibraryUpgrader run] + 1590

              5   CoreFoundation                      0x00007fff88275c7c __invoking___ + 140

              6   CoreFoundation                      0x00007fff88275b14 -[NSInvocation invoke] + 132

              7   Message                             0x00007fff836bd953 -[MonitoredInvocation invoke] + 196

              8   Message                             0x00007fff8369a529 -[ThrowingInvocationOperation main] + 33

              9   Message                             0x00007fff8369a4cf -[_MFInvocationOperation main] + 449

              10  Foundation                          0x00007fff8c898554 -[__NSOperationInternal start] + 705

              11  Foundation                          0x00007fff8c8ab876 ____NSOQSchedule_block_invoke_2 + 124

              12  libdispatch.dylib                   0x00007fff8590190a _dispatch_call_block_and_release + 18

              13  libdispatch.dylib                   0x00007fff859027e9 _dispatch_worker_thread2 + 255

              14  libsystem_c.dylib                   0x00007fff8322f3da _pthread_wqthread + 316

              15  libsystem_c.dylib                   0x00007fff83230b85 start_wqthread + 13


    21/07/11 13:43:29,694 Mail: FileURLGetDYLDEntryPointWithImage(/System/Library/PrivateFrameworks/Librarian.f ramework/Librarian,LBGetAttributeValueForItem) failed.

    21/07/11 13:43:29,694 Mail: FileURLGetDYLDEntryPointWithImage(/System/Library/PrivateFrameworks/Librarian.f ramework/Librarian,LBGetAttributeValueForItem) failed.

    21/07/11 13:43:29,724 Mail: *** Assertion failure in -[LibraryUpgrader run], /SourceCache/Message/Message-1237.1/Library.subproj/LibraryUpgrader.m:547

    MailAccounts were initialized before the Library was ready!


              0   Message                             0x00007fff8386e4a9 -[MFAssertionHandler _handleFailureWithPreamble:description:arguments:] + 116

              1   Message                             0x00007fff8386e63f -[MFAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 185

              2   Message                             0x00007fff83820c39 __-[LibraryUpgrader run]_block_invoke_5 + 151

              3   CoreFoundation                      0x00007fff88238ecc __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 12

              4   CoreFoundation                      0x00007fff881f0fa2 __CFRunLoopDoBlocks + 322

              5   CoreFoundation                      0x00007fff88218a95 __CFRunLoopRun + 885

              6   CoreFoundation                      0x00007fff882183e6 CFRunLoopRunSpecific + 230

              7   HIToolbox                           0x00007fff843bfa1b RunCurrentEventLoopInMode + 277

              8   HIToolbox                           0x00007fff843c713d ReceiveNextEventCommon + 355

              9   HIToolbox                           0x00007fff843c6fca BlockUntilNextEventMatchingListInMode + 62

              10  AppKit                              0x00007fff8b11c6a9 _DPSNextEvent + 659

              11  AppKit                              0x00007fff8b11bfb0 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

              12  AppKit                              0x00007fff8b3d15fd -[NSApplication _realDoModalLoop:peek:] + 610

              13  AppKit                              0x00007fff8b3d1231 -[NSApplication runModalForWindow:] + 120

              14  Mail                                0x000000010a88a7c1 Mail + 1054657

              15  Mail                                0x000000010a88a679 Mail + 1054329

              16  Mail                                0x000000010a78d8a1 Mail + 18593

              17  Mail                                0x000000010a78d169 Mail + 16745

              18  Foundation                          0x00007fff8c866bba __-[NSNotificationCenter addObserver:selector:name:object:]_block_invoke_1 + 47

              19  CoreFoundation                      0x00007fff8822c88a _CFXNotificationPost + 2698

              20  Foundation                          0x00007fff8c852e6f -[NSNotificationCenter postNotificationName:object:userInfo:] + 65

              21  Mail                                0x000000010a78b961 Mail + 10593

              22  AppKit                              0x00007fff8b120c5e -[NSApplication _postDidFinishNotification] + 212

              23  AppKit                              0x00007fff8b1209c4 -[NSApplication _sendFinishLaunchingNotification] + 78

              24  AppKit                              0x00007fff8b11f735 -[NSApplication(NSAppleEventHandling) _handleAEOpenEvent:] + 242

              25  AppKit                              0x00007fff8b11f496 -[NSApplication(NSAppleEventHandling) _handleCoreEvent:withReplyEvent:] + 330

              26  CoreFoundation                      0x00007fff882762c1 -[NSObject performSelector:withObject:withObject:] + 65

              27  Foundation                          0x00007fff8c88966b __-[NSAppleEventManager setEventHandler:andSelector:forEventClass:andEventID:]_block_invoke_1 + 101

              28  Foundation                          0x00007fff8c8885f2 -[NSAppleEventManager dispatchRawAppleEvent:withRawReply:handlerRefCon:] + 283

              29  Foundation                          0x00007fff8c888480 _NSAppleEventManagerGenericHandler + 105

              30  AE                                  0x00007fff8ab53a91 _Z20aeDispatchAppleEventPK6AEDescPS_jPh + 200

              31  AE                                  0x00007fff8ab5396f _ZL25dispatchEventAndSendReplyPK6AEDescPS_ + 38

              32  AE                                  0x00007fff8ab53863 aeProcessAppleEvent + 250

              33  HIToolbox                           0x00007fff843ce631 AEProcessAppleEvent + 102

              34  AppKit                              0x00007fff8b11c8f5 _DPSNextEvent + 1247

              35  AppKit                              0x00007fff8b11bfb0 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135

              36  AppKit                              0x00007fff8b11895b -[NSApplication run] + 456

              37  AppKit                              0x00007fff8b3962ad NSApplicationMain + 860

              38  Mail                                0x000000010a862c3c Mail + 891964


    21/07/11 13:43:29,878 Mail: Error loading /Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAudio:  dlopen(/Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHD Audio, 262): no suitable image found.  Did find:

              /Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin/Contents/MacOS/DVCPROHDAu dio: no matching architecture in universal wrapper

    21/07/11 13:43:29,879 Mail: Cannot find function pointer NewPlugIn for factory C5A4CE5B-0BB8-11D8-9D75-0003939615B6 in CFBundle/CFPlugIn 0x7fe3d2d0f2f0 </Library/Audio/Plug-Ins/HAL/DVCPROHDAudio.plugin> (bundle, not loaded)

    21/07/11 13:43:29,902 ([0x0-0xe50e5][2325]) Exited with code: 255

  • macartz Level 1 (0 points)

    I have the same problem, I've tried all the above, nothing is working. I start mail and it begins import, fails, says it's corrupt, then tries again. Only this time doubling the amount of files it's trying to import, after trying this 6 or 7 times, it's now trying to import over 300,000 emails. Great!

  • Stokesy Level 1 (0 points)

    Just tried again copied the following from console


    21/07/2011 18:24:38.845 Mail: Upgrade failed because of exception: While copying non-account files, could not copy /Users/David/Library/Mail/MessageUidsAlreadyDownloaded3 to /Users/David/Library/Mail/V2-Temp.noindex/MailData/MessageUidsAlreadyDownloaded 3; ERROR: Error Domain=NSCocoaErrorDomain Code=513 "“MessageUidsAlreadyDownloaded3” couldn’t be copied because you don’t have permission to access “MailData”." UserInfo=0x108bf4b30 {NSUserStringVariant=(


    ), NSDestinationFilePath=/Users/David/Library/Mail/V2-Temp.noindex/MailData/Messag eUidsAlreadyDownloaded3, NSFilePath=/Users/David/Library/Mail/MessageUidsAlreadyDownloaded3, NSUnderlyingError=0x108bc7ad0 "The operation couldn’t be completed. Permission denied"}

  • David Hazinski Level 1 (35 points)

    I finally got it working. Moved everything in the mail library, then had it rebuild itself. Whatever the issue was, it was in converting over my old index. But this got the mail app working, which is what I was looking for.


    I moved everything over to make sure I didn't throw away important stuff, then deleted the files once it had reloaded.


    But a fix. It's working. Hope this helps.

  • Stokesy Level 1 (0 points)

    Thanks David - this also worked for me.  Copied to Mail folder onto desktop and open mail icon - whcih rebuilt the mailbox.  Works!

  • elpelso Level 1 (0 points)

    After contacting Apple tech support, their final suggestion was also to move the Mail folder from ~/Library (folder which is invisible under Lion, have to navigate to it first via Finder's Go To Folder command) to e.g. the desktop, and then launch Mail.  All accounts and rules were kept (although the rules were unchecked).  Then, after Mail was up and running, via the import mailbox command, I was told to re-import all my old .mbox mailboxes.  Tedious, and had to re-arrange all my mailboxes again (as Mail imports them into an 'import' folder), but at least it's up and running...  Far from elegant, though... 

  • macartz Level 1 (0 points)

    I was able to fix my problem. The email import doubling each time I tried to convert my email was due to my RSS mail folder. Once I deleted it, it stopped and had the correct number of emails to import. I was able to bypass the import by creating an empty folder in my mail titled VN, I was then able to start mail and then imported my mail boxes.

  • rainbow robin Level 1 (0 points)

    My mail problem is that the Sent folder in Lion Mail does not allow me to import my old sent folders (I had one for each of my mailbox accounts which automatically added new emails that I sent). Mail now only shows my mailbox without the ability to create new Sent sub-folders. Suggestions anyone?


    I think I have the solution now. I have sent an email from each email address and this automatically creates a Sent sub-folder for that email address. I'm now going to retrieve the old sent emails from Time Machine


    Message was edited by: rainbow robin

Previous 1 2 Next