Previous 1 2 3 4 5 6 Next 83 Replies Latest reply: Jun 25, 2014 1:20 PM by a_hosney Go to original post
  • ChasteDylan Level 1 Level 1 (0 points)

    Here's how I fixed it...

     

    I had same problem on MacBook and MacPro. Not just dedktop backgrounds but all preferences.

    Lion worked fine for a day then I was changing the sharing prefernce and that seemed to trigger the bug.

    As I ran different software some preference seemed to change but then after restart were gone...with Adobe product I couldn't save projects because for some reason every time you save a project it alters the preferences file which was locked. I tried changing permissions for the entire preferences folder and that didnt work...So every time I needed to savea project I had to delete the relevant preference file and then save. Needless to say it didn't take long before I was banging my head off a wall because that was less damaging to my being.

     

    I was just about to give up when I tried changing the permission for the entire users folder and it was all plain sailing from there...

    D

  • drsjs Level 1 Level 1 (0 points)

    Great fix!  Works on MacAir as well!

  • etkal Level 1 Level 1 (20 points)

    Does anyone know how to enable (in Lion) *both* the right-click *and* two-finger tap for the secondary mouse click?  I like using the two-finger tap, but I also often revert back to trying to right-click since I also use Windows machines.  However, the Lion trackpad preferences no longer has separate sections for clicking in general and secondary click, so I can't seem to enable both triggers...

     

      <ET>

  • Mr. Dakota Brower Level 1 Level 1 (0 points)

    Thank you Maxym. You just saved me hours of frustration. Truly appreciate it.

  • panayotis tse Level 1 Level 1 (0 points)

    works fine!!!! thanks Maxym!

  • JohnMK Level 1 Level 1 (0 points)

    Thanks for your slightly impatient attempt to explain.  I do appreciate your trying explain this terminal command stuff.  I tried to follow your instructions to the 't'.  Unfortunately, no joy.  I am probably missing some very basic element that was assumed.  Guess, I have to wait till Apple makes the fix for dummies like me.

  • Ragnar-Kon Level 1 Level 1 (20 points)

    Yes I'll agree that it was was slightly impatient attempt. I support Macintosh PCs for a living at a university, and sometimes tech support can be... frustrating. The day I wrote that happened to be one of those frustrating days.

     

    I made a video of the process for employees here at the university. If I have extra time later this week I'll remove the university-specific instructions and post a link to the video.

  • JohnMK Level 1 Level 1 (0 points)

    Ragnar-Kon,

     

    I was able to finally solve the problem after trying various permutations of the process.  Winning strategy:  I unclicked all the boxes in Preferences. logged out/in -then went to terminal and added the command line and <entered> before closing (which I hadn't done before).  logged out/in then went to Preferences and the 'secondary click' was already checked (good sign).  I checked the others and "voila" just as you said.

    I also instruct, and I am very aware of my own limits of patience. 

     

    Thanks for your efforts.  No offence taken, nor meant.

     

    Apple Discussions has saved me much time and energy over the years.

  • jonfromsuwanee Level 1 Level 1 (0 points)

    I have a brand new MBP shipped with this issue from Apple.  I tried unclicking the secondary click box and executing the "defaults" command in the terminal, all to no avail.  Any other ideas?

  • jonfromsuwanee Level 1 Level 1 (0 points)

    OK, Lion works differently from Snow Leopard on the secondary click, at least for me.  I have a 2 year old MBP with Snow Leopard, and to perform the secondary click, I just tap with two fingers.  I tried the suggested fixes to no avail.  I called Apple support, and after futzing with it for a few minutes, he suggested I use two fingers and actually click the trackpad (push it down).  It worked.  I tried it on my older MBP with SL and it works there as well.  I wonder why they changed it?  But I'm happy it works.

  • basman9000 Level 1 Level 1 (0 points)

    Thank you

    You Are The Man

  • RitGZ Level 1 Level 1 (0 points)

    Hey mark ! I am facing the same issue, did you get any solution ?

  • andreyp Level 1 Level 1 (0 points)

    I have early 2008 MacBook Pro 15.4 inch and after installing OS X Lion right click was not working.  First I went to system preferances - mouse and didn't find anything to enable  or turn on RIGHT click.  

     

    After reading this forum I realize that to enable RIGHT click I have to go to system preferances -trackpad   (not MOUSE menu).

     

    When I went to Trackpad menu  I changed Secondary click from "tap with two fingers" to "tap in the bottom right corner" and it works PERFECT.  I don't understand why write script in TERMINAL...????

     

    /___sbsstatic___/migration-images/migration-img-not-avail.png

  • marianmi Level 1 Level 1 (5 points)

    Obviously you have a newer Macbook Pro, you sure it's early 2008?

     

    Early 2008 Macbook Pro do not have only trackpad like in the figure above, but have trackpad + button (see http://en.wikipedia.org/wiki/File:MacBook_Pro_situated_on_a_wooden_table.jpg). You cannot click on the trackpad, only on the button. Also, the button is only for left-clicking, the hardware cannot detect if you click on left or right corner.

     

    We have only 1 option in the menu you highlighted (Click or tap with 2 fingers) and that option was not working for us since the preference was not saved (or the file was being corrupted). Thus only with the terminal command the preference was saved in the config file, and we could right click.

     

    I do believe you have a 2009 macbook pro (at least), that's the year they started shipping buttonless trackpads if I am not mistaken.

  • Gaurav_juventeous Level 1 Level 1 (0 points)

    guys

     

    iam having the same problem with my macbook 4, 1 (white body, older trackpad having single button)

     

    first is that either i am not able to properly excute the terminal commands... but i have tried every possible way ,,, and still got no luck with the secondary click thing

     

    2) i deleted all the preference and preferencepane folder items , still it wont work

     

    3) i opened a new user account ... and it worked like magic

     

    now i dont know how to migrate all the data my admin account to the newly created user account

     

    can u guys suggest some tricks... so that i transfer/move all my data my admin account to the new user account then delete the old admin account and make the user account as my new-admin account...

     

    desparately looking for help

     

     

    Gaurav

    macbook 4,1

    using dumb Lion