4 Replies Latest reply: Jul 21, 2011 8:13 AM by nojb
leonino_c Level 1 Level 1 (0 points)

Hi !

 

Just after upgrading to Lion, I started Mail just to find out that it is now unable to connect to my IMAP account. It continues to ask the password lamenting the impossibility to login correctly. The account is protected through SSL and a simple username/password authentication scheme. It worked as a charm till the upgrade.

 

Note that also other software (e.g. Direct Mail) that tries to access the same imap server fails in the same way as Mail does. The console doesn't seem to show any specific message.

 

Ideas ?


Mail, Mac OS X (10.7)
  • 1. Re: Mail and SSL IMAP
    smamols Level 1 Level 1 (0 points)

    I am having issues also after Lion upgrade with my mail.

    AOL and Gmail are fine, but my MS Exchange account is horrible.  Account now appears twice, signature would not work (finally fixed by adding it to "both/duplicate" accounts") grouped messages do not appear as they should, or do in the other accounts, messages load slow.  So far this aspect of Lion is terrible.

    It also asks for my password multiple times.

  • 2. Re: Mail and SSL IMAP
    steven228 Level 1 Level 1 (5 points)

    I have the same IMAP/SSL configuration and the same problem. My iPad and iPhone can connect to it fine, as could Mail.app in Snow Leopard.

  • 3. Re: Mail and SSL IMAP
    bram_ltk Level 1 Level 1 (0 points)

    I subscribe to the above problems. When I try to connect to the mail server at my job (IMAP) using SSL (993), the connection fails. However, when I am in the intranet and I switch to the non-SSL connection (available only from the inside on port 143), the connection succeeds.

     

    Everything worked fine until I upgraded to Lion. And everything works fine on the iPhone / iPad.

     

    I tried creating the account from scratch, even logged in as another user (I thought that maybe there were some caching / certificate problems). Still the same behaviour.

     

    Help?

  • 4. Re: Mail and SSL IMAP
    nojb Level 1 Level 1 (5 points)

    This is not an isolated problem. People in another thread have the same problem: <https://discussions.apple.com/thread/3188992?start=0&tstart=0>.

    It seems IMAP/SSL sends a malformed authentication request in some cases. The problem seems

    to go away if you don't use SSL.