Previous 1 2 3 Next 34 Replies Latest reply: Jul 25, 2012 2:32 PM by gbrissey
mrmamba Level 1 Level 1

After upgrading to Lion 10.7 refuses to start.

MacBook Pro, Mac OS X (10.7)
  • jmarcus Level 1 Level 1

    Same here. The upgrade/conversion process starts but then fails.


    Any ideas?

  • Thespenny Level 1 Level 1

    For me, it crashes when opening Preferences in Mail. Been unable to have much success with Mail.

  • mrmamba Level 1 Level 1

    Fixed launching from the terminal:


    cd /Applications




    If that works, remove the mail icon from the dock and put it back again

  • brandon_in_seattle78 Level 1 Level 1

    My mail is failed during the upgrade (hung while creating conversations). I had to force quit it.    Then it went through all the way when I tried it again.  But now, mail won't start up and doesn't respond every time... I tried what you suggested and got:

    BM:Applications brandonm$ ./

    2011-07-20 12:05:57.730 Mail[550:d103] No Info.plist file in application bundle or no NSPrincipalClass in the Info.plist file, exiting

  • bossmann Level 1 Level 1

    i had the same problem.  I went to preferences, clicked on Mail, Contacts & calendars.  Mail & Notes was unchecked and once i checked it all 4 of my email accounts appeared.  when i launched Mail everything was back to normal. 


    Hope that works for you as well. 

  • lizesqe Level 1 Level 1

    I have the same problem.  Message just says -- mail "cannot be opened because of a problem" and suggests I contact the developer or possibly reinstall app -- which I cannot do because my original is misplaced somewhere in physical files.


    Can anybody help?  Fortunately,I can get mail off my iPad and iPhone, but what a pain.


    Have MacBook Pro Intel Core 2 Duo purchased last Spring.  So sorry I downloaded Lion.

  • timothy adam Level 1 Level 1

    I receive the following message when I launch Mail and try to upgrade/import:


    The import failed.

    An error occurred during the import.  Make sure you have available space in your home folder and try again.


    I looked in (in Applications/Utilities) and found the following error:


    Mail: Copy from /Users/myuser/Library/Mail/V2/MailData/Envelope Index to /Users/myuser/Library/Mail/V2/MailData/Envelope Index-4 failed with 14: not an error


    It continues to increment each time I attempt to run the import.  The file permissions on "Envelope Index" seem kind of interesting:


    myuser (Me) Read & Write

    myuser (Me) Read only

    everyone Read Only


    Compared to the permissions of the copies its made:


    myuser (Me) Read & Write

    staff Read Only

    everyone Read Only


    Does this mean anything to anyone?

  • alanfromkaty Level 1 Level 1

    "I have the same problem.  Message just says -- mail "cannot be opened because of a problem" and suggests I contact the developer or possibly reinstall app -- which I cannot do because my original is misplaced somewhere in physical files"


    ditto!  What a pain!

  • timothy adam Level 1 Level 1

    Thanks to deivy for pointing this out here.

    Mail uses files called “Envelope Index files” to keep track of messages in your local mailboxes. If there are problems with information in your mailboxes, you might see an alert message saying that Mail needs to repair your mailboxes by reindexing your messages for you.

    At other times, you may want to reindex messages yourself—for example, when searching mailboxes using Subject, To, or From doesn’t return the correct results.

    1. Quit Mail if it’s open.
    2. In ~/Library/Mail/V2/MailData, delete any file that begins with “Envelope Index,” such as Envelope Index or Envelope Index-shm.Your home Library folder is hidden by default. To display it, choose Finder > “Go to Folder” and then enter “~/Library.”
    3. Open Mail.Mail creates new Envelope Index files. This process may take a few minutes, depending on how many messages Mail is reindexing.

    Trashing the envelope files did the trick.  Although, I did try repairing my permissions that did not inevietably solve the issue.


    The new Mail is cool. 

  • exfan Level 1 Level 1

    Tried the solution but did not work.


    I only get a blank window now (well grey) no messages, nothing.


    So frustrating!

  • brandon_in_seattle78 Level 1 Level 1

    I basically started new.


    What I did was log into the terminal window,


    cd Library

    mv Mail ../Mail.old


    Then restart mail, and then did an import of the Mail.old directory.


    Not really ideal since now I have to rearrange folders, etc.  But that solved my problem and I was able to use mail and get all my old folders back in there.

  • Smilingman Level 1 Level 1

    Heres what i did:

    Read a couple of post in here. Somebody wrote something about opening in terminal and stuff, didnt get that BUT he alsp wrote remove from dock, so i did.. Then i openen mail fra the app folder and it worked! Took a minutte while updating and so, but no problemo. It found all my email fram imap server and all my old emails on my harddrive not saved somewhere up there in the sky...


    Did the same with adress book and my calender... Everything is fine but for 5 minuttes there i almost started screaming and finding ways of killing my computer.

  • The Ambassador Level 1 Level 1

    I did the Find the Library and remove the Envelope file thing - and I am good to go! Thanks!

  • dextrogiro Level 1 Level 1

    I had the same problem. The fact is that all apps presente before upgrade in /Applications were moved to /private/var/stash/Applications, those include all Apple applicacions as well as all the other. When trying to start from the dock any system app (mail, ical,...) you will get the error "cannot be opened because of a problem" as it tries to open the wrong version of the app. The correct version of te apps is located (as expected) under /Applications but none of your previously installed apps will be there. Actually the Applications link of the Sidebar (in Finder) pints the this wrong path (/private/var/stash/Applications).


    This definitely a bug, but cannot get how could this happen to one computer (Macbook Air) as the other one a Macbook went through the upgrade spotless.





Previous 1 2 3 Next